Page 1 of 1

"starting the service providing vpn connection failed"

Posted: Thu Nov 09, 2017 9:30 am
by jameswon
OS: Mint 18.2, KDE

Hello, I am trying to setup a vpn connection using the network manager. Upon clicking "connect" and input the password, I always get the pop up error from sys tray "starting the service providing vpn connection failed".

Thank you for any advice.

Re: "starting the service providing vpn connection failed"

Posted: Thu Nov 09, 2017 9:57 am
by sammiev
What vpn provider are you using?

How did you set it up?

Please supply a link to the instructions used.

Re: "starting the service providing vpn connection failed"

Posted: Thu Nov 09, 2017 11:56 am
by jameswon
sammiev wrote:What vpn provider are you using?

How did you set it up?

Please supply a link to the instructions used.
Hello, I'm using this instruction except that mine is KDE: https://support.goldenfrog.com/hc/en-us ... ux-Ubuntu-

Re: "starting the service providing vpn connection failed"

Posted: Thu Nov 09, 2017 2:30 pm
by sammiev
I was going to try them out for free, but it still wants a credit card.

The one item I noticed was that the cert file is not in /etc/openvpn it's in /home/{user_name}/ directory.

Other than that the rest is straight forward.

Re: "starting the service providing vpn connection failed"

Posted: Fri Nov 10, 2017 5:11 am
by jameswon
Copied the .crt to /etc/openvpn but it's the same problem.

I just tried on my openSUSE system and found that it might be related to LZO compression under advanced options of openvpn settings.

If that option is not ticked, vpn connection will try to connect but end up in timeout. If it's ticked according to the instruction, it fails with the said error immediately.

Re: "starting the service providing vpn connection failed"

Posted: Fri Nov 10, 2017 9:48 am
by greerd
Can you ping your designated server? e.g. ping -c3 us1.vpn.goldenfrog.com
Also, I noticed in the tomato setup they use port 443 so you could try adding :443 to the end of your gateway.