LM 18.2 Cinnamon and Bluetooth

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
lifeson
Level 1
Level 1
Posts: 4
Joined: Wed Nov 15, 2017 6:15 pm

LM 18.2 Cinnamon and Bluetooth

Post by lifeson » Wed Nov 15, 2017 6:33 pm

Hey All...

LM and Bluetooth have been a long, winding road for me.
I really love Linux Mint, Cinnamon and have been loving (and learning to handle it more and more, with lots of salt-grains, though) over last few years.

Today, being so happy for few weeks about my newly installed version of LM 18.2 Cinnamon 64 bit on an old laptop, especially the enhanced bluetooth functionality of LM 18.2 --- I commited a seemingly huge mistake (again, and again.....):

Allowing the OS-implemented software update, to trigger an update of glibc (level 3 update, in update manager). It included "locales", "libc-bin", and "multiarch-support" packages, version updates from 2.23-0ubuntu7 to 2.23-0ubuntu9, and my bluetooth audio speakers went down again (after soooo many(!!!) previous experiences w. older versions of LM Cinnamon before. SOS.

Is there any way to revert this, except for a complete re-install, which may take days again?

Surely appreciate some insight to this, many thanks!

(Other than that, I still think LM Cinnamon is the Greatest OS around!)

Cheers!

lifeson
Level 1
Level 1
Posts: 4
Joined: Wed Nov 15, 2017 6:15 pm

Re: LM 18.2 Cinnamon and Bluetooth

Post by lifeson » Wed Nov 15, 2017 8:19 pm

What it did for me, was uninstalling blueberry first, then installing blueman, and an instant reboot.
Problem solved for now... :)

Still, I'd like to know, how to really revert udates of packages that were updated through LM's update manager???

Thanks in advance.

lifeson
Level 1
Level 1
Posts: 4
Joined: Wed Nov 15, 2017 6:15 pm

Re: LM 18.2 Cinnamon and Bluetooth

Post by lifeson » Wed Nov 15, 2017 8:35 pm

Reading up in the forum...

I find that people advise, UPDATING the system generally through this command...

Code: Select all

sudo apt update && sudo apt dist-upgrade
...instead of using update mgr. and thereby excluding packages of 3-,4-, and 5-levels.

Would that be more functional although the dialogs in update mgr. warn against it?

:?

qassem
Level 1
Level 1
Posts: 1
Joined: Fri Nov 17, 2017 6:47 am

for those how have Athero Ar5b22 bluetooth problam

Post by qassem » Fri Nov 17, 2017 12:06 pm

this best method for solving Bluetooth issues in Linux OS by Qualcomm Atheros AR5B combo series. :D :D :D :D :D :D .
covering pin number 50 an Wireless + Bluetooth card using thin wire type or paper type.

lifeson
Level 1
Level 1
Posts: 4
Joined: Wed Nov 15, 2017 6:15 pm

Re: LM 18.2 Cinnamon and Bluetooth

Post by lifeson » Wed Dec 06, 2017 1:42 pm

lifeson wrote:Reading up in the forum...

I find that people advise, UPDATING the system generally through this command...

Code: Select all

sudo apt update && sudo apt dist-upgrade
...instead of using update mgr. and thereby excluding packages of 3-,4-, and 5-levels.

Would that be more functional although the dialogs in update mgr. warn against it?

:?

I guess this question of mine was just too stupid, and practising this as a beginner can be more than detrimental. :twisted:

User avatar
JerryF
Level 8
Level 8
Posts: 2205
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: LM 18.2 Cinnamon and Bluetooth

Post by JerryF » Wed Dec 06, 2017 5:13 pm

You can set Update Manager to only include Level 1 and Level 2 updates. (Edit, Preferences, Levels)

If you have 'Always show security updates' and ‘Always show kernel updates' those are usually Level 4 updates.
Please edit your original post and add [SOLVED] to the beginning of the Subject Line if your problem has been solved. It helps other members.

Post Reply

Return to “Software & Applications”