Stellarium crashes on boot [Solved]

Questions about applications and software
Forum rules
Before you post please read how to get help
zeddiegain
Level 1
Level 1
Posts: 3
Joined: Fri Nov 17, 2017 5:37 pm

Stellarium crashes on boot [Solved]

Postby zeddiegain » Fri Nov 17, 2017 5:42 pm

Hey guys.
So when i start stellarium it crashes just some seconds in. What is this about? I am not very good with linux but here is the CLI output.

Code: Select all

 -------------------------------------------------------
[ This is Stellarium 0.14.3 - http://www.stellarium.org ]
[ Copyright (C) 2000-2016 Fabien Chereau et al.         ]
 -------------------------------------------------------
Writing log file to: "/home/zed/.stellarium/log.txt"
File search paths:
  0 .  "/home/zed/.stellarium"
  1 .  "/usr/share/stellarium"
Config file is:  "/home/zed/.stellarium/config.ini"
Detected: OpenGL "4.5"
Driver version string: "4.5.0 NVIDIA 384.90"
GL vendor is "NVIDIA Corporation"
GL renderer is "GeForce GTX 970/PCIe/SSE2"
GL Shading Language version is "4.50 NVIDIA"
GLSL Version Number detected:  4.5
GLSL version is fine, we should not see a graphics problem.
Cache directory is:  "/home/zed/.cache/stellarium/stellarium"
Sky language is  "sv_SE"
Application language is  "sv_SE"
Loading Solar System data ...
Loading star data ...
"Loading \"/usr/share/stellarium/stars/default/stars_0_0v0_5.cat\": 0_0v0_2; 4963"
"Loading \"/usr/share/stellarium/stars/default/stars_1_0v0_5.cat\": 1_0v0_2; 21598"
"Loading \"/usr/share/stellarium/stars/default/stars_2_0v0_5.cat\": 2_0v0_2; 150090"
"Loading \"/usr/share/stellarium/stars/default/stars_3_1v0_3.cat\": 3_1v0_3; 428466"
Finished loading star catalogue data, max_geodesic_level:  3
navigation/preset_sky_time is a double - treating as jday: "2451514.25001"
Reloading DSO data...
Loaded 10756 DSO records
Loading DSO name data ...
Loaded 221 / 297 DSO name records successfully
Loading star names from "/usr/share/stellarium/skycultures/western/star_names.fab"
Loaded 339 / 339 common star names
Loading star names from "/usr/share/stellarium/stars/default/name.fab"
Loaded 4506 / 4506 scientific star names
Loading variable stars from "/usr/share/stellarium/stars/default/gcvs_hip_part.dat"
Loaded 6916 / 6916 variable stars
Loading cross-index data from "/usr/share/stellarium/stars/default/cross-index.dat"
Loaded 108279 / 108279 cross-index data records
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 88 / 88 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Initializing basic GL shaders...
Creating GUI ...
Loaded plugin "Exoplanets"
Exoplanets: file format is wrong! Error: Invalid JSON value: "<html>"
Exoplanets: default exoplanets.json to  "/home/zed/.stellarium/modules/Exoplanets/exoplanets.json"
Exoplanets: loading catalog file: "/home/zed/.stellarium/modules/Exoplanets/exoplanets.json"
Loaded plugin "FOV"
Loaded plugin "MeteorShowers"
MeteorShowersMgr: Loading catalog file: "/home/zed/.stellarium/modules/MeteorShowers/showers.json"
Loaded plugin "Novae"
Novae: version of the catalog: 1
Novae: loading catalog file: "/home/zed/.stellarium/modules/Novae/novae.json"
Loaded plugin "Oculars"
Ocular plugin - press Command-O to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at:  "/home/zed/.stellarium/modules/Oculars/ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version  3
Loaded plugin "Satellites"
Satellites: loading catalog file: "/home/zed/.stellarium/modules/Satellites/satellites.json"
Satellite has invalid orbit: "DELTA 1 R/B" "08063"
Satellite has invalid orbit: "SL-3 R/B" "11849"
Satellite has invalid orbit: "SL-8 R/B" "12389"
Satellite has invalid orbit: "SL-8 R/B" "14484"
Satellite has invalid orbit: "TIANGONG 1" "37820"
Satellite has invalid orbit: "FLOCK 1B-27" "40422"
Satellite has invalid orbit: "FLOCK 1B-28" "40423"
Satellite has invalid orbit: "FLOCK 1B-21" "40427"
Satellite has invalid orbit: "FLOCK 1B-22" "40428"
Satellite has invalid orbit: "FLOCK 1B-10" "40429"
Satellite has invalid orbit: "FLOCK 1B-9" "40430"
Satellite has invalid orbit: "FLOCK 1D-1" "40451"
Satellite has invalid orbit: "FLOCK 1D-2" "40452"
Satellite has invalid orbit: "FLOCK 1B-5" "40453"
Satellite has invalid orbit: "FLOCK 1B-6" "40454"
Satellite has invalid orbit: "GEARRS-1" "40456"
Satellite has invalid orbit: "MICROMAS" "40457"
Satellite has invalid orbit: "FLOCK 1B-11" "40459"
Satellite has invalid orbit: "FLOCK 1B-12" "40460"
Loaded plugin "SolarSystemEditor"
Using the ssystem.ini file that already exists in the user directory...
Unable to find module called "TimeZoneConfiguration"
Loaded plugin "TimeZoneConfiguration"
IP answer: "MY IP ADRESS,SE,Sweden,M,Sk\xC3\xA5ne,My adressEurope/Stockholm,55.8524,13.6609,0\r\n"
Exoplanets: starting update...
Satellites: starting Internet update...
terminate called after throwing an instance of 'std::runtime_error'
  what():  Invalid JSON value: "<html>"
Avbruten (SIGABRT)


What can this be about and how do i fix it?
Thanks and cheers :D
Last edited by zeddiegain on Mon Nov 20, 2017 3:20 pm, edited 1 time in total.

User avatar
Joe2Shoe
Level 2
Level 2
Posts: 74
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Stellarium crashes on boot

Postby Joe2Shoe » Fri Nov 17, 2017 6:05 pm

I have two 10-year old Dell laptops with an Intel 945GMA Graphics card (onboard) and Stellarium will not run with MESA, so I applied a "fix" that makes Stellarium run in "software mode". Works fine.
I looks like you have nVidia graphics. I can't help with that, as my laptop with the nVidia graphics chip bit the dust recently.
Good luck.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

zeddiegain
Level 1
Level 1
Posts: 3
Joined: Fri Nov 17, 2017 5:37 pm

Re: Stellarium crashes on boot

Postby zeddiegain » Sun Nov 19, 2017 4:57 am

Joe2Shoe wrote:I have two 10-year old Dell laptops with an Intel 945GMA Graphics card (onboard) and Stellarium will not run with MESA, so I applied a "fix" that makes Stellarium run in "software mode". Works fine.
I looks like you have nVidia graphics. I can't help with that, as my laptop with the nVidia graphics chip bit the dust recently.
Good luck.



oh bummer hah.. well thanks for the good luck atleast! :D

Mute Ant
Level 12
Level 12
Posts: 4192
Joined: Tue Sep 03, 2013 7:45 pm

Re: Stellarium crashes on boot

Postby Mute Ant » Sun Nov 19, 2017 8:36 pm

You need to give enough information so that someone can follow the same path to where you are, like which version of Mint are you are using, and where did your software come from...

Mint 14 and a PPA == No support, you are alone.

Mint 18 and the repository == Good support, lots of other users.

Rapid changes and runtime bugs are sort of built-in to 0.xxxxx software. "Released For Comment" was the old-style label. Loading it into my Mint 18.3 from the Xenial repository I get...
o stellarium and stellarium-data packages both at version 0.14.3-1
o Start-up message "Your Open-GL installation has problems" which I ignored. It works. Nice software when the real outdoors is at 3 celcius.
Strange women lying in ponds distributing swords is no basis for a system of government.

User avatar
Joe2Shoe
Level 2
Level 2
Posts: 74
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Stellarium crashes on boot

Postby Joe2Shoe » Sun Nov 19, 2017 9:18 pm

This "fix" works on both of my 10 year old laptops with Intel 945GMA graphics. Don't know if it will work for you.
Both laptops are running LM18.2 Cinnamon Sonya 64-bit.

Stellarium OpenGL2 Error Fix

When opening Stellarium, this error message appears:
"No OpenGL 2 found on this system. Please upgrade hardware or use MESA or an older version (of Stellarium)."

1. Open a Terminal, type:
LIBGL_ALWAYS_SOFTWARE=1 stellarium

Stellarium will open and run, but not at high-speed.

2. Create a bash script to open Stellarium:
a. Open a blank text file & insert the following:
#!/bin/bash
# Stellarium OpenGL2 Error Fix
echo "Stellarium OpenGL2 Error Fix"
LIBGL_ALWAYS_SOFTWARE=1 stellarium
b. Save file to Desktop, name "StellariumFix" (w/o quotes).
c. Open a Terminal, type (to make file executable):
chmod 744 /home/inspiron/Desktop/StellariumFix

Double-click StellariumFix on Desktop to run Stellarium.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
phd21
Level 14
Level 14
Posts: 5020
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Stellarium crashes on boot

Postby phd21 » Sun Nov 19, 2017 10:02 pm

Hi "zeddiegain",

Welcome to the wonderful world of Linux Mint and its excellent forum !

It would help to know more about your system setup. If you run "inxi -Fxzd" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

Code: Select all

inxi -Fxzd


Stellarium 0.15.2 Released! How to Install it in Ubuntu 16.04, March 23, 2017
http://ubuntuhandbook.org/index.php/2017/03/stellarium-0-15-2-released/
To install this using the PPA method, open a console terminal, type in, or copy & paste, each line below one by one:

Code: Select all

sudo add-apt-repository ppa:stellarium/stellarium-releases

Code: Select all

sudo apt-get udpate

Code: Select all

sudo apt install stellarium


FYI: Install Planetarium App KStars 2.7 via PPA in Ubuntu 16.04
http://ubuntuhandbook.org/index.php/2016/10/install-planetarium-app-kstars-2-7-via-ppa-in-ubuntu-16-04/
To install this using the PPA method, open a console terminal, type in, or copy & paste, each line below one by one:

Code: Select all

sudo add-apt-repository ppa:mutlaqja/ppa

Code: Select all

sudo apt-get udpate


For Linux Mint 17.x

Code: Select all

sudo apt install kstars


For Linux Mint 18.x

Code: Select all

sudo apt install indi-full kstars-bleeding




Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

zeddiegain
Level 1
Level 1
Posts: 3
Joined: Fri Nov 17, 2017 5:37 pm

Re: Stellarium crashes on boot

Postby zeddiegain » Mon Nov 20, 2017 11:58 am

Joe2Shoe wrote:This "fix" works on both of my 10 year old laptops with Intel 945GMA graphics. Don't know if it will work for you.
Both laptops are running LM18.2 Cinnamon Sonya 64-bit.

Stellarium OpenGL2 Error Fix

When opening Stellarium, this error message appears:
"No OpenGL 2 found on this system. Please upgrade hardware or use MESA or an older version (of Stellarium)."

1. Open a Terminal, type:
LIBGL_ALWAYS_SOFTWARE=1 stellarium

Stellarium will open and run, but not at high-speed.

2. Create a bash script to open Stellarium:
a. Open a blank text file & insert the following:
#!/bin/bash
# Stellarium OpenGL2 Error Fix
echo "Stellarium OpenGL2 Error Fix"
LIBGL_ALWAYS_SOFTWARE=1 stellarium
b. Save file to Desktop, name "StellariumFix" (w/o quotes).
c. Open a Terminal, type (to make file executable):
chmod 744 /home/inspiron/Desktop/StellariumFix

Double-click StellariumFix on Desktop to run Stellarium.



Thanks! This solved it!
And thanks to everybody trying to help out.
I will remember next time when i got a problem to give system info too.

User avatar
Joe2Shoe
Level 2
Level 2
Posts: 74
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Stellarium crashes on boot [Solved]

Postby Joe2Shoe » Tue Nov 21, 2017 11:19 am

phd21, I also installed KStars. Quite nice. Thanks.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
phd21
Level 14
Level 14
Posts: 5020
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Stellarium crashes on boot [Solved]

Postby phd21 » Tue Nov 21, 2017 12:13 pm

Hi "Joe2Shoe",

You are welcome ...

I think Stellarium and Kstar are both excellent. I always install both of these. I have had some issues with Stellarium because of older computer hardware like older video cards. FYI: There are also some additional Kstar packages inthe "Synaptic Package Manager (SPM)".
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde


Return to “Software & Applications”