Chrome Locks System

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Aristekrat
Level 1
Level 1
Posts: 12
Joined: Fri Dec 01, 2017 6:59 pm

Chrome Locks System

Post by Aristekrat » Fri Dec 01, 2017 7:13 pm

Launching Chrome and even Chromium on Linux Mint causes the system to lock up, only restoring after a hard shutdown.

I've tried all the solutions I could find online to resolve the problem and a few of my own, nothing has worked. A list of what I've tried so far:
-Disabling all browser extensions,
-Disabling hardware acceleration (seems to give it more time before freezing, but still freezes)
-Logging out of Chrome
-Switching kernels
-Installing different versions of Mint, I've tried 17, 17.1, 18.2, 18.3 (all 64 bit version) - the bug is present in all of them.

Chrome causes the system to totally lock up within 30s of launching. I can't even move my mouse cursor. As a result, I'm mostly looking for a way to get more information on what's going wrong rather than a direct solution. I don't even know what error is occurring underneath the covers. If there is a way I can get an error report after a hard crash I would appreciate that.

I have a laptop that runs Mint 17.* and it has no problems with Chrome. I was previously able to run Chrome just fine on the problem desktop using Linux Mint 15.*. I'd guess there's something about my system's hardware, Chrome, and Mint that don't play nicely with each other. My problem desktop is currently running Linux Mint 18.3 Cinnamon on a 64 bit system.

User avatar
kc1di
Level 13
Level 13
Posts: 4655
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Chrome Locks System

Post by kc1di » Sat Dec 02, 2017 7:21 am

Hello Aristekrat and Welcome to Linux Mint Forums,

You did not say what your video card is. could you go to a terminal and type this command and post the output here?

Code: Select all

inxi -Fxz
Thanks.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Aristekrat
Level 1
Level 1
Posts: 12
Joined: Fri Dec 01, 2017 6:59 pm

Re: Chrome Locks System

Post by Aristekrat » Sun Dec 03, 2017 12:47 pm

Here you are,

Code: Select all

System:  Kernel: 4.10.0-40-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: P8Z77-V LX v: Rev X.0x
           Bios: American Megatrends v: 1902 date: 04/12/2013
CPU:       Quad core Intel Core i5-3570K (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27741
           clock speeds: max: 4100 MHz 1: 1702 MHz 2: 1671 MHz 3: 1618 MHz
           4: 1695 MHz
Graphics:  Card: NVIDIA GK106 [GeForce GTX 660] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on NVE6
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GK106 HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.10.0-40-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1128.2GB (2.1% used)
           ID-1: /dev/sda model: M4 size: 128.0GB
           ID-2: /dev/sdb model: WDC_WD1002FAEX size: 1000.2GB
Partition: ID-1: / size: 102G used: 6.5G (7%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 472M used: 125M (28%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 17.12GB used: 0.00GB (0%) fs: swap dev: /dev/dm-2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 35.0
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 222 Uptime: 3 min Memory: 836.7/15992.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

User avatar
kc1di
Level 13
Level 13
Posts: 4655
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Chrome Locks System

Post by kc1di » Sun Dec 03, 2017 2:24 pm

Your using nouveau gpu driver which has problems. You can either go to Administration> Driver Manager and install the recommended Nvidia driver for you card or
modify your boot line in grub to add nomodeset. See here;
https://www.linuxmint.com/rel_sylvia_cinnamon.php
Scroll down to solving freezes.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Aristekrat
Level 1
Level 1
Posts: 12
Joined: Fri Dec 01, 2017 6:59 pm

Re: Chrome Locks System

Post by Aristekrat » Sat Dec 09, 2017 2:09 pm

I wanted to say this totally fixed my problem. Now that I've done it I can faintly recall switching over the driver for LM 15 also. Many thanks for the solution, Chrome was a key part of my system, I couldn't go without it.

User avatar
kc1di
Level 13
Level 13
Posts: 4655
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Chrome Locks System

Post by kc1di » Sat Dec 09, 2017 4:10 pm

Your Welcome, Enjoy :)
Please take a moment and mark the subject line of your original post <Solved> Thank You.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Post Reply

Return to “Software & Applications”