ConvertAll Won't Run After LM18.3 Upgrade

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
Joe2Shoe
Level 3
Level 3
Posts: 111
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

ConvertAll Won't Run After LM18.3 Upgrade

Postby Joe2Shoe » Sat Dec 02, 2017 4:08 pm

ConvertAll was working fine on LM18.2 Cinnamon 64-bit, on 3 laptops. Now, after upgrading to LM18.3 Cinnamon 64-bit, the program will not open.
When running via Menu/Accessories/ConvertAll, the program does not open. When running via the Terminal, this error shows:
"Segmentation fault"

Python 3.6.2 is installed.
PyQt python-pyqt5 is already the newest version (5.5.1+dfsg-3ubuntu4).
Qt is installed qt-opensource-linux-x64-5.7.0.run

The 3 above programs installed correctly.

When installing ConvertAll 0.7.2:
tar -xzvf convertall-0.7.2.tar.gz
cd convertall-0.7.2
python3 install.py

convertall-0.7.2 # python3 install.py
Checking dependencies...
Python Version 3.6.2 -> OK
PyQt not found -> Sorry, PyQt 4.x is required and must be built for Python 3

I could not find PyQt 4.x built for Python 3 yet.
Does anyone have any suggestions?
Thanks.

---

Code: Select all

 inxi -Fxz
System:    Host: inspiron-1501 Kernel: 4.13.0-16-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell product: Vostro 1000
           Mobo: Dell model: 0CR584 Bios: Dell v: 2.6.3 date: 12/07/2007
CPU:       Dual core AMD Turion 64 X2 Mobile TL-64 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 svm) bmips: 8778
           clock speeds: max: 2200 MHz 1: 2194 MHz 2: 2194 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS482M [Mobility Radeon Xpress 200]
           bus-ID: 01:05.0
           Display Server: X.org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           tty size: 80x24 Advanced Data: N/A for root
Audio:     Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.13.0-16-generic
Network:   Card-1: Broadcom BCM4311 802.11b/g WLAN
           driver: b43-pci-bridge bus-ID: 05:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Broadcom BCM4401-B0 100Base-TX
           driver: b44 v: 2.0 bus-ID: 08:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (29.5% used)
           ID-1: /dev/sda model: ST500LT012 size: 500.1GB temp: 46C
Partition: ID-1: / size: 63G used: 15G (26%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 92G used: 5.7G (7%) fs: ext4 dev: /dev/sda6
           ID-3: /boot size: 1.9G used: 190M (11%) fs: ext4 dev: /dev/sda1
           ID-4: swap-1 size: 8.80GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 52.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 226 Uptime: 1:14 Memory: 1413.5/3821.5MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
RAM:     4GB (2x2GB) Crucial PC2-6400 DDR2-800MHz
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
Joe2Shoe
Level 3
Level 3
Posts: 111
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

[SOLVED] ConvertAll Won't Run After LM18.3 Upgrade

Postby Joe2Shoe » Sat Dec 02, 2017 4:51 pm

UPDATE:
After running ConvertAll via the Terminal as root (sudo -i convertall), ConvertAll runs now.
Last edited by Joe2Shoe on Sat Dec 02, 2017 5:37 pm, edited 1 time in total.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
BenTrabetere
Level 4
Level 4
Posts: 495
Joined: Sat Jul 19, 2014 12:04 am
Location: Hattiesburg, MS USA

Re: ConvertAll Won't Run After LM18.3 Upgrade

Postby BenTrabetere » Sat Dec 02, 2017 5:29 pm

The python3-pyqt4 package is a dependency. You can find it Software Manager.

User avatar
Joe2Shoe
Level 3
Level 3
Posts: 111
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: ConvertAll Won't Run After LM18.3 Upgrade

Postby Joe2Shoe » Sat Dec 02, 2017 5:34 pm

Thanks for the info. python3-pyqt4 is already installed on my system.
I'll remove it, then reinstall to see if it fixes these issues.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
Joe2Shoe
Level 3
Level 3
Posts: 111
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: ConvertAll Won't Run After LM18.3 Upgrade

Postby Joe2Shoe » Sat Dec 02, 2017 7:49 pm

Uninstalled/Reinstalled, same situation.
At least I can sudo ConvertAll in the Terminal to get it to work.

What part of Mississippi are you from?
Thanks again.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
BenTrabetere
Level 4
Level 4
Posts: 495
Joined: Sat Jul 19, 2014 12:04 am
Location: Hattiesburg, MS USA

Re: ConvertAll Won't Run After LM18.3 Upgrade

Postby BenTrabetere » Sun Dec 03, 2017 12:22 am

Joe2Shoe wrote:Uninstalled/Reinstalled, same situation.
At least I can sudo ConvertAll in the Terminal to get it to work.

Even though apt-cache depends convertall does not list it as a dependency, you may also need to install the python3-pyqt5 package. According to the website, ConvertAll requires the following:
    Python 3.4 or higher
    Qt 5.4 or higher
    PyQt 5.4 or higher

What part of Mississippi are you from?

Hattiesburg

User avatar
Joe2Shoe
Level 3
Level 3
Posts: 111
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: ConvertAll Won't Run After LM18.3 Upgrade

Postby Joe2Shoe » Sun Dec 03, 2017 10:33 am

Installed:
Python 3.6.2
QT 5.7.0
PyQt 5.5.1
python3-pyqt4 4.11.4
python3-pyqt5 5.5.1

No difference, still have to "sudo -i convertall" in the Terminal to make it run.
Thanks for the additional assistance.

Have a lot of friends down in your area, I miss it.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
BenTrabetere
Level 4
Level 4
Posts: 495
Joined: Sat Jul 19, 2014 12:04 am
Location: Hattiesburg, MS USA

Re: ConvertAll Won't Run After LM18.3 Upgrade

Postby BenTrabetere » Mon Dec 04, 2017 1:34 am

My final suggestion is to contact the developer. Something is not right.
http://www.bellz.org/contact.html

User avatar
Joe2Shoe
Level 3
Level 3
Posts: 111
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: ConvertAll Won't Run After LM18.3 Upgrade

Postby Joe2Shoe » Wed Dec 06, 2017 7:41 pm

I downgraded one laptop from kernel 4.11.0-xx-generic to 4.10.0-37-generic and now ConvertAll works again.
So, it could be a kernel-compatibility thing.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire


Return to “Software & Applications”