Problem with Redshift on 18.3 Cinnamon

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Problem with Redshift on 18.3 Cinnamon

Post by orschiro » Thu Dec 07, 2017 3:47 am

Dear all,

I love the default addition of Redshift to 18.3 Cinnamon.

But I have some problems with it.

After booting up my machine and logging into my session, Redshift doesn't automatically turn my screen red despite being enabled.

I click on the tray icon and go to "Info". Then I get to see that no settings are being applied.

Again, I go to the tray icon and then uncheck "Enabled". It then tells me that it "Failed to run Redshift. Trying location provider `geoclue2'..."

With all this happening, I am properly connected to the WiFi.

Can anyone confirm a similar problem?

Thank you!

Image

Image

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by orschiro » Fri Dec 08, 2017 2:02 am

I was able to workaround this problem by adding a delay of 5 seconds to the startup.

Image

User avatar
Moem
Level 15
Level 15
Posts: 5894
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by Moem » Fri Dec 08, 2017 7:30 am

Oh hey, you can add delay on startup applications on 18.3 Cinnamon? Somehow I seem to have lost that ability... the control just isn't there. i thought the setting had been moved elsewhere.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
ArtGirl
Level 4
Level 4
Posts: 392
Joined: Sat Apr 15, 2017 1:16 pm
Location: UK

Re: Problem with Redshift on 18.3 Cinnamon

Post by ArtGirl » Fri Dec 08, 2017 7:56 am

Moem wrote:Oh hey, you can add delay on startup applications on 18.3 Cinnamon? Somehow I seem to have lost that ability... the control just isn't there. i thought the setting had been moved elsewhere.
You don't have the 'edit' button at the bottom of the startup application box?
18.3 Mate 64bit
Radeon R9 255, Mesa 17.2.8, 4.15.0-13,
Lenovo x310, intel i7-4790, 16 ram,
Ugee 2150


For any advice I've been able to add, eg re graphics tablets, please search forum.

Image

User avatar
Moem
Level 15
Level 15
Posts: 5894
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by Moem » Fri Dec 08, 2017 8:11 am

ArtGirl wrote:You don't have the 'edit' button at the bottom of the startup application box?
I have it at the right hand side. But it doesn't have a 'delay' option if I open it. Just name, command and comment.
And I don't have the delay setting next to each entry in the startup application window, that is shown in oshiro's picture. I do remember that from 17.3.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
Moem
Level 15
Level 15
Posts: 5894
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by Moem » Fri Dec 08, 2017 8:15 am

A picture says more than a thousand words...

Image
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
ArtGirl
Level 4
Level 4
Posts: 392
Joined: Sat Apr 15, 2017 1:16 pm
Location: UK

Re: Problem with Redshift on 18.3 Cinnamon

Post by ArtGirl » Fri Dec 08, 2017 8:37 am

Moem wrote:A picture says more than a thousand words...

Image
I see! You're on a different version or release. I understand now. :)
18.3 Mate 64bit
Radeon R9 255, Mesa 17.2.8, 4.15.0-13,
Lenovo x310, intel i7-4790, 16 ram,
Ugee 2150


For any advice I've been able to add, eg re graphics tablets, please search forum.

Image

User avatar
Moem
Level 15
Level 15
Posts: 5894
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by Moem » Fri Dec 08, 2017 8:57 am

Well, it's 18.3 Cinnamon, just like the poster of this topic, who apparently does have the delay controls. So I have no idea what's up here.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by orschiro » Fri Dec 08, 2017 9:09 am

I hope this video helps clarify things: https://www.useloom.com/share/94b82316c ... 1d0cc791c9

User avatar
ArtGirl
Level 4
Level 4
Posts: 392
Joined: Sat Apr 15, 2017 1:16 pm
Location: UK

Re: Problem with Redshift on 18.3 Cinnamon

Post by ArtGirl » Fri Dec 08, 2017 9:14 am

Moem wrote:Well, it's 18.3 Cinnamon, just like the poster of this topic, who apparently does have the delay controls. So I have no idea what's up here.
Surreal. :?
18.3 Mate 64bit
Radeon R9 255, Mesa 17.2.8, 4.15.0-13,
Lenovo x310, intel i7-4790, 16 ram,
Ugee 2150


For any advice I've been able to add, eg re graphics tablets, please search forum.

Image

User avatar
Moem
Level 15
Level 15
Posts: 5894
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by Moem » Fri Dec 08, 2017 9:20 am

Nope, it doesn't! It's a nice video though. :)
I have the same distro and version and desktop environment as you do, and yet I don't have the startup delay setting anywhere. I'm using a different theme, but going back to default does not bring the settings back. I switched all settings to Mint-X and got this:

Image

The thing is, setting a delay is exactly what I would have suggested as a solution for your problem, if it weren't for the fact that I went to look at my own startup settings and did not see that setting anymore, so I assumed it was moved or removed. Now I'm sort of peeved that I'm apparently missing something that the rest of the world does have. But since this is a separate issue from yours, I'll make a new topic about it. Thank you for weighing in!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
ArtGirl
Level 4
Level 4
Posts: 392
Joined: Sat Apr 15, 2017 1:16 pm
Location: UK

Re: Problem with Redshift on 18.3 Cinnamon

Post by ArtGirl » Fri Dec 08, 2017 9:22 am

Moem wrote: The thing is, setting a delay is exactly what I would have suggested as a solution for your problem, if it weren't for the fact that I went to look at my own startup settings and did not see that setting anymore, so I assumed it was moved or removed. Now I'm sort of peeved that I'm apparently missing something that the rest of the world does have. But since this is a separate issue from yours, I'll make a new topic about it. Thank you for weighing in!
No problem, and sounds good about a new topic. Hope it works out. OP, I hope someone using Redshift can feed back soon.
Last edited by ArtGirl on Fri Dec 08, 2017 9:25 am, edited 1 time in total.
18.3 Mate 64bit
Radeon R9 255, Mesa 17.2.8, 4.15.0-13,
Lenovo x310, intel i7-4790, 16 ram,
Ugee 2150


For any advice I've been able to add, eg re graphics tablets, please search forum.

Image

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by orschiro » Fri Dec 08, 2017 9:23 am

> Thank you for weighing in!

Sure thing! Hope we can solve your problem, too. :-)

Should we report the Redshift delay upstream? Maybe it's a bug?

User avatar
Moem
Level 15
Level 15
Posts: 5894
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by Moem » Fri Dec 08, 2017 10:32 am

So yes, my problem was something I borked. :lol:

Orschiro, I would personally regard your Redshift problem as solved; Geoclue takes a little while to start up and do its thing, so setting Redshift to kick in after that is indeed a good solution, and the one I use as well. We could see that as a bug, but it's debatable which program is the one with the bug here. The problem lies mostly in the way they work together.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by orschiro » Fri Dec 08, 2017 10:34 am

I agree with you, maybe not a bug but certainly nice if it's well integrated into Linux Mint.

And I guess it's safe to add a 5 seconds delay to the Redshift startup for default future releases, don't you think?

Where is the best place for the developers to potentially take this request into account for the next version?

tkxak
Level 1
Level 1
Posts: 3
Joined: Sat Dec 02, 2017 10:01 am

Re: Problem with Redshift on 18.3 Cinnamon

Post by tkxak » Sat Dec 09, 2017 7:59 am

Take a look at this Redshift GUI: viewtopic.php?f=47&t=258944
You can use it to desactivate the GEO location and put the data manually (you can do that in terminal too)

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Problem with Redshift on 18.3 Cinnamon

Post by orschiro » Sat Dec 09, 2017 3:51 pm

Thanks! For now I am fine with the delay 5 seconds setting.

I am wondering if my experienced problem should be treated as a bug though.

User avatar
JerryF
Level 9
Level 9
Posts: 2510
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Problem with Redshift on 18.3 Cinnamon

Post by JerryF » Sat Dec 09, 2017 4:37 pm

Moem wrote:Oh hey, you can add delay on startup applications on 18.3 Cinnamon? Somehow I seem to have lost that ability... the control just isn't there. i thought the setting had been moved elsewhere.
Still there. Do you have a customized theme? :?:
Shutter-002.jpg
IF AND WHEN your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

Post Reply

Return to “Software & Applications”