Installation Problem : Google Calendar Desklet

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Franklinbel
Level 1
Level 1
Posts: 1
Joined: Sun Dec 10, 2017 5:29 pm

Installation Problem : Google Calendar Desklet

Post by Franklinbel » Sun Dec 10, 2017 5:46 pm

Hi Gang,

I've been trying to install the Calendar Desklet with Gcalcli, but it just doens't seem to work.
I'm using 18.3 Cinnamon and been following this explanation.
But this is what I get as a responce :

Code: Select all

Traceback (most recent call last):
  File "/usr/local/bin/gcalcli", line 4, in <module>
    __import__('pkg_resources').run_script('gcalcli==3.4.0', 'gcalcli')
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3144, in <module>
    @_call_aside
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3128, in _call_aside
    f(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3157, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 668, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 681, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 875, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (oauth2client 1.4.12 (/usr/local/lib/python2.7/dist-packages/oauth2client-1.4.12-py2.7.egg), Requirement.parse('oauth2client<5.0.0dev,>=1.5.0'), set(['google-api-python-client']))
I'm probably doing something wrong but have NO idea what exactly. Can someone point me in the right direction?
Thanks in Advance!!

Post Reply

Return to “Software & Applications”