Disable Smooth Scrolling in Pluma, Gedit, etc.?

Questions about applications and software
Forum rules
Before you post please read how to get help
elmood
Level 1
Level 1
Posts: 1
Joined: Mon Dec 11, 2017 2:26 am

Disable Smooth Scrolling in Pluma, Gedit, etc.?

Postby elmood » Mon Dec 11, 2017 2:35 am

I have several machines running Linux Mint MATE. One has 18, and another has 18.2. On the 18 system everything works great and when I use the page up/down keys in Gedit-based editors like Pluma, Xed and Gedit the new text appears immediately. On the 18.2 system it has an smooth scrolling / ease effect which I find very annoying. The web seems to agree that this is a Gtk3 problem and there is no option to disable it within Gtk itself.

Apart from downgrading my system (feels kind of wrong) is there any way to fix this issue, such as:

- Patching Pluma, Gtk3, etc. to not do smooth scrolling?
- Speeding up the scrolling speed so that it is essentially instantaneous?
- Downgrading to Gtk2? I don't see a way to get access to older versions of these apps within the Package Manager
- Mapping the page up/down keys to do whatever action the mouse wheel does... since the wheel seems to move instantly up and down?

Linux Mint is 99.9% awesome and is everything I need... but this change really affects my productivity in coding. For the last hours instead of hacking on my app I've been trying to make my editor responsive enough that it doesn't drive me bonkers!

Thanks!

Return to “Software & Applications”