library pkg conflict

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
carot
Level 1
Level 1
Posts: 3
Joined: Fri Dec 08, 2017 10:57 am

library pkg conflict

Post by carot » Wed Dec 13, 2017 9:01 am

Hi, All,

i have a question about libqt5gui5 package conflict,

the teamviewer (version 13) application needs libqt5gui5 >=5.5

but i have libqt5gui5 (version:5.4.1+dfsg-2ubuntu3~ubuntu14.04.1 )
and its needed by qt5 application and other application.

so how do i resolve this problem?
would i reserved the both version for different application?
the both lib seem to be installed to the same folder.

User avatar
thx-1138
Level 6
Level 6
Posts: 1079
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: library pkg conflict

Post by thx-1138 » Wed Dec 13, 2017 10:16 am

...at first - which version of Mint are you running?

Because as the name itself implies, 5.4.1+dfsg-2ubuntu3~ubuntu14.04.1, is meant for older Ubuntu 14.x / Mint 17.x versions.
But on Ubuntu 16.x / Mint 18.x the version installed should (currently) be libqt5gui5 (5.5.1+dfsg-16ubuntu7.5)...

If you mix packages / libraries meant for different versions, you get various 'weird' results at the very least i'd say...

carot
Level 1
Level 1
Posts: 3
Joined: Fri Dec 08, 2017 10:57 am

Re: library pkg conflict

Post by carot » Thu Dec 14, 2017 7:41 am

$ cat /etc/issue
Linux Mint 17.1 Rebecca \n \l

User avatar
thx-1138
Level 6
Level 6
Posts: 1079
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: library pkg conflict

Post by thx-1138 » Thu Dec 14, 2017 8:50 am


screenshot
Level 1
Level 1
Posts: 36
Joined: Sat Feb 01, 2014 8:54 am

Re: library pkg conflict

Post by screenshot » Thu Dec 28, 2017 2:01 pm

here is 2 answers:
viewtopic.php?f=47&t=259538

Post Reply

Return to “Software & Applications”