Page 1 of 1

Force flatpak apps using some theme

Posted: Sun Dec 17, 2017 4:23 pm
by vlad1777d

I installed Atom, Gimp, Inkscape via Flatpak, they work, but use some strange theme: ... -l-6Uc.jpg

What do I want: to apply to all Flatpak applications any dark theme, because in system I use Mint-Y-Dark.

Same for Inkscape, Atom. They use that strange GTK theme.
What I tried:
Installing 'org.gtk.Gtk3theme.Arc-Dark/x86_64/3.22'. Doesn't changed theme.
Trying to specify this theme for GIMP in environment variable:
'sudo flatpak override --env=GTK_THEME=Adwaita org.gimp.GIMP'
Doesn't worked. I checked such way on general GIMP (system one), it doesn't work too. And with (system) 'gnome-terminal' too. But it worked with 'gnome-calculator' (system).

But if I change system theme in cinnamon-control-center to Adwaita, then it would be changed in flatpak Gimp too (by the way, on fly).

My list of flatpak packages:
flatpak list
Ref Options
org.gimp.GIMP/x86_64/stable system,current
org.gnome.Eolie/x86_64/stable system,current
org.freedesktop.Platform.GL.nvidia-384-90/x86_64/1.4 system,runtime
org.freedesktop.Sdk/x86_64/1.6 system,runtime
org.gnome.Platform/x86_64/3.24 system,runtime
org.gnome.Platform/x86_64/3.26 system,runtime
org.gtk.Gtk3theme.Arc-Dark/x86_64/3.22 system,runtime
org.gtk.Gtk3theme.Breeze-Dark/x86_64/3.22 system,runtime

If somebody will help me to solve this - I would be very grateful =)

Best regards,

Re: Force flatpak apps using some theme

Posted: Sun Dec 17, 2017 4:46 pm
by vlad1777d
Hint from ahayzen on #flatpak channel:

GIMP and Inkscape are both Gtk2 and Atom is using Electron which is using currently Gtk2 as well IIRC.
For gimp i have this env override to make it use Adwaita, GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc

But for me this worked badly. Not all theme was replaced, it was the hybrid of Mint-Y-Dark and Adwaita.

Re: Force flatpak apps using some theme

Posted: Thu Dec 21, 2017 7:27 pm
by vlad1777d
Actual =)