Software Manager issue after upgrading to Linux Mint MATE 18.3

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
MintyTeeka
Level 1
Level 1
Posts: 3
Joined: Tue Dec 19, 2017 11:30 am

Software Manager issue after upgrading to Linux Mint MATE 18.3

Post by MintyTeeka » Tue Dec 19, 2017 11:43 am

After upgrading from Linux Mint MATE 18.1 to Linux Mint MATE 18.3, Software Manager does not launch from mint menu. It does launch from a terminal however. What could be broken here?

Code: Select all

System:    Host: James Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3) dm: mdm Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUS product: All Series
           Mobo: ASUSTeK model: MAXIMUS VII HERO v: Rev 1.xx Bios: American Megatrends v: 3103 date: 03/09/2016
CPU:       Quad core Intel Core i7-4790K (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 32000
           clock speeds: min/max: 800/4400 MHz 1: 4000 MHz 2: 4007 MHz 3: 4037 MHz 4: 4242 MHz 5: 4009 MHz
           6: 4024 MHz 7: 4055 MHz 8: 4000 MHz
Graphics:  Card: NVIDIA GM204 [GeForce GTX 970] bus-ID: 01:00.0 chip-ID: 10de:13c2
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 970/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.90 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GM204 High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:0fbb
           Card-2 Intel 9 Series Family HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:8ca0
           Card-3 Shure X2u Adapter driver: USB Audio usb-ID: 003-002 chip-ID: 14ed:29b6
           Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic
Network:   Card: Intel Ethernet Connection (2) I218-V
           driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0 chip-ID: 8086:15a1
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1480.3GB (5.6% used)
           ID-1: /dev/sda model: SanDisk_SDSSDXPS size: 480.1GB serial: 153635400449
           ID-2: /dev/sdb model: WDC_WD1005FBYZ size: 1000.2GB serial: WD-WMC6M0H3L3VM
Partition: ID-1: / size: 409G used: 48G (13%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 34.30GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:40C
           Fan Speeds (in rpm): cpu: 0
Repos:     Active apt sources in file: /etc/apt/sources.list.d/gezakovacs-ppa-xenial.list
           deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/gezakovacs/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/mono-official.list
           deb http://download.mono-project.com/repo/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sylvia main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/remmina-ppa-team-remmina-next-xenial.list
           deb http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu xenial main
           deb-src http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu xenial main
Info:      Processes: 256 Uptime: 12 min Memory: 1460.4/32117.1MB
           Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481 running in mate-terminal) inxi: 2.2.35

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Software Manager issue after upgrading to Linux Mint MATE 18.3

Post by greerd » Tue Dec 19, 2017 3:07 pm

Check what the launch command is in the menu (I'm not familiar with mate menu edidting) and run that in a terminal.

I had an issue with Software Manager after my upgrade to 18.3 that when clicked, I got the enter root password, but the app never started.

The menu command was 'gksu mintinstall', when running "gksu mintinstall" in a terminal, it said should not be run as root so deleting the gksu solved the problem. Maybe the same issue with you?

I think there is a change in 18.3 where Software Manager (mintinstall) is no longer run as root, and the upgrade didn't change the menu command.

MintyTeeka
Level 1
Level 1
Posts: 3
Joined: Tue Dec 19, 2017 11:30 am

Re: Software Manager issue after upgrading to Linux Mint MATE 18.3

Post by MintyTeeka » Fri Jan 05, 2018 12:13 pm

I understand the Launch Command is "gksu mintinstall" for 18.1 and becomes "mintinstall" for 18.3. I have checked that. But something else is broken here to stop it launching from menu. Works from terminal, but not from menu. Works on a newly created user account. So it appears to be something in /home/USER thats breaking it. Maybe a file is missing or broken, knowing what files mintinstall reads from would help. Any insight or ideas welcome.

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Software Manager issue after upgrading to Linux Mint MATE 18.3

Post by minitux » Fri Jan 05, 2018 12:38 pm

try to remove the directory mintinstall from ~/.cache in the user that not work, login with that user and type

Code: Select all

rm -r .cache/mintinstall
and then re-try

bjmh46
Level 3
Level 3
Posts: 135
Joined: Fri May 30, 2014 6:44 pm

Re: Software Manager issue after upgrading to Linux Mint MATE 18.3

Post by bjmh46 » Sun Jan 07, 2018 10:27 am

In xfce, I removed the old panel shortcut, right clicked on software manager in the whisker menu, clicked on "add to panel". Problem solved. Don't know if something like this will work in Mate.

MintyTeeka
Level 1
Level 1
Posts: 3
Joined: Tue Dec 19, 2017 11:30 am

Re: Software Manager issue after upgrading to Linux Mint MATE 18.3

Post by MintyTeeka » Fri Feb 16, 2018 3:58 pm

Fixed by deleting and re-creating user account. Not ideal but only thing that worked.

Post Reply

Return to “Software & Applications”