Flatpak Shutdown Hangs Problem

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 10
Joined: Wed Nov 07, 2012 9:08 pm

Flatpak Shutdown Hangs Problem

Post by arobertson1 » Thu Jan 04, 2018 10:24 am

I installed the Flatpak version of Telegram on Linux Mint 18.3 Cinnamon and every time the PC is shutdown it hangs with:

[TIME] Timed out stopping /dev/dm-0

It does eventually time out and then shuts down but is quite slow to do so. After uninstalling Telegram the problem went away. I then tried another Flatpak to see if this was unique to Telegram and it isn't - if any Flatpak is currently running when you try to shutdown then the PC will hang. If you quit the Flatpak first / kill the process and then shutdown everything works as normal.

Is this a bug with Flatpak or does my PC have a problem? It's more noticeable with Telegram as this is set to run in the startup applications and is usually running at shutdown.

Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am

Re: Flatpak Shutdown Hangs Problem

Post by orschiro » Fri Jan 05, 2018 2:15 am

Recently, I had a similar problem using Gradio Flatpak. Can you let me know if this helps?

https://www.reddit.com/r/linuxmint/comm ... ion_c2_of/

I installed the watchdog package.
Last edited by orschiro on Fri Jan 05, 2018 2:54 am, edited 2 times in total.

User avatar
Level 5
Level 5
Posts: 693
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Flatpak Shutdown Hangs Problem

Post by pbear » Fri Jan 05, 2018 2:22 am

Tested this with another Flatpak - to wit, Gnome Web - and observe the same 90 second time-out to shutdown in both my main Mate system and a Cinnamon test box. My assumption would be that it's the runtime environment which is hanging, but that's just a hunch.

ETA: After reading the man page, decided didn't want to install watchdog. But editing the system.conf timeout worked nicely.
Time flies like an arrow. Fruit flies like a banana.
Running Mate 18.3 64 bit (by upgrade from 18.1-2)

Level 1
Level 1
Posts: 13
Joined: Sat Aug 20, 2011 7:05 pm

Re: Flatpak Shutdown Hangs Problem

Post by thecursedfly » Sat Mar 17, 2018 7:42 pm

Well, after wasting some time today (not an expert Linux user), I got to the same conclusion.
In my case I had the KeepassXC flatpak open when rebooting a few times my machine today (testing some stuff that needs to happen on startup), and everytime i had to wait for 1,5 minutes before it would complete the shutdown.
I guess that I will abandon my intention of using flatpak (if available) for all my applications until this gets fixed...

Post Reply

Return to “Software & Applications”