<Solved>Cant run F.lux

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
whois1230
Level 3
Level 3
Posts: 118
Joined: Mon Aug 28, 2017 5:35 am

<Solved>Cant run F.lux

Post by whois1230 » Sun Jan 14, 2018 7:51 pm

Hi, I installed F.lux according to the instructions here: https://github.com/xflux-gui/fluxgui ---
Ubuntu PPA Package Manager Install

To install via apt:

sudo add-apt-repository ppa:nathan-renniewaldock/flux
sudo apt-get update
sudo apt-get install fluxgui

See ubuntuhandbook.org instructions for more details.

If you have trouble with the PPA version try the manual install below.
f.lux indicator applet appears in my start menu, but when I click it nothing happens. It used to work before, before I installed a newer version of Python.

Last edited by whois1230 on Tue Jan 16, 2018 9:19 am, edited 1 time in total.

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Cant run F.lux

Post by orschiro » Mon Jan 15, 2018 1:55 am

Any reason why you are not using Redshift which is the default application in LM 18.3?

User avatar
gld59
Level 2
Level 2
Posts: 61
Joined: Thu Nov 30, 2017 11:05 pm
Location: Australia

Re: Cant run F.lux

Post by gld59 » Mon Jan 15, 2018 2:17 am

They work differently. As well as shifting the colour balance, f.lux tries to remove the specific blue light frequencies which do most to keep us awake.

Hoser Rob
Level 11
Level 11
Posts: 3973
Joined: Sat Dec 15, 2012 8:57 am

Re: Cant run F.lux

Post by Hoser Rob » Mon Jan 15, 2018 10:26 am

It clearly states in the docs, right above the section quoted in the OP, that only python 2 is supported, and also ...
The fluxgui is only known to work with Python 2, so use python2 instead of python for the commands in this README if Python 3 is the default on your system.
Python 3 is pretty common nowadays, this indicates to me poor dev support. I'd be looking for something else.

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Cant run F.lux

Post by orschiro » Mon Jan 15, 2018 10:28 am

f.lux tries to remove the specific blue light frequencies
And Redshift doesn't? That would be new to me.

whois1230
Level 3
Level 3
Posts: 118
Joined: Mon Aug 28, 2017 5:35 am

Re: Cant run F.lux

Post by whois1230 » Tue Jan 16, 2018 9:18 am

Ok, so the problem is Python. I installed Redshift instead.

Post Reply

Return to “Software & Applications”