Lightning (Thunderbird Extension) not working properly

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
spegru
Level 3
Level 3
Posts: 131
Joined: Sat Sep 26, 2009 5:34 am

Lightning (Thunderbird Extension) not working properly

Post by spegru » Fri Jan 19, 2018 6:48 am

I'm currently on 18.3 and the standard packaged Thunderbird 52.5 and Lightning 5.4

Main problem is misbehaviour of Lightning in that I cant invite participants to a meeting (press invite invitees and nothing happens) at all.

Also when I sent up a new event and press save it does so but then when I close the dialogue it says event not saved (even though it is). I can live with that but it is a bit annoying

This an issue I have been suffering from for several months. Not 100% sure when it started but I am sure it has been there even since before I upgraded to Mint v18.
It was previously suggested that I upgrade to a newer Thunderbird, but when I did so Lightning stopped working altogether and I felt lucky to get it back at all
The whole email/calendar config has been upgraded many times and even moevd from PC to PC so I suppose there could be some old rubbish lying around from previous versions but I am loth to rebuild from scratch because I have ancient email from old accounts that don't exist any more which I feel sure I will lose if the system is given half a chance!

This issue affects several calendars and types whether Google or CalDav.

Any ideas? Thanks.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by Cosmo. » Fri Jan 19, 2018 7:16 am

Do at first a check, if there is an ownership problem in your user account:

Mark the following command and press ctrl-c

Code: Select all

find $HOME ! -user $USER -type f
open a terminal and press ctrl-shift-V
Mark the complete result inclusive the command with the mouse and press ctrl-shift-C
In the forum click the Code-button above the text box, than press ctrl-v.

Report in case, that there is no output.

spegru
Level 3
Level 3
Posts: 131
Joined: Sat Sep 26, 2009 5:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by spegru » Fri Jan 19, 2018 8:00 am

Thanks. did you mean for me to transpose my user name as 'user'?
Anyway I'm doing that now - it's huge! and begins with "find: ‘/home/stephen/.gnupg’: Permission denied"

Are you sure you want all that?

spegru

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by Cosmo. » Fri Jan 19, 2018 9:47 am

spegru wrote:Thanks. did you mean for me to transpose my user name as 'user'?
No, you have to leave the command as given.. Or better: Copy it and paste it into the clipboard.

And yes, I am sure, that I want the output completely. As I described inside code-tags.

The one line, that you reported, does alone show, that there are ownership problems. And your question, if I want all indicates, that there are a number of them.

spegru
Level 3
Level 3
Posts: 131
Joined: Sat Sep 26, 2009 5:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by spegru » Fri Jan 19, 2018 2:48 pm

OK I tried to do that but I got the following error from the forum
Your message contains 4071276 characters.
The maximum number of allowed characters is 60000
I did say it was big. Is there a way to home in on the problem?

Thanks

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by Cosmo. » Fri Jan 19, 2018 5:28 pm

I am working with this way of investigation since 3 years (and impossible to count the cases), but this has never happened until now. So I wonder, if you did something wrong. To give me at least an impression take the first 20 lines of the output and provide them here.

spegru
Level 3
Level 3
Posts: 131
Joined: Sat Sep 26, 2009 5:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by spegru » Mon Jan 22, 2018 6:59 am

I just tried that again and I noticed that nearly all (99.9%) of the output is associated with an Android SDK I have installed, that I have only ever used once! Unfortunately it results in an amazing 532 pages of output when copied into a
Libreoffice document with 8 point font! I expect it's possible to filter out all the lines that begin with "android-sdk-linux" but my skills aren't up to that
However if I look at the output and ignore all that stuff, then visually, it looks like there are only a few lines
find: ‘/home/stephen/.gnupg’: Permission denied
and
find: ‘/home/stephen/.cache/dconf’: Permission denied
find: ‘/home/stephen/.android’: Permission denied
/home/stephen/.wget-hsts

Is that any help?

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by Cosmo. » Mon Jan 22, 2018 10:18 am

The first line regarding the folder .gnupg could give a problem in this context, the others cannot. But I must eave it open, if correcting the ownership for the .gnupg folder will help.

Anyway: In your home you should be the only owner of all content. So correct this:
Mark the following command completely and make sure, that you do not miss any sign, than press ctrl-c

Code: Select all

find /home/$SUDO_USER ! -user $SUDO_USER -exec chown $SUDO_USER:$SUDO_USER '{}' \;
Open a terminal and enter

Code: Select all

sudo -i
and press the Enter-key; you get prompted for your password, enter it.
Now still in the same terminal press ctrl-shift-V
Run this command and wait until it has finished. It does not produce a readable output.
Press twice ctrl-d
Immediately log off and back into your account.

As I wrote I am in doubt, if this solves the original problem. If it does not the next suspicion goes against the TB-profile. Switching a TB-profile is a rather costly task, especially if you should use a POP3 account. So I recommend to create a fresh new user account in the system(!) (not in TB) and do the minimum settings in TB in the test account to find out, if Lightning works there as expected.
Before you ask: I do not like and use Lightning, so I cannot give specific advise. I have to reduce my advices to general experience with TB extensions.

spegru
Level 3
Level 3
Posts: 131
Joined: Sat Sep 26, 2009 5:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by spegru » Tue Jan 23, 2018 6:42 am

Ok thankyou. I have now done all that (including a full reboot) and now the output of

Code: Select all

find $HOME ! -user $USER -type f
is ..... nothing at all!

So I guess that is a lot tidier, but unfortunately it has not altered the problem.

Is it relevant that all 11 of my calenders are affected? They are mostly google but one is sogo caldav.
By the way I can also accept invites that are sent to me by other people - I just can't create invites.
And then there is the lesser, odd behaviour of seemingly not being able to save events using the save button - although they are really

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by Cosmo. » Tue Jan 23, 2018 8:34 am

Cosmo. wrote:As I wrote I am in doubt, if this solves the original problem.
Read my last advice there.

spegru
Level 3
Level 3
Posts: 131
Joined: Sat Sep 26, 2009 5:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by spegru » Wed Jan 24, 2018 7:01 am

Thanks for your help anyway.

I just realised a common point of failure between the 'Save' event button that does not work as it should, as well as the non working 'Invite Attendee' button, which is my main problem:
They are both buttons!
Thus the common point of failure seems likely to be in the GUI or perhaps the permissions behind it that allow the GUI to do anything

spegru
Level 3
Level 3
Posts: 131
Joined: Sat Sep 26, 2009 5:34 am

Re: Lightning (Thunderbird Extension) not working properly

Post by spegru » Wed Jan 24, 2018 4:41 pm

Further to that, I tested to see if any other buttons do not work but the rest all do seem to

I may have found a workaround for invitees which is to select the Invitees tab and right click, which then brings up the invitees tab in a working format.

Maybe this is just a gui bug

Post Reply

Return to “Software & Applications”