GnuCash problem with help

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
cleanman2
Level 1
Level 1
Posts: 6
Joined: Thu Jan 26, 2017 4:39 pm

GnuCash problem with help

Post by cleanman2 » Sun Jan 28, 2018 7:49 pm

I just upgraded from Mint 18 to Mint 18.3 and decided to install GnuCash from a flatpax.

It installed and runs but when I click on the entries under the Help menu I get this error: The URI ‘ghelp:gnucash-guide’ does not point to a valid page.

Googling produced no solutions.

Could someone please show me how to get help working?

Thanks, Jim

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 331
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: GnuCash problem with help

Post by Joe2Shoe » Sun Jan 28, 2018 8:01 pm

I always install GnuCash from the Software Manager. Works for me on 4 LM laptops, including help. I don't use flatpak.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 331
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: GnuCash problem with help

Post by Joe2Shoe » Sun Jan 28, 2018 8:09 pm

Okay. I found the fix for you.
Close GnuCash.
Open Software Manager and search for gnucash-docs.
Install it, then restart GnuCash.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 331
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: GnuCash problem with help

Post by Joe2Shoe » Sun Jan 28, 2018 8:20 pm

You can also download the GnuCash Tutorial and Concepts Guide .pdf here:
https://www.gnucash.org/docs/v2.6/C/gnucash-guide.pdf
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

lmuserx4849

Re: GnuCash problem with help

Post by lmuserx4849 » Sun Jan 28, 2018 8:53 pm

I noticed that applications appear to have a apt package version and a flatpak version.

I installed gnucash & gnucash-docs, but both are apt packages.

There's documentation at: http://gnucash.org/docs.phtml

Regarding flatpaks....

How do you know, before you install, what version an application is?

For gnucash, LM 18.3, the apt package shows version 2.6.12, but when you look at the flatpak, there is no version info.

Do all flatpaks come from flathub.org?
I looked at https://flathub.org/apps.html, and there is no version info, no maintainer info, no contact info for a flatpak. If there is a problem with an application's flatpak, who do you report it to?

Do flatpaks contain an application's documentation in general? Can an application installed via a flatpak, reach outside of its' container to documentation already installed on the system.

cleanman2
Level 1
Level 1
Posts: 6
Joined: Thu Jan 26, 2017 4:39 pm

Re: GnuCash problem with help

Post by cleanman2 » Sun Jan 28, 2018 10:28 pm

Joe2Shoe wrote:Okay. I found the fix for you.
Close GnuCash.
Open Software Manager and search for gnucash-docs.
Install it, then restart GnuCash.
Thanks, I didn't know about the separate docs package. I tried your suggestion but it didn't work and I didn't think that it would because I installed from a flatpax. From what I have read a flatpax sets up it's own isolated environment and runs the software in it. When I installed the docs package from software manager it ended up outside of the flatpax environment.

Using a flatpax was an experiment by me so I just uninstalled that version and reinstalled it normally from software manager, now all is well. Thanks for your help.

Regards, Jim

cleanman2
Level 1
Level 1
Posts: 6
Joined: Thu Jan 26, 2017 4:39 pm

Re: GnuCash problem with help

Post by cleanman2 » Sun Jan 28, 2018 10:35 pm

lmuserx4849 wrote:I noticed that applications appear to have a apt package version and a flatpak version.

I installed gnucash & gnucash-docs, but both are apt packages.

There's documentation at: http://gnucash.org/docs.phtml

Regarding flatpaks....

How do you know, before you install, what version an application is?

For gnucash, LM 18.3, the apt package shows version 2.6.12, but when you look at the flatpak, there is no version info.

Do all flatpaks come from flathub.org?
I looked at https://flathub.org/apps.html, and there is no version info, no maintainer info, no contact info for a flatpak. If there is a problem with an application's flatpak, who do you report it to?

Do flatpaks contain an application's documentation in general? Can an application installed via a flatpak, reach outside of its' container to documentation already installed on the system.
This is my first experience with a flatpax so I don't know the answers to your questions. I thought they were supposed to be a one click solution to software installation so I assumed the docs would be included. I am going to try find where to report the missing docs in this case and see what happens.

Regards, Jim

ent_wife
Level 1
Level 1
Posts: 4
Joined: Fri Mar 09, 2018 12:50 pm

Re: GnuCash problem with help

Post by ent_wife » Tue Aug 14, 2018 1:54 am

Au update for August 2018: I attempted to install GnuCash from Flatpak today. It was not able to load in-app documentation. There is no Flatpak Gnucash-docs package/installation. I also attempted to install the apt package gnucash-docs, but it did not change the inability of the Flatpak Gnucash to load in-app documentation.

I'm concerned about installing regular gnucash because it appears to install 41 additional libraries, and update one. I am not sure what all these libraries do, or how they will interact with whatever is already installed on this system. Is the installation and upgrade reversible?

Thanks lmuserx4849 and Joe2Shoe for pointing out other sources of GnuCash documentation.

Post Reply

Return to “Software & Applications”