firejail --overlay disables firefox internet connection

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
crusoe
Level 1
Level 1
Posts: 8
Joined: Mon Jan 29, 2018 4:00 pm

firejail --overlay disables firefox internet connection

Post by crusoe »

Hello,
I wonder if someone can help with my problem
using firejail --overlay-tmpfs
or
firejail --overlay

disables internet connection.
Is there a way to fix this issue?

thank you
User avatar
all41
Level 16
Level 16
Posts: 6683
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: firejail --overlay disables firefox internet connection

Post by all41 »

Hi crusoe,
Hey--welcome aboard the Mint forums.
It would help to know what you wish to accomplish here, and also more regarding your current software.
Please offer the terminal results of:
inxi -S
Light travels faster than sound. That's why some people appear smart until you hear what they are saying.
You will seldom see a grey-beard wearing a tinfoil hat.
crusoe
Level 1
Level 1
Posts: 8
Joined: Mon Jan 29, 2018 4:00 pm

Re: firejail --overlay disables firefox internet connection

Post by crusoe »

Hello all41,
thank you for answering.
inxi -S
System: Host: rigel Kernel: 4.13.0-32-generic x86_64 (64 bit)
Desktop: Cinnamon 3.6.7 Distro: Linux Mint 18.3 Sylvia
as per firefail manpage
running firejail --overlay-tmpfs firefox
will mount a filesystem overlay on top of the current filesystem. All filesystem modifications go into the overlay, and are discarded when the sandbox is closed.


I am running Mint as VB guest (host is slackware) alongside other guests: funtoo, devuan, slackware.
I do not have internet connection problems with other guests running firefox in firejail in the same fashion.

thank you
Elizine
Level 1
Level 1
Posts: 29
Joined: Wed Feb 10, 2016 11:29 pm

Re: firejail --overlay disables firefox internet connection

Post by Elizine »

Maybe it is the DNS setting, try this command:

Code: Select all

$ firejail --noprofile --overlay --dns=8.8.8.8
Also, do a "netstat -rn" inside the sandbox, just to make sure the default gateway is configured.

To disable network namespace use --net=none:

Code: Select all

$ firejail --net=none
crusoe
Level 1
Level 1
Posts: 8
Joined: Mon Jan 29, 2018 4:00 pm

Re: firejail --overlay disables firefox internet connection

Post by crusoe »

Thank you Elizine
adding --dns=x.x.x.x
helped
interesting aspects:
Mint is the only VB guest having this issue
evidently not all directives are causing the problem:
firefail --seccomp --noprofile firefox
works without specifying gateway.

these do not work:
firefail --overlay firefox
firefail --overlay-tempfs firefox
firefail --net-none firefox

adding --dns=x.x.x.x
firefail --overlay-tempfs --dns=x.x.x.x firefox
works
evidently for some directives I have to specify gateway. Not sure why.
I would assume that this has some to do with my specific setup that Mint does not like although same setup works for other virtual guests.

Thank you again
Post Reply

Return to “Software & Applications”