Broken package

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Broken package

Post by riki » Mon Feb 05, 2018 1:44 pm

I am running Sylvia 18.3 and have a broken package which I have tried to fix unsuccessfully.
Details as follows: dpkg: error: parsing file '/var/lib/dpkg/status' near line 44171 package 'libtalloc2:i386':
field name '!reference' must be followed by colon
E: Sub-process /usr/bin/dpkg returned an error code (2)
A package failed to install. Trying to recover:

Would appreciate help, thanks.

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Broken package

Post by minitux » Mon Feb 05, 2018 1:55 pm

Code: Select all

sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-old1  

Code: Select all

sudo mv /var/lib/dpkg/status-old /var/lib/dpkg/status

Code: Select all

sudo dpkg --configure -a

Code: Select all

sudo apt install -f

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Broken package

Post by riki » Mon Feb 05, 2018 2:15 pm

Thanks minitux but none of your commands work, my password is not accepted. See output below.
Last edited by riki on Mon Feb 05, 2018 3:09 pm, edited 1 time in total.

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Broken package

Post by riki » Mon Feb 05, 2018 3:08 pm

Code: Select all

System:    Host: riki-System-Product-Name Kernel: 4.13.0-32-generic i686 (32 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: M2N68-AM SE2 v: Rev X.0x
           Bios: American Megatrends v: 1002 date: 09/22/2009
CPU:       Dual core AMD Athlon 7550 (-MCP-) cache: 1024 KB
           flags: (lm nx pae sse sse2 sse3 sse4a svm) bmips: 10045
           clock speeds: max: 2511 MHz 1: 2511 MHz 2: 2511 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 02:00.0
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1600x900@60.00hz
           GLX Renderer: Gallium 0.4 on NVA8
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 NVIDIA MCP61 High Definition Audio
           driver: snd_hda_intel bus-ID: 00:05.0
           Card-2 NVIDIA High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 02:00.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card: NVIDIA MCP61 Ethernet
           driver: forcedeth port: d480 bus-ID: 00:07.0
           IF: enp0s7 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 250.1GB (9.8% used)
           ID-1: /dev/sda model: WDC_WD2500AAJS size: 250.1GB
Partition: ID-1: / size: 228G used: 21G (10%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.15GB used: 0.47GB (22%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 38.0C mobo: 30.0C gpu: 34.0
           Fan Speeds (in rpm): cpu: 3068 sys-1: 1268
Info:      Processes: 207 Uptime: 1:49 Memory: 1224.6/2012.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
riki@riki-System-Product-Name ~ $
Last edited by Moem on Mon Feb 05, 2018 3:11 pm, edited 1 time in total.
Reason: Adding [code] tags. They retain some formatting that makes your output easier to read.

Post Reply

Return to “Software & Applications”