gopro

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
morganandre
Level 1
Level 1
Posts: 1
Joined: Mon Feb 05, 2018 6:11 pm

gopro

Post by morganandre » Mon Feb 05, 2018 6:17 pm

Hi I am new to Linux and not very computer savvy. I have a GOPRO Hero 4, and I can't seem to get the videos off the GOPRO. It brings me to the PIX Software to take off pictures from the camera, but I do not have any pictures just videos, and when I click the video tab there is nothing that shows up. What software or application do I need to have to make this work.

Thank you

User avatar
prestonR
Level 5
Level 5
Posts: 844
Joined: Wed Jan 07, 2015 12:24 pm
Location: Harare

Re: gopro

Post by prestonR » Tue Feb 06, 2018 9:41 am

The big one is Kdenlive, a more manageable smaller app is Openshot. How and if they handle the import correctly I cannot say since I usually just put the card in a reader and copy the footage to my data drive.

If you download UbuntuStudio 17.04 and burn it to a USB3 drive you can try both (and check out others) and see what you like best. Also check the version numbers; UbuntuStudio has much more recent versions then what's on offer from the Mint repos, in the case of Kdenlive it really matters.

If you plan to get serious, I would rather install UbuntuStudio as a dualboot (if you had no probs installing Mint then that should be done in 20min) then adding an older Kdenlive to your existing Mint. All video software is very complex and needs the whole system to play along nicely; UbuntuStudio does this out-of-the-box and comes with a real-time kernel, Mint is meant for a much wider use.

User avatar
Flemur
Level 14
Level 14
Posts: 5012
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: gopro

Post by Flemur » Tue Feb 06, 2018 10:08 am

morganandre wrote:What software or application do I need to have to make this work.
With the camera USB connected, have you tried navigating to the camera with your file-browser? It should show up under 'places' or something similar.

Edit: Like this:
https://community.gopro.com/t5/Cameras/ ... td-p/64558
Running on firmware version 5, and hooking up via USB to Linux. - (latest kernels, freshly updated, so not old versions of Linux)
I can copy the files off with no problem, but when I try and "move" the files, an error happens and all files are deleted from the card. So I only get the first file safely... all the others vanish.
So, "copy", don't "move!" (always a good idea anyway)
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Hoser Rob
Level 10
Level 10
Posts: 3184
Joined: Sat Dec 15, 2012 8:57 am

Re: gopro

Post by Hoser Rob » Wed Feb 07, 2018 11:21 am

You could try reading this ...

http://bernaerts.dyndns.org/linux/74-ub ... access-bug

... though before trying the suggested fix, make sure you don't already have the newer version. Copy/paste this to the terminal to see:

Code: Select all

apt-cache policy libgphoto2

Post Reply

Return to “Software & Applications”