Can't install Virtualbox-qt

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
DoctorVell
Level 1
Level 1
Posts: 6
Joined: Thu Feb 01, 2018 11:50 am
Location: San Antonio, Texas
Contact:

Can't install Virtualbox-qt

Post by DoctorVell » Thu Feb 08, 2018 11:07 am

Hi there, I am currently running LinuxMint 18.2 I just installed this version because I found out what was wrong with my 18.3 version (it doesn't support my hardware). Anyway,I am trying to install Virtualbox-qt and this is what I get

drsv@DRSV ~ $ sudo apt-get install virtualbox-qt
[sudo] password for drsv:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
libgsoap8 libvncserver1 virtualbox virtualbox-dkms
Suggested packages:
vde2 virtualbox-guest-additions-iso
The following NEW packages will be installed:
libgsoap8 libvncserver1 virtualbox virtualbox-dkms virtualbox-qt
0 upgraded, 5 newly installed, 0 to remove and 384 not upgraded.
E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/cache/apt/archives/
drsv@DRSV ~ $

I know at one time I had to edit the sources.list file to get this to work, but I forgot what to do. Please help...This is from a direct Live CD install.

Thanks :)
Last edited by Moem on Thu Feb 08, 2018 11:27 am, edited 1 time in total.
Reason: A more descriptive title will often result in better or faster answers.
Doctor Vell ----- http://www.doctorvell.com

Level: Amateur (for now)
Kernel: 4.4.0-53-generic x86_64
Desktop: Cinnamon 3.2.7
Distro: Linux Mint 18.1 Serena

User avatar
WharfRat
Level 20
Level 20
Posts: 11571
Joined: Thu Apr 07, 2011 8:15 pm

Re: Can't install Virtualbox-qt

Post by WharfRat » Thu Feb 08, 2018 3:39 pm

According to the Could not get lock /var/cache/apt/archives/lock message maybe update manager was running at the time you were trying to install the package.

If that's not the case then just remove the lock file with sudo rm /var/cache/apt/archives/lock
ImageImage

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Can't install Virtualbox-qt

Post by Cosmo. » Thu Feb 08, 2018 4:01 pm

Depending from the kernel you use be prepared for problems with this VB version, a complete freeze of the host when you're running a VM is possible.

DoctorVell
Level 1
Level 1
Posts: 6
Joined: Thu Feb 01, 2018 11:50 am
Location: San Antonio, Texas
Contact:

Re: Can't install Virtualbox-qt

Post by DoctorVell » Fri Feb 09, 2018 10:50 am

I got it to work...thank-you I just did the sudo rm /var/cache/apt/archives/lock command it works perfectly now.

Thank-you again!
Doctor Vell ----- http://www.doctorvell.com

Level: Amateur (for now)
Kernel: 4.4.0-53-generic x86_64
Desktop: Cinnamon 3.2.7
Distro: Linux Mint 18.1 Serena

Post Reply

Return to “Software & Applications”