Multiple versions of Blender crashing upon program launch

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Sat Feb 17, 2018 4:38 pm

Multiple versions of Blender crashing upon program launch

Post by Brian802 » Sat Feb 17, 2018 5:05 pm


I would like some help installing Blender on my EEE Slate. Since I'm new to Linux I think there's a high chance I missed something obvious.

I tried installing version 2.76 from Apps, and also downloading the latest version from the official website and extracting to the home folder. My current install is Blender 2.79 via PPA:

Code: Select all

$ sudo add-apt-repository ppa:thomas-schiex/blender
$ sudo apt-get update
$ sudo apt-get install blender
With all the methods I tried, when launching Blender, a greyed-filled Blender window opens and closes after a couple seconds. I'm wondering if there is anything I need to additionally install or update.

Asus EEE Slate
Linux Mint 18.3 XFCE
Intel Core i5 U 470, open-source microcode version 3.2018018.0+really20170707ubuntu16.04.1
OpenGL version string: 2.1 Mesa 17.2.4

Blender's crashlog:

Code: Select all

# Blender 2.79 (sub 0), Unknown revision

# backtrace
/usr/lib/blender/blender(BLI_system_backtrace+0x30) [0x17914d0]
/usr/lib/blender/blender() [0xd2b9d1]
/lib/x86_64-linux-gnu/ [0x7f4a16f374b0]
/usr/lib/x86_64-linux-gnu/dri/ [0x7f49ea2f5eb6]
/usr/lib/x86_64-linux-gnu/dri/ [0x7f49ea2f7559]
/usr/lib/x86_64-linux-gnu/dri/ [0x7f49ea2e4468]
/usr/lib/x86_64-linux-gnu/dri/ [0x7f49ea2e5345]
/usr/lib/x86_64-linux-gnu/dri/ [0x7f49ea1064da]
/usr/lib/x86_64-linux-gnu/dri/ [0x7f49ea106ddd]
/usr/lib/x86_64-linux-gnu/dri/ [0x7f49ea13d333]
/usr/lib/x86_64-linux-gnu/dri/ [0x7f49e9e8b12e]
/usr/lib/x86_64-linux-gnu/dri/ [0x7f49e9e90da3]
/usr/lib/blender/blender() [0xd2f76d]
/usr/lib/blender/blender(wm_draw_update+0x882) [0xd312b2]
/usr/lib/blender/blender(WM_main+0x28) [0xd2c678]
/usr/lib/blender/blender(main+0x376) [0xce5b96]
/lib/x86_64-linux-gnu/ [0x7f4a16f22830]
/usr/lib/blender/blender(_start+0x29) [0xd28689]

Post Reply

Return to “Software & Applications”