Error on python update

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
futex
Level 1
Level 1
Posts: 37
Joined: Fri Apr 04, 2014 5:31 pm

Error on python update

Post by futex » Wed Feb 21, 2018 6:40 am

Hello,

I'm on Mint 18.3, and yesterday where was a update off the python packages, but when i do the upgrade, i have an error:

Code: Select all

Need to get 0 B / 95.0 MB of archives. After unpacking 32.8 kB will be used.
Do you want to continue? [Y / n /?] Y
Extraction of models from packages: 100%
Preconfiguration of packages ...
Parameterization of python-minimal (2.7.12-1 ~ 16.04) ...
dpkg: python-minimal package (--configure) processing error:
 the installed post-installation script subprocess returned a status output error 1
Errors were encountered during execution:
 python-minimal
E: Subprocess / usr / bin / dpkg returned an error code (1)
Failed to perform the requested operation on package. Trying to recover:
dpkg: dependency issues prevent python-dev configuration:
 python-dev depends on python (= 2.7.12-1 ~ 16.04); however:
  The version of python on the system is 2.7.11-1.

dpkg: python-dev package (--configure) processing error:
 dependency issues - left unconfigured
Parameterization of python-minimal (2.7.12-1 ~ 16.04) ...
dpkg: python-minimal package (--configure) processing error:
 the installed post-installation script subprocess returned a status output error 1
Errors were encountered during execution:
 python-dev
 python-minimal
I have try to upgrade it manualy, when dpkg etc.. But it still failed. Anyone have a solution?

Thank you

User avatar
Lord Boltar
Level 4
Level 4
Posts: 382
Joined: Mon Jan 09, 2017 7:24 pm

Re: Error on python update

Post by Lord Boltar » Wed Feb 21, 2018 11:43 pm

dependency issues prevent python-dev configuration:
python-dev depends on python (= 2.7.12-1 ~ 16.04); however:
The version of python on the system is 2.7.11-1.

you will have to upgrade Python before installing the Python-Dev

Go to your Synaptic package manager - in the search box type in python and select python 2.7.12-1~16.04 and install then install
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

futex
Level 1
Level 1
Posts: 37
Joined: Fri Apr 04, 2014 5:31 pm

Re: Error on python update

Post by futex » Thu Feb 22, 2018 4:54 am

i wanted to do it, but it want to install python-minimal first

Code: Select all

apt-get install python
Reading package lists ... Done
Building the dependency tree
Reading status information ... Done
Suggested packages:
   python-doc python-tk
The following packages will be updated:
   python
1 updated, 0 newly installed, 0 removed and 93 not updated.
1 partially installed or removed.
It is necessary to take 0 o / 137 ko in the archives.
After this operation, 0 o of additional disk space will be used.
Parameterization of python-minimal (2.7.12-1 ~ 16.04) ...
dpkg: python-minimal package (--configure) processing error:
  the installed post-installation script subprocess returned a status output error 1
Errors were encountered during execution:
  python-minimal
E: Subprocess / usr / bin / dpkg returned an error code (1)
And the python package appear to be be broken in synaptic.

User avatar
Lord Boltar
Level 4
Level 4
Posts: 382
Joined: Mon Jan 09, 2017 7:24 pm

Re: Error on python update

Post by Lord Boltar » Thu Feb 22, 2018 12:01 pm

IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

futex
Level 1
Level 1
Posts: 37
Joined: Fri Apr 04, 2014 5:31 pm

Re: Error on python update

Post by futex » Thu Feb 22, 2018 12:18 pm

I don't understand what do you mean, i have a problem with the version 2.7 not the 3.6.
And me version doen't come from an external repository

Code: Select all

apt-cache policy python                                                                                                                                                                                    ✓  4.2.6 ⬢ 
python:
  Installé : 2.7.11-1
  Candidat : 2.7.12-1~16.04
 Table de version :
     2.7.12-1~16.04 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
 *** 2.7.11-1 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status

futex
Level 1
Level 1
Posts: 37
Joined: Fri Apr 04, 2014 5:31 pm

Re: Error on python update

Post by futex » Wed Feb 28, 2018 8:38 am

Anyone have a solution, i always have this problem. The python package appear to be broken

Code: Select all

BB  python                                                     - interactive high-level object-oriented language (default version)

Post Reply

Return to “Software & Applications”