Unable to get snap packages to work in 18.3

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
mcarvalho
Level 1
Level 1
Posts: 2
Joined: Thu Feb 22, 2018 8:46 am

Unable to get snap packages to work in 18.3

Post by mcarvalho » Thu Feb 22, 2018 8:52 am

I'm on 18.3 Sylvia and can't get Snap packages to work as expected. For example, when I go to the snap website and find an application I want to install, I click on the "Install" button but nothing happens! "snap://" URLs don't seem to resolve.

I did install the snapd flatpak and I tried via the command line to install packages but it still doesn't work as expected. I always have to run snap to run the apps when I would like to have it run like any other installed app, which I can run directly.

Any advice?

User avatar
kc1di
Level 13
Level 13
Posts: 4645
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Unable to get snap packages to work in 18.3

Post by kc1di » Thu Feb 22, 2018 10:33 am

Hello mcarvalho and welcome to Linux Mint Forums,

Snap is not support in mint yet. They do support Flatpaks though.
I've also found that the appimages I have tried work as well.
You can read the reasoning behind this choice on the Oct 2017 blog found here:
https://blog.linuxmint.com/?p=3418

that's not saying that with the right files and packages you can't get snap to work , it's just that it's not supported out of the box.
But it will take some work on your part to figure out what's needed.
good luck :)
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Post Reply

Return to “Software & Applications”