[SOLVED] Can't install Virtual Box 5.2....conflicting/missing dependencies

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
borg101
Level 4
Level 4
Posts: 204
Joined: Tue Oct 25, 2016 9:00 pm

[SOLVED] Can't install Virtual Box 5.2....conflicting/missing dependencies

Post by borg101 » Sun Feb 25, 2018 12:20 pm

I had VB 5.2 installed and was trying to install guest additions so I could see shared folders from my host. I followed this guide and ran

Code: Select all

sudo apt-get install virtualbox-guest-additions-iso
and somehow that uninstalled VB 5.2. So, I installed VB from the software center, which I forgot was 5.0 and has issues with Windows 10 VM's. I started the VM and it locked my system which took me into grub for some reason. When I selected regular startup, I was greeted with a black screen and it just hung there until I reset it again. Same thing happened the next time. On my 3rd reboot, I selected to boot with an older kernel and I was back in. So I purged everything to do with VB in terminal. I just downloaded the 5.2 .deb package from VB's main site and I was greeted with "Error: Dependency is not satisfiable: libqtcore5a (>=5.6.0~beta)". So, I tried installing libqt5core5a and got "Error: Breaks existing package 'qtbase5-dev' dependency libqt5core5a(=5.5.1 +dfsg-16ubuntu7.5)".

I don't even want to google anymore to troubleshoot because I'm afraid I'll further mess up my system.
Last edited by borg101 on Sun Feb 25, 2018 12:25 pm, edited 1 time in total.
Mobo: ASRock model: Z97E-ITX | CPU: Quad core Intel Core i5-4690 | GPU: NVIDIA GM206 [GeForce GTX 960] | RAM: 16GB DDR3 | SSD/HDD: Total Size: 8251.6GB | OS: Mint 19 (Cinnamon/Gnome)

User avatar
borg101
Level 4
Level 4
Posts: 204
Joined: Tue Oct 25, 2016 9:00 pm

Re: Can't install Virtual Box 5.2....conflicting/missing dependencies

Post by borg101 » Sun Feb 25, 2018 12:25 pm

NM....figured it out. I was trying to install the yakkety version instead of xenial.
Mobo: ASRock model: Z97E-ITX | CPU: Quad core Intel Core i5-4690 | GPU: NVIDIA GM206 [GeForce GTX 960] | RAM: 16GB DDR3 | SSD/HDD: Total Size: 8251.6GB | OS: Mint 19 (Cinnamon/Gnome)

Post Reply

Return to “Software & Applications”