Firefox Quantum rendering extremely choppy and slow

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
FullOfCaffeine
Level 1
Level 1
Posts: 10
Joined: Sat Mar 03, 2018 12:33 pm

Firefox Quantum rendering extremely choppy and slow

Post by FullOfCaffeine » Sat Mar 03, 2018 12:47 pm

Hi there!

First of all, let me say I'm very impressed with Mint 18.3. I've been using it for over a month on my `Dell XPS 9550` and overall it works well.

I did have some issues which I *guess* are related to the Nvidia proprietary drivers. First, I noticed that the overall graphics performance was lower than my previous Macbook Pro 2014, even for Chrome. The rendering performance of Cinnamon is also not 100% (sometimes alt+tab takes almost a second to render), although for now it's very usable. I think I found a sweet (although not perfect) spot in the `nvidia-387.34` driver.

Chrome renderins is acceptable (although not perfect, as I mentioned above) but it's a huge CPU and memory hog, and even more on Mint, for some reason (comparing to macOS). I then wanted to try Firefox Quantum after reading good reviews about it: The native GUI works great and it does use less resources than Chrome (even battery time is greater when using it) but the web page rendering performance is horrible. Even scrolling the page is far from smooth, it just struggles for some reason.

Does anyone know why? Is this a known issue? If someone has some tips on how to fix the Firefox issues or the overall Nvidia issues with Mint, I'd be grateful.

Detailed system info: https://pastebin.com/8Br4vJwA

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Firefox Quantum rendering extremely choppy and slow

Post by greerd » Sun Mar 04, 2018 10:11 am

Hi FullOfCaffeine and welcome to the forum,

I glanced over your linked specs and the specs for your XPS 9550 (I'm jealous!) it looks to me that you shouldn't be having any issues with any browser.
Can you post some more info about your setup by posting the output of the following terminal command withing the code tags. (the '</>' icon)

Code: Select all

inxi -Fxz
Some things you could try:

- What's your GPU utilization, in a terminal what does nvidia-smi -q -d UTILIZATION show?

- Run Menu - Administration - System monitor, click the Processes tab then click the % CPU column header to sort processes by CPU usage. Maybe something is hogging the cpu.

- I'm not familiar with this but does the Nvidia X Server Settings app show the option to boot to/from nvidia/intel? (Nvidia Prime)

- Try disabling hardware acceleration in firefox, see Pjotr's tips #6 here although I doubt thats the issue, but maybe worth a shot.

Cheers

FullOfCaffeine
Level 1
Level 1
Posts: 10
Joined: Sat Mar 03, 2018 12:33 pm

Re: Firefox Quantum rendering extremely choppy and slow

Post by FullOfCaffeine » Tue Mar 06, 2018 6:10 am

Hi @greerd, thanks a lot for taking the time to look into my issue and for the reply!

Here's the info you've requested:

Code: Select all

System:    Host: XPS-15-9550 Kernel: 4.13.0-36-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 2.24.30) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: XPS 15 9550
           Mobo: Dell model: 0N7TVV v: A01 Bios: Dell v: 1.2.25 date: 05/07/2017
CPU:       Quad core Intel Core i7-6700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 20736
           clock speeds: max: 2600 MHz 1: 2600 MHz 2: 2600 MHz 3: 2600 MHz 4: 2600 MHz 5: 2600 MHz 6: 2600 MHz
           7: 2600 MHz 8: 2600 MHz
Graphics:  Card-1: Intel Skylake Integrated Graphics bus-ID: 00:02.0
           Card-2: NVIDIA GM107M [GeForce GTX 960M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 3840x2160@60.00hz
           GLX Renderer: GeForce GTX 960M/PCIe/SSE2 GLX Version: 4.6.0 NVIDIA 387.34 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-36-generic
Network:   Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Atheros usb-ID: 001-002
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: NA (-) ID-1: /dev/nvme0n1 model: N/A size: 1024.2GB
Partition: ID-1: / size: 886G used: 450G (54%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 473M used: 422M (95%) fs: ext2 dev: /dev/nvme0n1p2
           ID-3: swap-1 size: 34.20GB used: 0.09GB (0%) fs: swap dev: /dev/dm-3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 54.5C mobo: N/A gpu: 0.0:57C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 350 Uptime: 2 days Memory: 10724.1/32021.4MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (zsh 5.1.1) inxi: 2.2.35 
> - What's your GPU utilization, in a terminal what does nvidia-smi -q -d UTILIZATION show?

Code: Select all

==============NVSMI LOG==============

Timestamp                           : Tue Mar  6 10:05:12 2018
Driver Version                      : 387.34

Attached GPUs                       : 1
GPU 00000000:01:00.0
    Utilization
        Gpu                         : 0 %
        Memory                      : 0 %
        Encoder                     : 0 %
        Decoder                     : 0 %
    GPU Utilization Samples
        Duration                    : 18446744073709.22 sec
        Number of Samples           : 99
        Max                         : 99 %
        Min                         : 0 %
        Avg                         : 0 %
    Memory Utilization Samples
        Duration                    : 18446744073709.22 sec
        Number of Samples           : 99
        Max                         : 15 %
        Min                         : 0 %
        Avg                         : 0 %
    ENC Utilization Samples
        Duration                    : 18446744073709.22 sec
        Number of Samples           : 99
        Max                         : 0 %
        Min                         : 0 %
        Avg                         : 0 %
    DEC Utilization Samples
        Duration                    : 18446744073709.22 sec
        Number of Samples           : 99
        Max                         : 0 %
        Min                         : 0 %
        Avg                         : 0 %
- Run Menu - Administration - System monitor, click the Processes tab then click the % CPU column header to sort processes by CPU usage. Maybe something is hogging the cpu.
Here's a screenshot of the output: https://clb.sh/e21379. TL;DS: There doesn't seem to be any CPU-hogging processes.
- I'm not familiar with this but does the Nvidia X Server Settings app show the option to boot to/from nvidia/intel? (Nvidia Prime)
I don't know. I'm not sure if this laptop has an Intel graphics card? How can I make sure that nvidia is being used? Maybe the info I pasted above confirms it somehow?
- Try disabling hardware acceleration in firefox, see Pjotr's tips #6 here although I doubt thats the issue, but maybe worth a shot.
I did that for Chrome once, but the results were subpar and it ran worse. I'll try with Firefox but ideally, I'd like to leave it on, if possible.

I must mention that the slowdown sometimes seems to be system-wide. Even alt-tab'ing takes almost a second to render (randomly, happens sometimes, not sure how to properly reproduce), for some reason. The overall Cinnamon experience sometimes doesn't feel smooth. And for example, I'm typing now in this textbox on Chrome and I feel how it struggles to handle the input and render the chars in the textbox, it's usable but far from smooth :(

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Firefox Quantum rendering extremely choppy and slow

Post by greerd » Tue Mar 06, 2018 7:18 am

I can see one issue
ID-2: /boot size: 473M used: 422M (95%) fs: ext2 dev: /dev/nvme0n1p2
Your /boot partition is almost full (95% full) which will cause issues.

Also
ID-1: / size: 886G used: 450G (54%) fs: ext4 dev: /dev/dm-1
its not full but not standard (I don't think) Did you use 'Something Else' when doing your install and are you using LVM?

Lets get more info, please post the output of

Code: Select all

lslk
.

But whether you're using LVM or not, your /boot is full we need to decrease the amount of data on it. I would suggest that you remove all but two installed kernels, the one your running and the last good one. Kernels can be removed by opening Update Manager - View - Linux kernels.

FullOfCaffeine
Level 1
Level 1
Posts: 10
Joined: Sat Mar 03, 2018 12:33 pm

Re: Firefox Quantum rendering extremely choppy and slow

Post by FullOfCaffeine » Tue Mar 06, 2018 9:09 am

I can see one issue
ID-2: /boot size: 473M used: 422M (95%) fs: ext2 dev: /dev/nvme0n1p2
Your /boot partition is almost full (95% full) which will cause issues.

Also
ID-1: / size: 886G used: 450G (54%) fs: ext4 dev: /dev/dm-1
its not full but not standard (I don't think) Did you use 'Something Else' when doing your install and are you using LVM?
Hmm, I actually don't remember if I chose to use LVM. How can I check? I did let the installer partition everything though and enabled full disk-encryption. What are the consequences of an almost full boot partition? What is `ID-1`?
Lets get more info, please post the output of
CODE: SELECT ALL

lslk
I don't seem to have this command installed and I couldn't install it (`sudo apt-get install lslk`).
But whether you're using LVM or not, your /boot is full we need to decrease the amount of data on it. I would suggest that you remove all but two installed kernels, the one your running and the last good one. Kernels can be removed by opening Update Manager - View - Linux kernels.
I'll do that. Any hints on why would this happen? I'm not fiddling with this machine, in fact, I'm pretty sure I left pretty much everything on default when installing to avoid further headaches, as I was migrating from macOS, and wanted a more stable Linux experience. I did activate TimeShift though as it's part of my backup strategy, maybe it has to do with that?

Thanks again for the help!

User avatar
Sir Charles
Level 7
Level 7
Posts: 1832
Joined: Thu Jan 04, 2018 1:00 pm

Re: Firefox Quantum rendering extremely choppy and slow

Post by Sir Charles » Tue Mar 06, 2018 9:16 am

I think there is a "b" missing in that command. Try:

Code: Select all

lsblk
Edit: I am sorry, I just made an assumption.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Firefox Quantum rendering extremely choppy and slow

Post by greerd » Tue Mar 06, 2018 10:20 am

Marziano wrote:
Tue Mar 06, 2018 9:16 am
I think there is a "b" missing in that command. Try:

Code: Select all

lsblk
Edit: I am sorry, I just made an assumption.
Oops, you are correct, thanks!

FullOfCaffeine
Level 1
Level 1
Posts: 10
Joined: Sat Mar 03, 2018 12:33 pm

Re: Firefox Quantum rendering extremely choppy and slow

Post by FullOfCaffeine » Tue Mar 06, 2018 10:32 am

@Marziano, thanks!

@greerd Here's the output:

Code: Select all

NAME                  MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
nvme0n1               259:0    0 953.9G  0 disk  
├─nvme0n1p3           259:3    0 952.9G  0 part  
│ └─nvme0n1p3_crypt   253:0    0 952.9G  0 crypt 
│   ├─mint--vg-root   253:1    0 899.5G  0 lvm   /
│   └─mint--vg-swap_1 253:2    0  31.9G  0 lvm   
│     └─cryptswap1    253:3    0  31.9G  0 crypt [SWAP]
├─nvme0n1p1           259:1    0   512M  0 part  /boot/efi
└─nvme0n1p2           259:2    0   488M  0 part  /boot
EDIT: So it seems I'm indeed using LVM. I don't understand it very well though - not sure if there are any beneifts or downsides to using it? Maybe I should've installed without it?

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Firefox Quantum rendering extremely choppy and slow

Post by greerd » Tue Mar 06, 2018 11:26 am

FullOfCaffeine wrote:
Tue Mar 06, 2018 10:32 am
@Marziano, thanks!

@greerd Here's the output:

Code: Select all

NAME                  MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
nvme0n1               259:0    0 953.9G  0 disk  
├─nvme0n1p3           259:3    0 952.9G  0 part  
│ └─nvme0n1p3_crypt   253:0    0 952.9G  0 crypt 
│   ├─mint--vg-root   253:1    0 899.5G  0 lvm   /
│   └─mint--vg-swap_1 253:2    0  31.9G  0 lvm   
│     └─cryptswap1    253:3    0  31.9G  0 crypt [SWAP]
├─nvme0n1p1           259:1    0   512M  0 part  /boot/efi
└─nvme0n1p2           259:2    0   488M  0 part  /boot
EDIT: So it seems I'm indeed using LVM. I don't understand it very well though - not sure if there are any beneifts or downsides to using it? Maybe I should've installed without it?
You have encrypted your '/' directory so this is probably why LVM was used, so I think we should get the /boot problem sorted out and see what happens.
If you uninstalled some unused kernels you can run the command inxi -P in a terminal to see how much removing the kernels freed up your /boot. I would expect that you'll want to get that at least down in the mid 80 percentiles to ensure that this isn't an issue. Generally speaking, full partitions bog down the whole system and anything over 90% full is almost certain to cause problems, although I not sure if a full /boot partition would effect the / partition. The / partition in your case is the everything except /boot and swap.

Normally one can use GParted from a live system to create more space for you /boot at the expense of the neighboring partition. But I'm not familiar with encrypted partitions so can't say if you can do this safely. Hopefully someone will jump in with some more info.

EDIT: Changed 'inxi -D' to 'inxi -P'

FullOfCaffeine
Level 1
Level 1
Posts: 10
Joined: Sat Mar 03, 2018 12:33 pm

Re: Firefox Quantum rendering extremely choppy and slow

Post by FullOfCaffeine » Thu Mar 08, 2018 6:49 am

Here's the output of `inxi -P`:

Code: Select all

 inxi -P                                                                                [2.5.0]
Partition: ID-1: / size: 886G used: 452G (54%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 473M used: 139M (31%) fs: ext2 dev: /dev/nvme0n1p2
           ID-3: swap-1 size: 34.20GB used: 0.28GB (1%) fs: swap dev: /dev/dm-3
I think there's enough space, for now, right?

Firefox is still struggling to render stuff. Youtube videos run like a slideshow :(

Chrome plays Youtube videos relatively well, but there are still some "image cuts" sometimes because of slow rendering. It's really puzzling to me how a laptop like this can have a rendering performance that's not fast enough. Maybe it has to do with the 4k res?

Maybe someone else with a 4k (using a Nvidia card) display or a similar laptop could report, too?

Thanks!

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Firefox Quantum rendering extremely choppy and slow

Post by greerd » Thu Mar 08, 2018 2:18 pm

FullOfCaffeine wrote:
Thu Mar 08, 2018 6:49 am
Here's the output of `inxi -P`:

Code: Select all

 inxi -P                                                                                [2.5.0]
Partition: ID-1: / size: 886G used: 452G (54%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 473M used: 139M (31%) fs: ext2 dev: /dev/nvme0n1p2
           ID-3: swap-1 size: 34.20GB used: 0.28GB (1%) fs: swap dev: /dev/dm-3
I think there's enough space, for now, right?
Yes, that looks good, now we know its not the source of the problem.
Firefox is still struggling to render stuff. Youtube videos run like a slideshow :(

Chrome plays Youtube videos relatively well, but there are still some "image cuts" sometimes because of slow rendering. It's really puzzling to me how a laptop like this can have a rendering performance that's not fast enough. Maybe it has to do with the 4k res?

Maybe someone else with a 4k (using a Nvidia card) display or a similar laptop could report, too?

Thanks!
Yes, hopefully someone else will jump in here!

In the mean time you inxi output shows
Graphics: Card-1: Intel Skylake Integrated Graphics bus-ID: 00:02.0
Card-2: NVIDIA GM107M [GeForce GTX 960M] bus-ID: 01:00.0
Display Server: X.Org 1.18.4 driver: nvidia Resolution: 3840x2160@60.00hz
GLX Renderer: GeForce GTX 960M/PCIe/SSE2 GLX Version: 4.6.0 NVIDIA 387.34 Direct Rendering: Yes
that you do have two graphics cards. Have you tried switching between Nvidia and Intel gpu using Prime select?

FullOfCaffeine
Level 1
Level 1
Posts: 10
Joined: Sat Mar 03, 2018 12:33 pm

Re: Firefox Quantum rendering extremely choppy and slow

Post by FullOfCaffeine » Fri Mar 09, 2018 5:49 am

that you do have two graphics cards. Have you tried switching between Nvidia and Intel gpu using Prime select?
How do I go about making sure which one is being used / force-select one of them?

By looking at my systems settings, it seems the Intel card is being used: https://clb.sh/a89c1f; but if I check `nvidia-settings`, it says the NVIDIA card is the one active: https://clb.sh/b5f082.

Thanks.

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Firefox Quantum rendering extremely choppy and slow

Post by greerd » Fri Mar 09, 2018 8:31 am

One thing that doesn't make sense to me it the sample duration of your nvidia-smi -q -d UTILIZATION output. Duration : 18446744073709.22 sec (584 thousand years)? It must of used carbon dating for that! I'm using a desktop with a GTX 970 and my duration varies but it's always around 12 or 16 seconds.

I guess if you are utilizing the nvidia card it should be using power, what does nvidia-smi -q -d POWER show, specifically the 'Power Draw'. I just ran the command and my Duration is 11.80 seconds, is your still some ridiculous number?

I think you can choose Intel(Power Saving Mode) from Nvidia-settings, reboot, check the setting to confirm it switched and test it out by running a video in FireFox.

There should be an Nvidia-Prime tray icon, if not you can enable; Menu - Preferences - Startup Applications - Support for NVIDIA Prime.

Is there another nvidia driver available in Driver Manager? Maybe give that a try.

FullOfCaffeine
Level 1
Level 1
Posts: 10
Joined: Sat Mar 03, 2018 12:33 pm

Re: Firefox Quantum rendering extremely choppy and slow

Post by FullOfCaffeine » Fri Mar 09, 2018 5:08 pm

I guess if you are utilizing the nvidia card it should be using power, what does nvidia-smi -q -d POWER show, specifically the 'Power Draw'. I just ran the command and my Duration is 11.80 seconds, is your still some ridiculous number?
Wow, I just ran it and it shows `N/A` instead! What the...

Code: Select all


==============NVSMI LOG==============

Timestamp                           : Fri Mar  9 21:05:52 2018
Driver Version                      : 387.34

Attached GPUs                       : 1
GPU 00000000:01:00.0
    Power Readings
        Power Management            : N/A
        Power Draw                  : N/A
        Power Limit                 : N/A
        Default Power Limit         : N/A
        Enforced Power Limit        : N/A
        Min Power Limit             : N/A
        Max Power Limit             : N/A
    Power Samples
        Duration                    : N/A
        Number of Samples           : N/A
        Max                         : N/A
        Min                         : N/A
        Avg                         : N/A
Does the log above make any sense? Maybe there's indeed some misconfiguration going one here, with the NVIDIA driver... :/

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Firefox Quantum rendering extremely choppy and slow

Post by greerd » Fri Mar 09, 2018 6:37 pm

Something not right, that's for sure, was nvidia selected in nvidia-settings or was this after you selected intel and rebooted?

If nvidia was selected I guess you could try purging, adding the drivers PPA (newer drivers) and installing the latest driver from the PPA.

Just to be sure, you should backup your user data in case things go south. Or hopefully this is a fresh install with nothing to backup.

One line at a time, from the terminal, you will be asked for your password the first time, enter in blindly because there is no visual feedback.

Code: Select all

sudo apt-get purge nvidia*
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-390
sudo reboot

FullOfCaffeine
Level 1
Level 1
Posts: 10
Joined: Sat Mar 03, 2018 12:33 pm

Re: Firefox Quantum rendering extremely choppy and slow

Post by FullOfCaffeine » Fri Mar 23, 2018 2:02 pm

Sorry for the delay, I've been travelling in the last two weeks.
Something not right, that's for sure, was nvidia selected in nvidia-settings or was this after you selected intel and rebooted?
I never selected Intel. As far as I'm concerned, Nvidia is activated. I just checked nvidia-settings now, and `nvidia (performance mode)` is selected, but `System Info` still shows `Intel Skylake`.

As for the N/As output for `nvidia-smi`, seems it's a known-bug:

https://devtalk.nvidia.com/default/topi ... ia-smi-a-/

I haven't tried the fix, though.
Just to be sure, you should backup your user data in case things go south. Or hopefully, this is a fresh install with nothing to backup.
This is my main workstation, so I haven't tried that yet. I want to exhaust all possibilities before doing a reinstall of the drivers. Is it so hard to know exactly what card is being used? :/

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Firefox Quantum rendering extremely choppy and slow

Post by greerd » Sat Mar 24, 2018 10:39 am

FullOfCaffeine wrote:
Fri Mar 23, 2018 2:02 pm
This is my main workstation, so I haven't tried that yet. I want to exhaust all possibilities before doing a reinstall of the drivers. Is it so hard to know exactly what card is being used? :/
This should help determine what you're using:

Code: Select all

glxinfo | grep OpenGL
and/or

Code: Select all

lspci -k | grep -EA2 'VGA|3D'

FullOfCaffeine
Level 1
Level 1
Posts: 10
Joined: Sat Mar 03, 2018 12:33 pm

Re: Firefox Quantum rendering extremely choppy and slow

Post by FullOfCaffeine » Mon Mar 26, 2018 1:22 pm

Code: Select all

fullofcaffeine@fullofcaffeine-XPS-15-9550 ~ $ glxinfo | grep OpenGL
grep: warning: GREP_OPTIONS is deprecated; please use an alias or script
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 960M/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 384.111
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5.0 NVIDIA 384.111
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 384.111
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
Looks like I'm using the NVIDIA card, indeed.

I ended up reinstalling the system (18.3) using the default settings. Overall rendering seems to be better, but Youtube rendering is still a bit choppy (comparing to my retina macbook pro 2014) y, maybe I should just get used to it. Perhaps that has to do with the 4k res.

Post Reply

Return to “Software & Applications”