Error installing wine on Linux Mint 18

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
ivendetta
Level 1
Level 1
Posts: 3
Joined: Wed Mar 07, 2018 8:47 pm

Error installing wine on Linux Mint 18

Post by ivendetta » Wed Mar 07, 2018 8:56 pm

Hello, I'm trying to install Wine on Linux Mint 18, and I get this error after following all the steps of the official website:

sudo apt-get install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
winehq-stable : Depends: wine-stable (= 3.0.0~xenial)
E: Unable to correct problems, you have held broken packages.

How can I solve? I already tried to install by "Software Manager" but I can not, the "install" button is gray with the name "not available". I've already looked through Synaptic if there are broken packages too, and it does not.

User avatar
catweazel
Level 14
Level 14
Posts: 5447
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Error installing wine on Linux Mint 18

Post by catweazel » Thu Mar 08, 2018 2:13 am

ivendetta wrote:
Wed Mar 07, 2018 8:56 pm
Hello, I'm trying to install Wine on Linux Mint 18, and I get this error after following all the steps of the official website:
Please post the output of this terminal command:

Code: Select all

inxi -rFxz
Enclose the results in code markers, which you can select from the mini toolbar above the textbox where you type your reply.

Also post the link to the instructions you're following.
A new scientific truth does not triumph by convincing its opponents and making them see the light, but rather because its opponents eventually die, and a new generation grows up that is familiar with it. - Max Planck

buteman
Level 3
Level 3
Posts: 183
Joined: Tue Nov 29, 2011 5:36 pm
Location: North Lincolnshire

Re: Error installing wine on Linux Mint 18

Post by buteman » Thu Mar 08, 2018 4:21 am

Try following this viewtopic.php?f=47&t=265282

ivendetta
Level 1
Level 1
Posts: 3
Joined: Wed Mar 07, 2018 8:47 pm

Re: Error installing wine on Linux Mint 18

Post by ivendetta » Thu Mar 08, 2018 1:08 pm

catweazel wrote:
Thu Mar 08, 2018 2:13 am
ivendetta wrote:
Wed Mar 07, 2018 8:56 pm
Hello, I'm trying to install Wine on Linux Mint 18, and I get this error after following all the steps of the official website:
Please post the output of this terminal command:

Code: Select all

inxi -rFxz
Enclose the results in code markers, which you can select from the mini toolbar above the textbox where you type your reply.

Also post the link to the instructions you're following.
Code output:

Code: Select all

System:    Host: vendetta Kernel: 4.13.0-36-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9) Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASRock model: FM2A55M-HD+ R2.0
           Bios: American Megatrends v: P1.00 date: 03/10/2016
CPU:       Quad core AMD A10-7860K Radeon R7 12 Compute Cores 4C+8G (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 31943
           clock speeds: max: 4000 MHz 1: 2500 MHz 2: 1400 MHz 3: 1400 MHz
           4: 1400 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 Graphics]
           bus-ID: 00:01.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.79hz
           GLX Renderer: Gallium 0.4 on AMD KAVERI (DRM 2.50.0 / 4.13.0-36-generic, LLVM 4.0.0)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kaveri HDMI/DP Audio Controller
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-36-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 01:00.0
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1000.2GB (7.5% used)
           ID-1: /dev/sda model: ST1000DM010 size: 1000.2GB
Partition: ID-1: / size: 60G used: 9.9G (18%) fs: ext4 dev: /dev/sda7
           ID-2: /home size: 184G used: 46G (27%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 16.00GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 21.1C mobo: N/A gpu: 27.0
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/megasync.list
           deb https://mega.nz/linux/MEGAsync/xUbuntu_16.04/ ./
           Active apt sources in file: /etc/apt/sources.list.d/numix-ppa-xenial.list
           deb http://ppa.launchpad.net/numix/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/numix/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mint-packages.c3sl.ufpr.br sylvia main upstream import backport
           deb http://mirror.unesp.br/ubuntu xenial main restricted universe multiverse
           deb http://mirror.unesp.br/ubuntu xenial-updates main restricted universe multiverse
           deb http://mirror.unesp.br/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/spotify.list
           deb http://repository.spotify.com stable non-free
           Active apt sources in file: /etc/apt/sources.list.d/steam.list
           deb [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
           deb-src [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
Info:      Processes: 196 Uptime: 1:32 Memory: 1972.8/5919.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Link of the tutorial I followed: https://wiki.winehq.org/Ubuntu

User avatar
pbear
Level 5
Level 5
Posts: 564
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Error installing wine on Linux Mint 18

Post by pbear » Thu Mar 08, 2018 1:23 pm

Try purging Wine, including Mono and Gecko - apt purge wine* will do it - then installing again.

Note: Sudo isn't needed for the apt command. You'll be asked for your password, though, after hitting enter.
Time flies like an arrow. Fruit flies like a banana.
Running Mate 18.3 64 bit (by upgrade from 18.1-2)

ivendetta
Level 1
Level 1
Posts: 3
Joined: Wed Mar 07, 2018 8:47 pm

Re: Error installing wine on Linux Mint 18

Post by ivendetta » Thu Mar 08, 2018 1:39 pm

pbear wrote:
Thu Mar 08, 2018 1:23 pm
Try purging Wine, including Mono and Gecko - apt purge wine* will do it - then installing again.

Note: Sudo isn't needed for the apt command. You'll be asked for your password, though, after hitting enter.
I tried this, the error continues. :(
Even though I do not have wine installed, I'm trying to install it for the first time.

Marziano
Level 6
Level 6
Posts: 1357
Joined: Thu Jan 04, 2018 1:00 pm

Re: Error installing wine on Linux Mint 18

Post by Marziano » Thu Mar 08, 2018 1:50 pm

This

Code: Select all

 wget https://dl.winehq.org/wine-builds/Release.key
    sudo apt-key add Release.key
    sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'
    sudo apt update
    sudo apt install --install-recommends wine-stable
    sudo apt install --install-recommends winehq-stable
got it it installed on my LM 18.3 Xfce.

I don't know which source you have used to install it. You could maybe try removing that source and give these commands a shot. Hope this helps.

Maybe run

Code: Select all

sudo apt remove --purge wine*
sudo apt autoremve
first to get rid of the residues from your former attempts.
Last edited by Marziano on Fri Mar 09, 2018 2:08 pm, edited 1 time in total.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

User avatar
pbear
Level 5
Level 5
Posts: 564
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Error installing wine on Linux Mint 18

Post by pbear » Thu Mar 08, 2018 1:58 pm

Ahem, sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/' is the wrong repo command for Mint. See link.
Time flies like an arrow. Fruit flies like a banana.
Running Mate 18.3 64 bit (by upgrade from 18.1-2)

Marziano
Level 6
Level 6
Posts: 1357
Joined: Thu Jan 04, 2018 1:00 pm

Re: Error installing wine on Linux Mint 18

Post by Marziano » Thu Mar 08, 2018 4:23 pm

I missed that link, my bad.
I went here: https://launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa
After that I ran the command as per my previous post.
How strange as it might sound it does add

Code: Select all

deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main
to my sources:

Code: Select all

inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
           deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome-unstable.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sylvia main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
But I must say that I announced success too early. Something is not just right. It is installed on the system:

Code: Select all

sudo apt-get install --install-recommends winehq-stable
gives this:

Code: Select all

Building dependency tree       
Reading state information... Done
winehq-stable is already the newest version (3.0.0~xenial).
And I can verify that in Synaptic as well:
Wine.png
And now we come to the BUT: I don find it in the menu and maybe worse still I cannot run it at all :lol:
Last edited by Marziano on Thu Mar 08, 2018 4:43 pm, edited 1 time in total.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

User avatar
Flemur
Level 15
Level 15
Posts: 5641
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Error installing wine on Linux Mint 18

Post by Flemur » Thu Mar 08, 2018 4:33 pm

ivendetta wrote:
Thu Mar 08, 2018 1:08 pm

Code: Select all

Repos:     Active apt sources in file: /etc/apt/sources.list.d/megasync.list
           deb https://mega.nz/linux/MEGAsync/xUbuntu_16.04/ ./
           Active apt sources in file: /etc/apt/sources.list.d/numix-ppa-xenial.list
           deb http://ppa.launchpad.net/numix/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/numix/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mint-packages.c3sl.ufpr.br sylvia main upstream import backport
           deb http://mirror.unesp.br/ubuntu xenial main restricted universe multiverse
           deb http://mirror.unesp.br/ubuntu xenial-updates main restricted universe multiverse
           deb http://mirror.unesp.br/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/spotify.list
           deb http://repository.spotify.com stable non-free
           Active apt sources in file: /etc/apt/sources.list.d/steam.list
           deb [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
           deb-src [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
Info:      Processes: 196 Uptime: 1:32 Memory: 1972.8/5919.3MB
I don't see any "wine" repos there.

My "inxi -r" gives, at the top:

Code: Select all

inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
           deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
...
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

User avatar
Flemur
Level 15
Level 15
Posts: 5641
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Error installing wine on Linux Mint 18

Post by Flemur » Thu Mar 08, 2018 4:38 pm

Marziano wrote:
Thu Mar 08, 2018 4:23 pm
I went here: https://launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa
"Deprecated" means "not approved" (usually because it's out of date) = you probably shouldn't use it.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Marziano
Level 6
Level 6
Posts: 1357
Joined: Thu Jan 04, 2018 1:00 pm

Re: Error installing wine on Linux Mint 18

Post by Marziano » Thu Mar 08, 2018 4:50 pm

Flemur wrote:
Thu Mar 08, 2018 4:38 pm
Marziano wrote:
Thu Mar 08, 2018 4:23 pm
I went here: https://launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa
"Deprecated" means "not approved" (usually because it's out of date) = you probably shouldn't use it.
Thanks Flemur,
But I got the same repo as you have:
deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main
I think the deprecated one is this:
ppa:ubuntu-wine/ppa
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

User avatar
pbear
Level 5
Level 5
Posts: 564
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Error installing wine on Linux Mint 18

Post by pbear » Fri Mar 09, 2018 12:53 am

Marziano wrote:
Thu Mar 08, 2018 4:23 pm
And now we come to the BUT: I don find it in the menu and maybe worse still I cannot run it at all :lol:
This is turning into a hijack of the OP's thread. Please open your own. I will mention, though, as these points are of use to ivendetta also, (i) when Wine is installed from ppa, it doesn't add a Menu item, (ii) Wine doesn't "run" in the sense of ordinary apps (it's a tool for installing and running other apps), and (iii) Wine installed from ppa needs to be configured by running winecfg in Terminal. Points one and three are mentioned on the download page.

As for this thread, I'm kind of stumped, ivendetta. Purge and reinstall usually works. Flemur makes a good point. You don't have a Wine repo, though I don't understand how you got the messages you did without one. Please reproduce the exact commands you've been using for installation (put in code tags for ease of identification). I'm familiar with the link. What I'm looking for is some small typo that's maybe causing a problem.

By the way, have you checked whether you even need version 3.0? If version 1.6 will cover you, it's in the official repo and much easier to install
Time flies like an arrow. Fruit flies like a banana.
Running Mate 18.3 64 bit (by upgrade from 18.1-2)

Marziano
Level 6
Level 6
Posts: 1357
Joined: Thu Jan 04, 2018 1:00 pm

Re: Error installing wine on Linux Mint 18

Post by Marziano » Fri Mar 09, 2018 5:02 am

pbear wrote:
Fri Mar 09, 2018 12:53 am
This is turning into a hijack of the OP's thread. Please open your own. I will mention, though, as these points are of use to ivendetta also, (i) when Wine is installed from ppa, it doesn't add a Menu item, (ii) Wine doesn't "run" in the sense of ordinary apps (it's a tool for installing and running other apps), and (iii) Wine installed from ppa needs to be configured by running winecfg in Terminal. Points one and three are mentioned on the download page.
My intention was not to hijack the OP's thread. I am not interested in Wine at all. I just installed it for the mere reason of reproducing the process in order to gain a better understanding of it and hopefully contribute to finding a solution to the OP's problem. With your help, which I am grateful for, I hope that I have had an infinitesimal part in that.

Wine will be going through

Code: Select all

remove --purge 
on my machine but not before I will have made it to work.

Thanks for your remarks!
Marziano
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

User avatar
pbear
Level 5
Level 5
Posts: 564
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Error installing wine on Linux Mint 18

Post by pbear » Fri Mar 09, 2018 12:43 pm

Learning Wine to help others is kind, but your learning curve doesn't belong in this thread. Let's stick to the OP's problem.
Time flies like an arrow. Fruit flies like a banana.
Running Mate 18.3 64 bit (by upgrade from 18.1-2)

Marziano
Level 6
Level 6
Posts: 1357
Joined: Thu Jan 04, 2018 1:00 pm

Re: Error installing wine on Linux Mint 18

Post by Marziano » Fri Mar 09, 2018 1:31 pm

pbear wrote:
Fri Mar 09, 2018 12:43 pm
Learning Wine to help others is kind, but your learning curve doesn't belong in this thread. Let's stick to the OP's problem.
I didn't mean that I would be asking for assistance for my "learning curve" here. Maybe l hadn't expressed myself clearly enough. Or you just have misunderstood my intention. At any event, let's stick to the OP's problem.
Ciao!
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

Post Reply

Return to “Software & Applications”