WiFi lost on update

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
bobfunduro
Level 2
Level 2
Posts: 73
Joined: Sun Dec 25, 2016 7:52 am

WiFi lost on update

Post by bobfunduro » Sat Mar 17, 2018 12:15 pm

Hi all

Mint 18 Cinnamon 32bit

Yep - I'm still persevering!

Had trouble with Mint not booting consistently. So the last time it refused to boot I loaded the recovery disc which got it booting ok but since then the Wifi won't work. Computer lights says wifi's on but it isn't and I cannot turn it on or off via the key board.

Been into 'network' and that will not allow me to turn it on.

Any real simple answers to this one?

Cheers

User avatar
Sir Charles
Level 7
Level 7
Posts: 1897
Joined: Thu Jan 04, 2018 1:00 pm

Re: WiFi lost on update

Post by Sir Charles » Sat Mar 17, 2018 12:32 pm

Check if the netwotk-manager service is running:

Code: Select all

service --status-all | grep network-manager

A "+" would indicate that it is.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

bobfunduro
Level 2
Level 2
Posts: 73
Joined: Sun Dec 25, 2016 7:52 am

Re: WiFi lost on update

Post by bobfunduro » Sat Mar 17, 2018 1:20 pm

Thanks Marziano for your reply.
Yes - network manager has a '+'

Where to now? Cheers

User avatar
Sir Charles
Level 7
Level 7
Posts: 1897
Joined: Thu Jan 04, 2018 1:00 pm

Re: WiFi lost on update

Post by Sir Charles » Sat Mar 17, 2018 1:25 pm

Please post the output from:

Code: Select all

rfkill list all
and

Code: Select all

iwconfig
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

bobfunduro
Level 2
Level 2
Posts: 73
Joined: Sun Dec 25, 2016 7:52 am

Re: WiFi lost on update

Post by bobfunduro » Sat Mar 17, 2018 2:09 pm

rfkill list all
0: phy0: wireless lan
soft bloked:no
hard blocked:yes

iwconfig
lo no wireless extensions.
enp0s10 wireless extensions.
wlp5s0 IEEE802.11bg ESSID:off/any
mode: managed Access point: not associated. Tx power =off
retry short limit:7 RTS thr:off Fragment thr:off
Power management:off

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: WiFi lost on update

Post by administrollaattori » Sat Mar 17, 2018 2:16 pm

bobfunduro wrote:
Sat Mar 17, 2018 2:09 pm
rfkill list all
0: phy0: wireless lan
soft bloked:no
hard blocked:yes
hard blocked:yes ... You need to switch wifi on from hardware switch. :wink:

bobfunduro
Level 2
Level 2
Posts: 73
Joined: Sun Dec 25, 2016 7:52 am

Re: WiFi lost on update

Post by bobfunduro » Sat Mar 17, 2018 2:46 pm

You mention the 'hardware switch'. I take it you mean via the keyboard?

If so

'Computer lights says wifi's on but it isn't and I cannot turn it on or off via the key board.
Been into 'networking > wifi' and that will not allow me to turn it on.'

Mmmm - sounds like a network card problem?

JeremyB
Level 20
Level 20
Posts: 10931
Joined: Fri Feb 21, 2014 8:17 am

Re: WiFi lost on update

Post by JeremyB » Sat Mar 17, 2018 3:00 pm

Try going into UEFI/BIOS and try "reset to defaults" as it might clear the hard block

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: WiFi lost on update

Post by administrollaattori » Sat Mar 17, 2018 3:10 pm

bobfunduro wrote:
Sat Mar 17, 2018 2:46 pm
You mention the 'hardware switch'. I take it you mean via the keyboard?
Yes. Once I had one funny computer which said "hard blocked=yes", but running sudo rfkill unblock all, it turned "hard blocked=no", so you could try unblock all via Terminal.

bobfunduro
Level 2
Level 2
Posts: 73
Joined: Sun Dec 25, 2016 7:52 am

Re: WiFi lost on update

Post by bobfunduro » Sat Mar 17, 2018 4:10 pm

Alas - no luck with unlock all.

Where too now? Is there any other code to put into terminal that'll hit the spot or diagnose further?

JeremyB
Level 20
Level 20
Posts: 10931
Joined: Fri Feb 21, 2014 8:17 am

Re: WiFi lost on update

Post by JeremyB » Sat Mar 17, 2018 4:18 pm

Use reset to defaults in BIOS, if it doesn't work, power off and remove power cord and battery, then hold power button for 20 seconds. Put back together and boot

bobfunduro
Level 2
Level 2
Posts: 73
Joined: Sun Dec 25, 2016 7:52 am

Re: WiFi lost on update

Post by bobfunduro » Sat Mar 17, 2018 4:48 pm

tried the second disconnect power option - alas no luck.

Just noticed that the Bluetooth icon light is on and can't turn it off. 'Networking' says no bluetooth adaptors found.

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: WiFi lost on update

Post by asinoro » Sat Mar 17, 2018 4:56 pm

bobfunduro wrote:
Sat Mar 17, 2018 12:15 pm
Hi all

Mint 18 Cinnamon 32bit

Yep - I'm still persevering!

Had trouble with Mint not booting consistently. So the last time it refused to boot I loaded the recovery disc which got it booting ok but since then the Wifi won't work. Computer lights says wifi's on but it isn't and I cannot turn it on or off via the key board.

Been into 'network' and that will not allow me to turn it on.

Any real simple answers to this one?

Cheers
What is your hardware specification?

Code: Select all

inxi -Fnxxxz 

bobfunduro
Level 2
Level 2
Posts: 73
Joined: Sun Dec 25, 2016 7:52 am

Re: WiFi lost on update

Post by bobfunduro » Sat Mar 17, 2018 5:22 pm

Ahh! bit of a problem here.

That'll take all night to type and it's near my bedtime! Tried copy to 'Writer' on a usb but this Windows computer won't recognise it.

Bye the way - I must thank you all for your patience.

bobfunduro
Level 2
Level 2
Posts: 73
Joined: Sun Dec 25, 2016 7:52 am

Re: WiFi lost on update

Post by bobfunduro » Sat Mar 17, 2018 5:33 pm

Just having a look at the specs and wonder if these bits are what your looking for?

Network:
Card 1. Nvidia ethernet If: enp0s10 State: down mac: <filter>

Card2. Qualcomm Atheros wireless network adaptor (pci express) If: wlp5s0 State: down. Mac: <filter>

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: WiFi lost on update

Post by administrollaattori » Sun Mar 18, 2018 1:23 pm

bobfunduro wrote:
Sat Mar 17, 2018 5:22 pm
Ahh! bit of a problem here.

That'll take all night to type and it's near my bedtime! Tried copy to 'Writer' on a usb but this Windows computer won't recognise it.

Bye the way - I must thank you all for your patience.
Wifi adapter's warranty has expired. :?

Post Reply

Return to “Software & Applications”