[SOLVED] mint-artwork-common > dpkg error - attn: DEVS [SOLVED]

Questions about applications and software
Forum rules
Before you post please read how to get help
red03golf
Level 2
Level 2
Posts: 97
Joined: Tue Feb 09, 2016 10:32 pm

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by red03golf » Wed Mar 21, 2018 9:04 pm

I see you're using a lower kernel number than I am. I'll drop to a 3.x kernel and see if I can get access to the dpkg...5.8 version, as it is right now, I can't get it.

Updates to come, later.
Tin-foil hat? - Check!!

User avatar
Pierre
Level 18
Level 18
Posts: 8905
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by Pierre » Wed Mar 21, 2018 10:49 pm

this error seems to be occurring if you are still using LM17.3 & possibly also if you are using Cinnamon, as well.
- maybe just wait until your local repository has updated, again.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
karlchen
Level 20
Level 20
Posts: 11222
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by karlchen » Thu Mar 22, 2018 8:28 am

Hi, Pierre.

The default main repos (packages.linuxmint.com, archive.ubuntu.com) gave me the updated dpkg on Mint 17.1 Cinnamon and on Mint 17.2 xfce without me having to do anything special.

Cheers,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Windows? - 1 window in every room

User avatar
BG405
Level 7
Level 7
Posts: 1856
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by BG405 » Thu Mar 22, 2018 5:55 pm

I did an update earlier and the mint-artwork-common package ws only listed in Update Manager after I'd updated dpkg (along with the other updates listed then). I don't know why the mint-artwork-common update was listed, in your case, prior to this?
Pierre wrote:
Wed Mar 21, 2018 10:49 pm
this error seems to be occurring if you are still using LM17.3 & possibly also if you are using Cinnamon, as well.
- maybe just wait until your local repository has updated, again.
My reply was posted from the LM17.3 Cinnamon 64-bit system. No update for the artwork package was visible in UM prior to the dpkg update being applied.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 4GB - Manjaro KDE, LM17.3 KDE 32
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

scubajeff
Level 1
Level 1
Posts: 4
Joined: Wed Dec 23, 2015 3:58 pm

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by scubajeff » Thu Mar 22, 2018 10:06 pm

I had the same error attempting to install mint-artwork-common_1.8.7.2_all.deb, on Mint 17.2 I solved it by updating dpkg.

I do not install Level 3 updates because they are described in the Update Manager GUI as "Safe updates. Not tested, but believed to be safe." I won't install anything that has not been tested. I was a UNIX and Linux Sys Admin for 20 years, and I never update anything on any system, unless it has been carefully tested. My motto at work was, "If it ain't broke, don't fix it!" That served me well for decades. Hence, my Mint version is way below the current 18.3 release. That also explains why my dpkg version was lower than required for mint-artwork-common.

I started with this version of dpkg: 1.17.5ubuntu5.5

People have stated that one needs 1.17.5 for the mint-artwork-common package to install. As you an see, I had 1.17.5, but the key is the "ubuntu5.5" part of the version name. It needs to be "ubuntu5.8".

The fix.

Refresh you list of available packages:

Code: Select all

apt-get update
------------------------------------------------------
Research the repo versions, and your installed version:
apt-cache policy dpkg -- shows your installed version, and any candidate package version available.

Code: Select all

apt-cache policy dpkg
dpkg:
  Installed: 1.17.5ubuntu5.5
  Candidate: 1.17.5ubuntu5.8
  Version table:
     1.17.5ubuntu5.8 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     1.17.5ubuntu5.6 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
 *** 1.17.5ubuntu5.5 0
        100 /var/lib/dpkg/status
     1.17.5ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
---------------------------------------------------------

Another verification that a newer package is available:

Code: Select all

apt-cache show dpkg
Package: dpkg
Architecture: amd64
Version: 1.17.5ubuntu5.8
Multi-Arch: foreign
Priority: required
Essential: yes
Section: admin
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>...
---------------------------------------------------------------------------------

Update the dpkg package:

Code: Select all

apt-get install --only-upgrade dpkg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  scummvm scummvm-data
Use 'apt-get autoremove' to remove them.
The following packages will be upgraded:
  dpkg
1 upgraded, 0 newly installed, 0 to remove and 506 not upgraded.
Need to get 1,958 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main dpkg amd64 1.17.5ubuntu5.8 [1,958 kB]
Fetched 1,958 kB in 1s (995 kB/s) 
(Reading database ... 186331 files and directories currently installed.)
Preparing to unpack .../dpkg_1.17.5ubuntu5.8_amd64.deb ...
Unpacking dpkg (1.17.5ubuntu5.8) over (1.17.5ubuntu5.5) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up dpkg (1.17.5ubuntu5.8) ...
-------------------------------------------------------------------------------------------

Verify the newly installed dpkg version:

Code: Select all

apt-cache policy dpkg
dpkg:
  Installed: 1.17.5ubuntu5.8
  Candidate: 1.17.5ubuntu5.8
  Version table:
 *** 1.17.5ubuntu5.8 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.17.5ubuntu5.6 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     1.17.5ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
-----------------------------------------------------------------------------------------------------------

Another way to verify the new package:

Code: Select all

 dpkg --status dpkg
Package: dpkg
Essential: yes
Status: install ok installed
Priority: required
Section: admin
Installed-Size: 6240
Origin: debian
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Bugs: debbugs://bugs.debian.org
Architecture: amd64
Multi-Arch: foreign
Version: 1.17.5ubuntu5.8
Replaces: manpages-it (<< 2.80-4)
Pre-Depends: libbz2-1.0, libc6 (>= 2.14), liblzma5 (>= 5.1.1alpha+20120614), libselinux1 (>= 2.1.0), zlib1g (>= 1:1.1.4), tar (>= 1.23)
Suggests: apt
Breaks: apt (<< 0.7.7), aptitude (<< 0.4.7-1), dpkg-dev (<< 1.15.8), libdpkg-perl (<< 1.15.8)
Conffiles:
 /etc/dpkg/dpkg.cfg f4413ffb515f8f753624ae3bb365b81b
 /etc/cron.daily/dpkg b6b8dc21210ea50db7cc4636f521758f
 /etc/logrotate.d/dpkg 782ea5ae536f67ff51dc8c3e2eeb4cf9
 /etc/alternatives/README 69c4ba7f08363e998e0f2e244a04f881
Description: Debian package management system
 This package provides the low-level infrastructure for handling the
 installation and removal of Debian software packages.
 .
 For Debian package development tools, install dpkg-dev.
Homepage: https://wiki.debian.org/Teams/Dpkg
Original-Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
----------------------------------------------------------------------------------------------

Next, I updated mint-artwork-common, using the Update Manager GUI, and it installed error free. You can now verify that update:

Code: Select all

apt-cache policy mint-artwork-common
mint-artwork-common:
  Installed: 1.8.7.2
  Candidate: 1.8.7.2
  Version table:
 *** 1.8.7.2 0
        700 http://packages.linuxmint.com/ rafaela/main amd64 Packages
        100 /var/lib/dpkg/status
-------------------------------------------------------------------------------------------------
You may wonder why a professional Linux Sys Admin would ever use a GUI, when the GUI is never configured to run at boot time on corporate servers, requiring that 100% of my work was done via the command line, for decades. My response; the GUI is easy, fast, usually a no-brainer, almost always works without error, and it's my personal computer, not a corporate server, and the GUI can minimize the potential for serious damage to your system. It saves me the time and pain of researching a series of complicated command lines. If a GUI tool helps reduce the learning curve for Linux, or simply automates complicated command line procedures, then it's ok. Many professional Linux Sys Admins will strongly disagree with that idea, and perhaps, even scoff at you for using a GUI.

Best Regards,
Jeff
Last edited by karlchen on Fri Mar 23, 2018 4:32 am, edited 1 time in total.
Reason: added [code] tags where appropriate. Note: [code] tags are what is behind the </> icon in the forum editor toolbar

User avatar
Pierre
Level 18
Level 18
Posts: 8905
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by Pierre » Fri Mar 23, 2018 1:31 am

Nope - - Jeff - - none of that works"
E: /var/cache/apt/archives/mint-artwork-common_1.8.7.2_all.deb: subprocess dpkg-deb --control returned error exit status 2
:?
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by Cosmo. » Fri Mar 23, 2018 6:26 am

BG405 wrote:
Thu Mar 22, 2018 5:55 pm
My reply was posted from the LM17.3 Cinnamon 64-bit system. No update for the artwork package was visible in UM prior to the dpkg update being applied.
I cannot confirm. Yesterday I started 2 LM 17.3 Cinnamon test systems, which I did not used in the last half year; so they did not get any updates in those 6 months. When I opened the update manager I got as well the update for mint-artwork-common and for dpkg. I did apply all open updates (those 2 and all the many others) and in both systems this worked without an issue.

This means: Both updates are visible at the same time (if both are still open) and both can get updated with the same step.

red03golf
Level 2
Level 2
Posts: 97
Joined: Tue Feb 09, 2016 10:32 pm

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by red03golf » Fri Mar 23, 2018 10:03 am

@jeff

That don't work for me, no 5.8 available:

Code: Select all

sudo apt-cache policy dpkg
dpkg:
  Installed: 1.17.5ubuntu5.7
  Candidate: 1.17.5ubuntu5.7
  Version table:
 *** 1.17.5ubuntu5.7 0
        500 http://mirror.cpsc.ucalgary.ca/mirror/ubuntu.com/packages/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.17.5ubuntu5.6 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     1.17.5ubuntu5 0
        500 http://mirror.cpsc.ucalgary.ca/mirror/ubuntu.com/packages/ trusty/main amd64 Packages
Another verification that a newer package is NOT available:

Code: Select all

sudo apt-cache show dpkg
Package: dpkg
Architecture: amd64
Version: 1.17.5ubuntu5.7
Multi-Arch: foreign
Priority: required
Essential: yes
Section: admin
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
Tin-foil hat? - Check!!

User avatar
karlchen
Level 20
Level 20
Posts: 11222
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by karlchen » Fri Mar 23, 2018 11:26 am

Hi, red03golf.

Try switching the Ubuntu repo servers to plain vanilla archive.ubuntu.com instead. They gave me dpkg 1.17.5ubuntu5.8 almost a week ago or so.

Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Windows? - 1 window in every room

red03golf
Level 2
Level 2
Posts: 97
Joined: Tue Feb 09, 2016 10:32 pm

[SOLVED] Re: mint-artwork-common > dpkg error - attn: DEVS [SOLVED]

Post by red03golf » Fri Mar 23, 2018 4:45 pm

karlchen wrote:
Fri Mar 23, 2018 11:26 am
Hi, red03golf.

Try switching the Ubuntu repo servers to plain vanilla archive.ubuntu.com instead. They gave me dpkg 1.17.5ubuntu5.8 almost a week ago or so.

Karl
@Karl - you're brilliant!! ;o)

SOLUTION:
Image

Then, update the cache

Here's the output, now:

Code: Select all

sudo apt-cache policy dpkg
[sudo] password for user: 
dpkg:
  Installed: 1.17.5ubuntu5.7
  Candidate: 1.17.5ubuntu5.8
  Version table:
     1.17.5ubuntu5.8 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
 *** 1.17.5ubuntu5.7 0
        100 /var/lib/dpkg/status
     1.17.5ubuntu5.6 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     1.17.5ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
Update & upgrade:

Code: Select all

sudo aptitude update && sudo aptitude upgrade
The following packages will be upgraded: 
  dpkg initramfs-tools initramfs-tools-bin iproute iproute2 isc-dhcp-client 
  isc-dhcp-common libapparmor1 libdpkg-perl lshw mint-artwork-common 
  python3-update-manager resolvconf update-manager-core 
The following packages are RECOMMENDED but will NOT be installed:
  libatm1
  ...
  sudo aptitude install libatm1
  ...
Woo Hoo!!

Consider this problem SOLVED.
  • Thank you, Karl, for the solution.
  • Thank you, everyone else, for your input and suggestions.
Last edited by red03golf on Fri Mar 23, 2018 5:39 pm, edited 2 times in total.
Tin-foil hat? - Check!!

Baldlygo
Level 3
Level 3
Posts: 101
Joined: Wed Feb 16, 2011 6:28 am
Location: Le Dorat, France
Contact:

Re: [SOLVED] mint-artwork-common > dpkg error - attn: DEVS [SOLVED]

Post by Baldlygo » Fri Mar 23, 2018 5:05 pm

Thanks for the info folks - I'd lived with the error a few days. Changed mirrors and now updated successfully.
Dell Inspiron R15 - Mint 17.3 Rosa

GGubby
Level 1
Level 1
Posts: 9
Joined: Wed Feb 10, 2016 6:40 am

Re: [SOLVED] mint-artwork-common > dpkg error - attn: DEVS [SOLVED]

Post by GGubby » Sat Mar 24, 2018 6:18 am

I have tried suggestions but continue to get error message for mint-srtwork-common upgrade!
How do I check if my dpkg is up to date?
Any other suggestions from people who have solved this problem?
Or...should I just not worry about the artwork upgrade?

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: [SOLVED] mint-artwork-common > dpkg error - attn: DEVS [SOLVED]

Post by Cosmo. » Sat Mar 24, 2018 6:26 am

GGubby wrote:
Sat Mar 24, 2018 6:18 am
How do I check if my dpkg is up to date?
Open synaptic, enter "dpkg" and check the version number.

Baldlygo
Level 3
Level 3
Posts: 101
Joined: Wed Feb 16, 2011 6:28 am
Location: Le Dorat, France
Contact:

Re: [SOLVED] mint-artwork-common > dpkg error - attn: DEVS [SOLVED]

Post by Baldlygo » Sat Mar 24, 2018 6:45 am

"apt show dpkg" - shows mine is Version: 1.17.5ubuntu5.8

dpkg only updated after changing sources - then mint-artwork-common updated no problem
Last edited by Baldlygo on Sat Mar 24, 2018 6:48 am, edited 1 time in total.
Dell Inspiron R15 - Mint 17.3 Rosa

GGubby
Level 1
Level 1
Posts: 9
Joined: Wed Feb 10, 2016 6:40 am

Re: [SOLVED] mint-artwork-common > dpkg error - attn: DEVS [SOLVED]

Post by GGubby » Sat Mar 24, 2018 6:45 am

'Thank you!' - I'm a real new comer to this but have found 3 dpkg files that had upgrades available; downloaded and re-run artwork upgrade successfully..... :)

Skara Brae
Level 1
Level 1
Posts: 47
Joined: Sat Jun 09, 2012 10:45 am

Re: [SOLVED] mint-artwork-common > dpkg error - attn: DEVS [SOLVED]

Post by Skara Brae » Wed Mar 28, 2018 2:01 pm

Running 17.3 "Rosa" MATE here (ever since Ubuntu went Unity <barf>), and I had the same "error" message only 10 minutes ago or so. Following the explanation of scubajeff on updating dpkg, I was able to successfully download and install the "mint-artwork-common" package.

Code: Select all

kriske@rosa ~ $ inxi -Sz
System:    Host: rosa Kernel: 4.4.0-109-generic x86_64 (64 bit) Desktop: MATE 1.12.0
           Distro: Linux Mint 17.3 Rosa

Code: Select all

kriske@rosa ~ $ apt-cache policy dpkg
dpkg:
  Installed: 1.17.5ubuntu5.7
  Candidate: 1.17.5ubuntu5.8
Before, and after the dpkg upgrade:

Code: Select all

kriske@rosa ~ $ apt-cache policy dpkg
dpkg:
  Installed: 1.17.5ubuntu5.8
  Candidate: 1.17.5ubuntu5.8
After which the mint-artwork-common package could be downloaded.

@scubajeff, thank you very for your explanation - it has, in my case, been extremely helpful.
Codename "PUMA": Intel Core i5-3450 // Gigabyte GA-H77-D3H // 1 x 4 GB DDR3-RAM // Gigabyte Geforce GTX 460 // WD Caviar Blue 500 GB (S-ATA) // Samsung WriteMaster DVD-rw // Aopen QF50C PC case
--
Registered Linux User #495429

User avatar
Pierre
Level 18
Level 18
Posts: 8905
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: [SOLVED] mint-artwork-common > dpkg error - attn: DEVS [SOLVED]

Post by Pierre » Mon Apr 02, 2018 1:19 am

what finally worked for me:
- Try switching the Ubuntu repo servers to plain vanilla archive.ubuntu.com instead.
as per what karlchen has said.
- sudo apt-get install --only-upgrade dpkg
verify that it is the latest version.
- sudo apt-get install --only-upgrade mint-artwork-common

Note: that I've had to use sudo or it wouldn't work. . .
Finally - - "your system is up-to-date" AND that Big Tick :D
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

DJScribe
Level 1
Level 1
Posts: 1
Joined: Mon Apr 02, 2018 11:10 pm

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by DJScribe » Mon Apr 02, 2018 11:12 pm

FenderGuy wrote:
Wed Mar 21, 2018 11:05 am
In Linux Mint 17.3, I typically perform all updates for Levels 1 and 2; however, to resolve THIS issue, I installed all the Level 3 updates that were noted as "safe for download" (i.e., in Update Manager, TYPE = down arrow).

Problem solved!
All this mambo j'hambo with links and mockery and in the end - turning on Level 3 is what solved it.

Thanks Fender - Nice work, brother!

Landon
Level 1
Level 1
Posts: 13
Joined: Fri Mar 25, 2016 11:42 pm

Re: [SOLVED] mint-artwork-common > dpkg error - attn: DEVS [SOLVED]

Post by Landon » Sat Apr 14, 2018 10:13 am

Installing the Level 3 updates fixed the problem for me as well, that is all that I had to do.

nandayo
Level 2
Level 2
Posts: 67
Joined: Sun Feb 17, 2013 11:23 am

Re: mint-artwork-common > dpkg error - attn: DEVS

Post by nandayo » Sun May 20, 2018 7:11 am

scubajeff wrote:
Thu Mar 22, 2018 10:06 pm
I had the same error attempting to install mint-artwork-common_1.8.7.2_all.deb, on Mint 17.2 I solved it by updating dpkg.

I do not install Level 3 updates because they are described in the Update Manager GUI as "Safe updates. Not tested, but believed to be safe." I won't install anything that has not been tested. I was a UNIX and Linux Sys Admin for 20 years, and I never update anything on any system, unless it has been carefully tested. My motto at work was, "If it ain't broke, don't fix it!" That served me well for decades. Hence, my Mint version is way below the current 18.3 release. That also explains why my dpkg version was lower than required for mint-artwork-common.

I started with this version of dpkg: 1.17.5ubuntu5.5

People have stated that one needs 1.17.5 for the mint-artwork-common package to install. As you an see, I had 1.17.5, but the key is the "ubuntu5.5" part of the version name. It needs to be "ubuntu5.8".

The fix.

Refresh you list of available packages:

Code: Select all

apt-get update
------------------------------------------------------
Research the repo versions, and your installed version:
apt-cache policy dpkg -- shows your installed version, and any candidate package version available.

Code: Select all

apt-cache policy dpkg
dpkg:
  Installed: 1.17.5ubuntu5.5
  Candidate: 1.17.5ubuntu5.8
  Version table:
     1.17.5ubuntu5.8 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     1.17.5ubuntu5.6 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
 *** 1.17.5ubuntu5.5 0
        100 /var/lib/dpkg/status
     1.17.5ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
---------------------------------------------------------

Another verification that a newer package is available:

Code: Select all

apt-cache show dpkg
Package: dpkg
Architecture: amd64
Version: 1.17.5ubuntu5.8
Multi-Arch: foreign
Priority: required
Essential: yes
Section: admin
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>...
---------------------------------------------------------------------------------

Update the dpkg package:

Code: Select all

apt-get install --only-upgrade dpkg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  scummvm scummvm-data
Use 'apt-get autoremove' to remove them.
The following packages will be upgraded:
  dpkg
1 upgraded, 0 newly installed, 0 to remove and 506 not upgraded.
Need to get 1,958 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main dpkg amd64 1.17.5ubuntu5.8 [1,958 kB]
Fetched 1,958 kB in 1s (995 kB/s) 
(Reading database ... 186331 files and directories currently installed.)
Preparing to unpack .../dpkg_1.17.5ubuntu5.8_amd64.deb ...
Unpacking dpkg (1.17.5ubuntu5.8) over (1.17.5ubuntu5.5) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up dpkg (1.17.5ubuntu5.8) ...
-------------------------------------------------------------------------------------------

Verify the newly installed dpkg version:

Code: Select all

apt-cache policy dpkg
dpkg:
  Installed: 1.17.5ubuntu5.8
  Candidate: 1.17.5ubuntu5.8
  Version table:
 *** 1.17.5ubuntu5.8 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.17.5ubuntu5.6 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     1.17.5ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
-----------------------------------------------------------------------------------------------------------

Another way to verify the new package:

Code: Select all

 dpkg --status dpkg
Package: dpkg
Essential: yes
Status: install ok installed
Priority: required
Section: admin
Installed-Size: 6240
Origin: debian
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Bugs: debbugs://bugs.debian.org
Architecture: amd64
Multi-Arch: foreign
Version: 1.17.5ubuntu5.8
Replaces: manpages-it (<< 2.80-4)
Pre-Depends: libbz2-1.0, libc6 (>= 2.14), liblzma5 (>= 5.1.1alpha+20120614), libselinux1 (>= 2.1.0), zlib1g (>= 1:1.1.4), tar (>= 1.23)
Suggests: apt
Breaks: apt (<< 0.7.7), aptitude (<< 0.4.7-1), dpkg-dev (<< 1.15.8), libdpkg-perl (<< 1.15.8)
Conffiles:
 /etc/dpkg/dpkg.cfg f4413ffb515f8f753624ae3bb365b81b
 /etc/cron.daily/dpkg b6b8dc21210ea50db7cc4636f521758f
 /etc/logrotate.d/dpkg 782ea5ae536f67ff51dc8c3e2eeb4cf9
 /etc/alternatives/README 69c4ba7f08363e998e0f2e244a04f881
Description: Debian package management system
 This package provides the low-level infrastructure for handling the
 installation and removal of Debian software packages.
 .
 For Debian package development tools, install dpkg-dev.
Homepage: https://wiki.debian.org/Teams/Dpkg
Original-Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
----------------------------------------------------------------------------------------------

Next, I updated mint-artwork-common, using the Update Manager GUI, and it installed error free. You can now verify that update:

Code: Select all

apt-cache policy mint-artwork-common
mint-artwork-common:
  Installed: 1.8.7.2
  Candidate: 1.8.7.2
  Version table:
 *** 1.8.7.2 0
        700 http://packages.linuxmint.com/ rafaela/main amd64 Packages
        100 /var/lib/dpkg/status
-------------------------------------------------------------------------------------------------
You may wonder why a professional Linux Sys Admin would ever use a GUI, when the GUI is never configured to run at boot time on corporate servers, requiring that 100% of my work was done via the command line, for decades. My response; the GUI is easy, fast, usually a no-brainer, almost always works without error, and it's my personal computer, not a corporate server, and the GUI can minimize the potential for serious damage to your system. It saves me the time and pain of researching a series of complicated command lines. If a GUI tool helps reduce the learning curve for Linux, or simply automates complicated command line procedures, then it's ok. Many professional Linux Sys Admins will strongly disagree with that idea, and perhaps, even scoff at you for using a GUI.

Best Regards,
Jeff
This worked for me, thanks a buch, but THAT'S A SHAME we have to look at forums to get a fixe of this, after mounth the problem was still alive on my computer, and unable to update. Good work devs, really.

Post Reply

Return to “Software & Applications”