[SOLVED] Cannot launch a lot of application since a few days

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
BernysPeur
Level 1
Level 1
Posts: 13
Joined: Wed Nov 07, 2012 3:27 pm

[SOLVED] Cannot launch a lot of application since a few days

Post by BernysPeur » Thu Mar 29, 2018 10:33 am

Hello

I am trying to repair a Mint 18 Sarah 64bit installation where it appears to be impossible to launch a lot of applications.

When I say a lot of applications it includes vlc, firefox, mate-system-monitort, all the programs in the control center, the update manager (for which I don't see anymore the icon at the bottom right), etc ...

The bad thing is that I have few messages displayed.
When I type "firefox" at the command line I immediately have a new command prompt with no message (and no firefox)
When I look at dmesg I have the following:

Code: Select all

[  324.149654] firefox[2817]: segfault at 0 ip 00007f11bfe124e3 sp 00007ffe349b8258 error 6 in libxul.so[7f11bc3cd000+5810000]
when I try to launch vlc I have the following message:

Code: Select all

QMutex: destroying locked mutex
and nothing in dmesg.

When I try to laucnh mate-system-monitor I do not have any message and nothing in dmesg. Just nothing happens.

Other applications like pidgin, libre office, gimp launch properly.

I don't know where to begin.
Can anyone help me?

Thank you!
Last edited by BernysPeur on Thu Mar 29, 2018 11:03 am, edited 1 time in total.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1897
Joined: Thu Jan 04, 2018 1:00 pm

Re: Cannot launch a lot of application since a few days

Post by Sir Charles » Thu Mar 29, 2018 10:38 am

This is most probably due to to the updates to some Virtualbox related packages the other day. Many people have had similar problems as yours. Try running

Code: Select all

sudo apt remove virtualbox-guest* 
from a terminal. Reboot and see if things work as they should.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

BernysPeur
Level 1
Level 1
Posts: 13
Joined: Wed Nov 07, 2012 3:27 pm

[SOLVED]Re: Cannot launch a lot of application since a few days

Post by BernysPeur » Thu Mar 29, 2018 10:53 am

That worked.

Thanks for this fast answer!

How can I prevent this from happening again?
Can I blacklist the virtualbox-guest things in the update manager?

Thanks!

User avatar
smurphos
Level 13
Level 13
Posts: 4628
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Cannot launch a lot of application since a few days

Post by smurphos » Thu Mar 29, 2018 11:00 am

Now you've removed them they won't update.

Your next update will include a mintupdate update - the new version of mintupdate prevents the problematic virtualbox-guest* packages being installed in future.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
Moem
Level 19
Level 19
Posts: 9570
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Cannot launch a lot of application since a few days

Post by Moem » Thu Mar 29, 2018 11:00 am

Nothing you can do in general... it was a buggy update. It might happen again with a different update for a different piece of software. If it happens again, check the forum and you will most likely see a solution posted.

By the way, marking a topic as SOLVED should be done in the title of the first post in the thread. That way, the title for the whole topic is changed, not just one of the posts.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

BernysPeur
Level 1
Level 1
Posts: 13
Joined: Wed Nov 07, 2012 3:27 pm

Re: [SOLVED] Cannot launch a lot of application since a few days

Post by BernysPeur » Thu Mar 29, 2018 11:05 am

Marked the first topic as solved!

Thanks!

Post Reply

Return to “Software & Applications”