Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependencyhell

Questions about applications and software
Forum rules
Before you post please read how to get help
fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependencyhell

Post by fruitkiller » Wed Apr 18, 2018 9:43 pm

So, after installing updates to yarn, which caused kvirc, xchat, pidgin, libpurple0 and a lot of other stuff to disappear and the error I get is very strange, first time I get an error that something fails to install because resource is busy....that's a very windows type of error...anyway...just a sample of what's happening and the crux of what is causing me to be unable to install something as simple as xchat right now looks like this :

Code: Select all

sudo apt-get -f install xchat
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libruby1.9.1 : Depends: ruby1.9.1 (= 1.9.3.484-2ubuntu1.11) but 1.9.3.484-2ubuntu1.8 is to be installed
 ruby1.9.1 : Depends: libruby1.9.1 (= 1.9.3.484-2ubuntu1.8) but 1.9.3.484-2ubuntu1.11 is to be installed
 xchat : Depends: libperl5.18 (>= 5.18.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
I get this situation, which is quite unwelcome, first time official updates mess up dependencies like this.

edit : I have to specify that when all this happened, I wasn't warned that so much packages would be uninstalled, it just happened right before my eyes. I don't know if installing Java 8's update caused any of this but it was scary.

Marziano
Level 6
Level 6
Posts: 1223
Joined: Thu Jan 04, 2018 1:00 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by Marziano » Thu Apr 19, 2018 7:39 am

This might be worth a try: Open Synaptic --> Edit --> Fix Broken Packages.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

User avatar
smurphos
Level 5
Level 5
Posts: 674
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by smurphos » Thu Apr 19, 2018 7:51 am

What's yarn? I can't find it in the repos. Is it from PPA?

inxi -r would be good.

Edit - actually inxi -Fxzr. I'm looking at the 18.3 repo but looking at the Ruby version you might be on 17.x?

And I know what yarn is now too - from https://dl.yarnpkg.com/debian/ stable main?? I guess the next questions are

1) Does that repo offer different versions of any packages that in the regular repos?
2) What dependencies does yarn have?

Hoser Rob
Level 11
Level 11
Posts: 3675
Joined: Sat Dec 15, 2012 8:57 am

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by Hoser Rob » Thu Apr 19, 2018 8:57 am

smurphos wrote:
Thu Apr 19, 2018 7:51 am
What's yarn? I can't find it in the repos. Is it from PPA?

inxi -r would be good.

Edit - actually inxi -Fxzr. I'm looking at the 18.3 repo but looking at the Ruby version you might be on 17.x?

And I know what yarn is now too - from https://dl.yarnpkg.com/debian/ stable main?? I guess the next questions are

1) Does that repo offer different versions of any packages that in the regular repos?
2) What dependencies does yarn have?
Bassically what he/she said. Yam is a package manager, used by Arch but available from the Debian repos. Though why you'd want to install a 3rd party package manager is beyond me ...

Marziano
Level 6
Level 6
Posts: 1223
Joined: Thu Jan 04, 2018 1:00 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by Marziano » Thu Apr 19, 2018 9:08 am

Yarn is a package manager for your code. It allows you to use and share code with other developers from around the world. Yarn does this quickly, securely, and reliably so you don’t ever have to worry.

Yarn allows you to use other developers’ solutions to different problems, making it easier for you to develop your software. If you have problems, you can report issues or contribute back, and when the problem is fixed, you can use Yarn to keep it all up to date.

Code is shared through something called a package (sometimes referred to as a module). A package contains all the code being shared as well as a package.json file which describes the package.
https://yarnpkg.com/en/docs/getting-started
Edit: What doesdpkg --audit say?
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by fruitkiller » Thu Apr 19, 2018 10:10 am

Marziano wrote:
Thu Apr 19, 2018 7:39 am
This might be worth a try: Open Synaptic --> Edit --> Fix Broken Packages.
I already did that obviously, it does the same thing as apt-install -f

I can show you what broken packages it says I have... :

https://my.mixtape.moe/crgfkg.png

It doesn't fix anything, it wants me to install one of those, and the error I said about resources being busy and thus updates going awry with yarn which causes all that recurs when trying to install them once I "fix" them, I know it wants me to do something else because just doing that will then have Synaptic tell me that if I quit changes I had selected will be unselected etc. I think it's time to upgrade to 17.3 and see what happens. (I'm on 17.1 since a short time after a 17.3 install went because I couldn't get any video drivers to work well all of a sudden. I think learning how to make debs out of the .run driver files will make the transition easier in case I get a X-crash error after doing such an update. But in the state things are, I don't even want to reboot, this whole thing removed a whole lot of stuff, probably nothing OS-shattering, but removed almost anything Qt related, as well as Skype (forgot to mention that). I need Pidgin to use facebook chat, otherwise I don't use facebook at all, but I can't convince those who left Skype behind or better things such as plain otr Pidgin. Anyway that doesn't matter for now...I half-expected this so I had made the screengrab yesterday night anyways. I think I will need more specific help than this. I got myself out of a few situations like this before thanks to this board, but it happened a long while ago, in the first few years of learning how to use Linux, first with Ubuntu 11.04/11.10 and then Mint 13/14/15.

fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by fruitkiller » Thu Apr 19, 2018 10:13 am

Marziano wrote:
Thu Apr 19, 2018 9:08 am
Yarn is a package manager for your code. It allows you to use and share code with other developers from around the world. Yarn does this quickly, securely, and reliably so you don’t ever have to worry.

Yarn allows you to use other developers’ solutions to different problems, making it easier for you to develop your software. If you have problems, you can report issues or contribute back, and when the problem is fixed, you can use Yarn to keep it all up to date.

Code is shared through something called a package (sometimes referred to as a module). A package contains all the code being shared as well as a package.json file which describes the package.
https://yarnpkg.com/en/docs/getting-started
Edit: What doesdpkg --audit say?

Code: Select all

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 libruby1.9.1         Libraries necessary to run Ruby 1.9.1
Thanks, that path looks fruitful....but I can't install libruby as per the error I've shown..although I will need confirmation on what this is instructing me to do, I never did this before and thanks for the new command (for me).

fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by fruitkiller » Thu Apr 19, 2018 10:20 am

Hoser Rob wrote:
Thu Apr 19, 2018 8:57 am
smurphos wrote:
Thu Apr 19, 2018 7:51 am
What's yarn? I can't find it in the repos. Is it from PPA?

inxi -r would be good.

Edit - actually inxi -Fxzr. I'm looking at the 18.3 repo but looking at the Ruby version you might be on 17.x?

And I know what yarn is now too - from https://dl.yarnpkg.com/debian/ stable main?? I guess the next questions are

1) Does that repo offer different versions of any packages that in the regular repos?
2) What dependencies does yarn have?
Bassically what he/she said. Yam is a package manager, used by Arch but available from the Debian repos. Though why you'd want to install a 3rd party package manager is beyond me ...
I don't know why I was suggested it....yarn comes from dl.package.com.....I did not add this PPA myself, I think it must have come from when I installed Chrome (there was a Chrome upgrade also yesterday, although that went well...I wish we could get a date for when PPA's were added, but I sure didn't.

Properties says it needs nodejs, which I have, but then under that it says, Conflicts (nodejs<4.0.0)

Marziano
Level 6
Level 6
Posts: 1223
Joined: Thu Jan 04, 2018 1:00 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by Marziano » Thu Apr 19, 2018 10:26 am

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
libruby1.9.1 Libraries necessary to run Ruby 1.9.1
I think we should be following what the error messages indicate. In this case, configuring the mentioned package:

Code: Select all

sudo dpkg --configure libruby1.9.1
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by fruitkiller » Thu Apr 19, 2018 8:41 pm

More impasse...See the circular error I get here. And to those who asked, yes, I am on 17.3 right now, 18.x can't work with my graphics card

Code: Select all

dpkg --configure libruby1.9.1
[sudo] password for phil: 
dpkg: dependency problems prevent configuration of libruby1.9.1:
 libruby1.9.1 depends on ruby1.9.1 (= 1.9.3.484-2ubuntu1.11); however:
  Version of ruby1.9.1 on system is 1.9.3.484-2ubuntu1.8.

dpkg: error processing package libruby1.9.1 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libruby1.9.1
Haven't been this frustrated in a good while, I feel like in my noob times, when I was willing (thanks study aids) to format and start over until I got it right again and again. Although, nothing critical is happening...this removal of all chat programs, some I had compiled myself, kvirc, and pidgin is just not acceptable. Rack your brains please guys :cry: , I browsed, a lot, and I can't find specific help for what I'm experiencing. I'm ready to remove yarn, but I wonder if that will not screw things over even more.

Code: Select all

fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7800 Series  
OpenGL version string: 4.5.13416 Compatibility Profile Context 15.30.1025

fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by fruitkiller » Thu Apr 19, 2018 9:42 pm

This is what happens after synaptic fix broken dependencies or through terminal with install -f

Code: Select all

The following extra packages will be installed:
  ruby1.9.1
Suggested packages:
  ruby1.9.1-examples ri1.9.1 graphviz ruby1.9.1-dev ruby-switch
The following packages will be upgraded:
  ruby1.9.1
1 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.
1 not fully installed or removed.
Need to get 0 B/35.6 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 682503 files and directories currently installed.)
Preparing to unpack .../ruby1.9.1_1.9.3.484-2ubuntu1.11_amd64.deb ...
Unpacking ruby1.9.1 (1.9.3.484-2ubuntu1.11) over (1.9.3.484-2ubuntu1.8) ...
[b]dpkg: error processing archive /var/cache/apt/archives/ruby1.9.1_1.9.3.484-2ubuntu1.11_amd64.deb (--unpack):
 unable to install new version of `/usr/bin/ruby1.9.1': Device or resource busy[/b]
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for menu (2.1.46ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/ruby1.9.1_1.9.3.484-2ubuntu1.11_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
This is the root of the problem. What I meant when I said device or resource is busy can't install etc. I don't know what causes this...I don't have anything but browsers and Audacious opened along with pluma.

User avatar
smurphos
Level 5
Level 5
Posts: 674
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by smurphos » Thu Apr 19, 2018 11:42 pm

fruitkiller wrote:
Thu Apr 19, 2018 8:41 pm
I'm ready to remove yarn, but I wonder if that will not screw things over even more.
It might, but that's the route I'd be looking at - basically taking out that repo and downgrading foreign packages before trying to force updates, repair packages etc...

It would still be helpful to see exactly what repos you have got with inxi -r

It would also be helpful I think to see exactly what has been installed and removed. At least then if you get to the stage were things are starting to work you know exactly what needs to be reinstalled.

cat /var/log/dpkg.log | grep "status installed" && cat /var/log/dpkg.log | grep "remove "

fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by fruitkiller » Fri Apr 20, 2018 2:30 pm

I have tried to remove yarn, but then I get told :

Code: Select all

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libruby1.9.1 : Depends: ruby1.9.1 (= 1.9.3.484-2ubuntu1.11) but 1.9.3.484-2ubuntu1.8 is to be installed
 ruby1.9.1 : Depends: libruby1.9.1 (= 1.9.3.484-2ubuntu1.8) but 1.9.3.484-2ubuntu1.11 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages 
Like I can't update current updates to important stuff like openssl right now, system won't budge until THIS is resolved. Yet I can't because "Device or resource is busy" which according to the error message is that "usr/bin/ruby1.9.1': Device or resource busy".

Although, thanks for the very useful command here! I have something more to give you, and I have removed the PPA for Debian-Yarn.

Results :

Code: Select all

2018-04-02 14:16:09 status installed hicolor-icon-theme:all 0.13-1
2018-04-02 14:16:10 status installed desktop-file-utils:amd64 0.22-1ubuntu1.1
2018-04-02 14:16:10 status installed mime-support:all 3.54ubuntu1.1
2018-04-02 14:16:11 status installed openjdk-7-jre-lib:all 7u171-2.6.13-0ubuntu0.14.04.2
2018-04-02 14:16:13 status installed openjdk-7-jre-headless:amd64 7u171-2.6.13-0ubuntu0.14.04.2
2018-04-02 14:16:14 status installed openjdk-7-jre:amd64 7u171-2.6.13-0ubuntu0.14.04.2
2018-04-02 14:16:14 status installed openjdk-7-jdk:amd64 7u171-2.6.13-0ubuntu0.14.04.2
2018-04-02 14:16:15 status installed libc-bin:amd64 2.19-0ubuntu6.14
2018-04-03 15:43:14 status installed libraw9:amd64 0.15.4-1ubuntu0.2
2018-04-03 15:43:15 status installed python-crypto:amd64 2.6.1-4ubuntu0.3
2018-04-03 15:43:15 status installed python3-crypto:amd64 2.6.1-4ubuntu0.3
2018-04-03 15:43:16 status installed libc-bin:amd64 2.19-0ubuntu6.14
2018-04-05 21:38:58 status installed libavahi-common-data:amd64 0.6.31-4ubuntu1.2
2018-04-05 21:38:58 status installed libavahi-common-data:i386 0.6.31-4ubuntu1.2
2018-04-05 21:38:58 status installed libavahi-common3:amd64 0.6.31-4ubuntu1.2
2018-04-05 21:38:59 status installed libavahi-common3:i386 0.6.31-4ubuntu1.2
2018-04-05 21:38:59 status installed libc-bin:amd64 2.19-0ubuntu6.14
2018-04-05 21:39:19 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-05 21:39:19 status installed ureadahead:amd64 0.100.0-16
2018-04-05 21:39:21 status installed menu:amd64 2.1.46ubuntu1
2018-04-05 21:39:21 status installed libavahi-common-dev:amd64 0.6.31-4ubuntu1.2
2018-04-05 21:39:21 status installed libavahi-client3:amd64 0.6.31-4ubuntu1.2
2018-04-05 21:39:22 status installed libavahi-client3:i386 0.6.31-4ubuntu1.2
2018-04-05 21:39:22 status installed libavahi-client-dev:amd64 0.6.31-4ubuntu1.2
2018-04-05 21:39:22 status installed libavahi-core7:amd64 0.6.31-4ubuntu1.2
2018-04-05 21:39:22 status installed libavahi-glib1:amd64 0.6.31-4ubuntu1.2
2018-04-05 21:39:22 status installed libvncserver0:amd64 0.9.9+dfsg-1ubuntu1.3
2018-04-05 21:39:23 status installed avahi-autoipd:amd64 0.6.31-4ubuntu1.2
2018-04-05 21:39:25 status installed avahi-daemon:amd64 0.6.31-4ubuntu1.2
2018-04-05 21:39:25 status installed avahi-utils:amd64 0.6.31-4ubuntu1.2
2018-04-05 21:39:25 status installed libruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-05 21:39:25 status installed ruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-05 21:39:26 status installed libc-bin:amd64 2.19-0ubuntu6.14
2018-04-05 21:39:26 status installed menu:amd64 2.1.46ubuntu1
2018-04-10 08:46:24 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-10 08:46:24 status installed libwayland-cursor0:amd64 1.4.0-1ubuntu1.1
2018-04-10 08:46:24 status installed libc-bin:amd64 2.19-0ubuntu6.14
2018-04-10 08:46:27 status installed libwayland-client0:amd64 1.4.0-1ubuntu1.1
2018-04-10 08:46:27 status installed libwayland-server0:amd64 1.4.0-1ubuntu1.1
2018-04-10 08:46:27 status installed libwayland-dev:amd64 1.4.0-1ubuntu1.1
2018-04-10 08:46:27 status installed libc-bin:amd64 2.19-0ubuntu6.14
2018-04-10 15:03:45 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-10 15:03:46 status installed patch:amd64 2.7.1-4ubuntu2.4
2018-04-18 21:20:44 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-18 21:20:46 status installed desktop-file-utils:amd64 0.22-1ubuntu1.1
2018-04-18 21:20:47 status installed mime-support:all 3.54ubuntu1.1
2018-04-18 21:20:49 status installed menu:amd64 2.1.46ubuntu1
2018-04-18 21:20:58 status installed hicolor-icon-theme:all 0.13-1
2018-04-18 21:21:33 status installed shared-mime-info:amd64 1.2-0ubuntu3
2018-04-18 21:21:35 status installed google-chrome-stable:amd64 66.0.3359.117-1
2018-04-18 21:22:21 status installed oracle-java8-installer:all 8u171-1~webupd8~0
2018-04-18 21:22:23 status installed menu:amd64 2.1.46ubuntu1
2018-04-18 21:23:30 status installed perl:amd64 5.18.2-2ubuntu1.3
2018-04-18 21:23:33 status installed perl-base:amd64 5.18.2-2ubuntu1.3
2018-04-18 21:23:34 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-18 21:25:06 status installed pidgin-dev:all 1:2.10.11-1ubuntu0+pidgin7.14.04
2018-04-18 21:25:08 status installed libpurple-dev:all 1:2.10.11-1ubuntu0+pidgin7.14.04
2018-04-18 21:25:08 status installed pidgin-mpris:amd64 0.2.3-2
2018-04-18 21:25:09 status installed pidgin:amd64 1:2.10.11-1ubuntu0+pidgin7.14.04
2018-04-18 21:25:09 status installed libpurple0:amd64 1:2.10.11-1ubuntu0+pidgin7.14.04
2018-04-18 21:25:09 status installed hplip:amd64 3.14.3-0ubuntu3.4
2018-04-18 21:25:11 status installed printer-driver-hpcups:amd64 3.14.3-0ubuntu3.4
2018-04-18 21:25:13 status installed libhpmud0:amd64 3.14.3-0ubuntu3.4
2018-04-18 21:25:13 status installed libsnmp30:amd64 5.7.2~dfsg-8.1ubuntu3.2
2018-04-18 21:25:13 status installed kvirc:amd64 4:4.2.0-2build1
2018-04-18 21:25:15 status installed kvirc-modules:amd64 4:4.2.0-2build1
2018-04-18 21:25:16 status installed perlqt-dev:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:16 status installed libphonon-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:17 status installed libqimageblitz-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:18 status installed libqscintilla-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:18 status installed libqt3support4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:19 status installed libqtxmlpatterns4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:19 status installed libqtxml4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:20 status installed libqtcore4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:20 status installed libqtdbus4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:20 status installed libqtdeclarative4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:21 status installed libqtgui4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:22 status installed libqthelp4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:22 status installed libqtnetwork4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:23 status installed libqtopengl4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:23 status installed libqtscript4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:24 status installed libqtsql4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:24 status installed libqtsvg4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:25 status installed libqttest4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:26 status installed libqtuitools4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:26 status installed libqtwebkit4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:27 status installed libsane-hpaio:amd64 3.14.3-0ubuntu3.4
2018-04-18 21:25:27 status installed pidgin-audacious:amd64 2.0.0-3
2018-04-18 21:25:28 status installed pidgin-libnotify:amd64 0.14-9ubuntu2
2018-04-18 21:25:29 status installed pidgin-skype:amd64 20130613+svn660+dfsg-1
2018-04-18 21:25:29 status installed pidgin-skype-common:amd64 20130613+svn660+dfsg-1
2018-04-18 21:25:30 status installed purple-hangouts:amd64 1.0+hg20180307-1~webupd8~trusty0
2018-04-18 21:25:30 status installed xchat:amd64 2.8.8-7.1ubuntu5.1
2018-04-18 21:25:31 status installed pidgin:amd64 1:2.10.11-1ubuntu0+pidgin7.14.04
2018-04-18 21:25:32 status installed libpurple0:amd64 1:2.10.11-1ubuntu0+pidgin7.14.04
2018-04-18 21:25:34 status installed libhpmud0:amd64 3.14.3-0ubuntu3.4
2018-04-18 21:25:35 status installed libsnmp30:amd64 5.7.2~dfsg-8.1ubuntu3.2
2018-04-18 21:25:35 status installed libqtcore4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
2018-04-18 21:25:40 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-18 21:25:41 status installed doc-base:all 0.10.5
2018-04-18 21:25:42 status installed libc-bin:amd64 2.19-0ubuntu6.14
2018-04-18 21:25:44 status installed cups:amd64 1.7.2-0ubuntu1.9
2018-04-18 21:25:45 status installed menu:amd64 2.1.46ubuntu1
2018-04-18 21:25:45 status installed desktop-file-utils:amd64 0.22-1ubuntu1.1
2018-04-18 21:25:45 status installed mime-support:all 3.54ubuntu1.1
2018-04-18 21:25:47 status installed hicolor-icon-theme:all 0.13-1
2018-04-18 21:25:51 status installed gconf2:amd64 3.2.6-0ubuntu2
2018-04-18 21:25:57 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-18 21:25:57 status installed ruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-18 21:25:57 status installed menu:amd64 2.1.46ubuntu1
2018-04-18 21:25:59 status installed yarn:all 1.6.0-1
2018-04-18 21:30:09 status installed perl:amd64 5.18.2-2ubuntu1.3
2018-04-18 21:30:11 status installed perl-base:amd64 5.18.2-2ubuntu1.3
2018-04-18 21:30:12 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-18 21:30:12 status installed ruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-18 21:30:12 status installed menu:amd64 2.1.46ubuntu1
2018-04-18 21:33:22 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-18 21:33:22 status installed ruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-18 21:33:22 status installed menu:amd64 2.1.46ubuntu1
2018-04-18 21:35:19 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-18 21:35:19 status installed ruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-18 21:35:19 status installed menu:amd64 2.1.46ubuntu1
2018-04-18 21:36:15 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-18 21:36:15 status installed ruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-18 21:36:15 status installed menu:amd64 2.1.46ubuntu1
2018-04-19 21:39:09 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-19 21:39:09 status installed ruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-19 21:39:10 status installed menu:amd64 2.1.46ubuntu1
2018-04-19 21:43:40 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-19 21:43:41 status installed ruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-19 21:43:41 status installed menu:amd64 2.1.46ubuntu1
2018-04-19 21:44:00 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-19 21:44:00 status installed ruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-19 21:44:00 status installed menu:amd64 2.1.46ubuntu1
2018-04-20 14:24:52 status installed man-db:amd64 2.6.7.1-1ubuntu1
2018-04-20 14:24:52 status installed ruby1.9.1:amd64 1.9.3.484-2ubuntu1.8
2018-04-20 14:24:52 status installed menu:amd64 2.1.46ubuntu1
2018-04-18 21:25:07 remove pidgin-dev:all 1:2.10.11-1ubuntu0+pidgin7.14.04 <none>
2018-04-18 21:25:08 remove libpurple-dev:all 1:2.10.11-1ubuntu0+pidgin7.14.04 <none>
2018-04-18 21:25:09 remove pidgin-mpris:amd64 0.2.3-2 <none>
2018-04-18 21:25:09 remove hplip:amd64 3.14.3-0ubuntu3.4 <none>
2018-04-18 21:25:11 remove printer-driver-hpcups:amd64 3.14.3-0ubuntu3.4 <none>
2018-04-18 21:25:13 remove kvirc:amd64 4:4.2.0-2build1 <none>
2018-04-18 21:25:15 remove kvirc-modules:amd64 4:4.2.0-2build1 <none>
2018-04-18 21:25:16 remove perlqt-dev:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:16 remove libphonon-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:17 remove libqimageblitz-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:18 remove libqscintilla-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:18 remove libqt3support4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:19 remove libqtxmlpatterns4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:19 remove libqtxml4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:20 remove libqtdbus4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:21 remove libqtdeclarative4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:21 remove libqtgui4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:22 remove libqthelp4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:22 remove libqtnetwork4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:23 remove libqtopengl4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:23 remove libqtscript4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:24 remove libqtsql4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:25 remove libqtsvg4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:25 remove libqttest4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:26 remove libqtuitools4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:26 remove libqtwebkit4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:27 remove libsane-hpaio:amd64 3.14.3-0ubuntu3.4 <none>
2018-04-18 21:25:27 remove pidgin-audacious:amd64 2.0.0-3 <none>
2018-04-18 21:25:28 remove pidgin-libnotify:amd64 0.14-9ubuntu2 <none>
2018-04-18 21:25:29 remove pidgin-skype:amd64 20130613+svn660+dfsg-1 <none>
2018-04-18 21:25:29 remove pidgin-skype-common:amd64 20130613+svn660+dfsg-1 <none>
2018-04-18 21:25:30 remove purple-hangouts:amd64 1.0+hg20180307-1~webupd8~trusty0 <none>
2018-04-18 21:25:31 remove xchat:amd64 2.8.8-7.1ubuntu5.1 <none>
2018-04-18 21:25:31 remove pidgin:amd64 1:2.10.11-1ubuntu0+pidgin7.14.04 <none>
2018-04-18 21:25:32 remove libpurple0:amd64 1:2.10.11-1ubuntu0+pidgin7.14.04 <none>
2018-04-18 21:25:34 remove libhpmud0:amd64 3.14.3-0ubuntu3.4 <none>
2018-04-18 21:25:35 remove libsnmp30:amd64 5.7.2~dfsg-8.1ubuntu3.2 <none>
2018-04-18 21:25:35 remove libqtcore4-perl:amd64 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 <none>
2018-04-18 21:25:36 remove libperl5.18:amd64 5.18.2-2ubuntu1.4 <none>
All of this happened pretty much when yarn started to install itself without asking if I wanted to remove all of those packages.

User avatar
smurphos
Level 5
Level 5
Posts: 674
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by smurphos » Fri Apr 20, 2018 11:43 pm

sudo apt-get check to see what dependency issues there are

apt-cache depends yarn to see what yarn says it needs / breaks / conflicts with.

apt-cache depends libperl5.18 - this is a pretty fundamental component which appears to have been chucked off the system...

maybe try sudo apt-get install libperl5.18 to see why that can't be installed.

fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by fruitkiller » Sat Apr 21, 2018 1:36 am

As usual, the only dependency it seems to want is...

Code: Select all

 for phil: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libruby1.9.1 : Depends: ruby1.9.1 (= 1.9.3.484-2ubuntu1.11) but 1.9.3.484-2ubuntu1.8 is installed
 ruby1.9.1 : Depends: libruby1.9.1 (= 1.9.3.484-2ubuntu1.8) but 1.9.3.484-2ubuntu1.11 is installed
I even downloaded the .deb file and gdebi tells me the same thing about broken deps.

Code: Select all

sudo apt-cache depends yarn
yarn
  Recommends: nodejs
  Conflicts: nodejs
  Conflicts: nodejs:i386
Already posted about this...

Code: Select all

bperl5.18
  Depends: libc6
  Depends: perl-base
  Replaces: perl-base
  Replaces: perl-base:i386
  Conflicts: libperl5.18:i386
Tried without the -f too, it all comes down back to ruby and libruby...

Code: Select all

sudo apt-get install -f libperl5.18
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libperl5.18 : Depends: perl-base (= 5.18.2-2ubuntu1.4) but 5.18.2-2ubuntu1.3 is to be installed
 libruby1.9.1 : Depends: ruby1.9.1 (= 1.9.3.484-2ubuntu1.11) but 1.9.3.484-2ubuntu1.8 is to be installed
 ruby1.9.1 : Depends: libruby1.9.1 (= 1.9.3.484-2ubuntu1.8) but 1.9.3.484-2ubuntu1.11 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Thanks for your help so far...it seems we're getting somewhere and in the thick of it.
Last edited by fruitkiller on Sat Apr 21, 2018 1:47 am, edited 1 time in total.

User avatar
smurphos
Level 5
Level 5
Posts: 674
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by smurphos » Sat Apr 21, 2018 1:44 am

Clutching at straws now - what happens if you try and install the correct perl-base version via a deb download? This link is for the 64bit version....

https://packages.ubuntu.com/trusty-upda ... e/download

fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by fruitkiller » Sat Apr 21, 2018 1:50 am

Like I said, I tried to install the .deb for ruby and I get a window over gdebi telling me I got, tells me to run gksudo synaptic or sudo apt-get install -f
...damnit.

I think it all lies in that error when I do sudo apt-get install -f :

Code: Select all

o you want to continue? [Y/n] Y
(Reading database ... 682503 files and directories currently installed.)
Preparing to unpack .../ruby1.9.1_1.9.3.484-2ubuntu1.11_amd64.deb ...
Unpacking ruby1.9.1 (1.9.3.484-2ubuntu1.11) over (1.9.3.484-2ubuntu1.8) ...
dpkg: error processing archive /var/cache/apt/archives/ruby1.9.1_1.9.3.484-2ubuntu1.11_amd64.deb (--unpack):
 unable to install new version of `/usr/bin/ruby1.9.1': Device or resource busy
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for menu (2.1.46ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/ruby1.9.1_1.9.3.484-2ubuntu1.11_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
That device or resource busy issue...

Maybe a reboot might help...I got no idea why it's saying that, I never saw this before in Linux, in windows, plenty of times...


fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by fruitkiller » Sat Apr 21, 2018 2:16 am

Great link thanks, we're getting there.

Although, lsod +D /usr/bin/libruby1.9.1 says that folder doesn't exist...

so I did it to /usr/bin/

I don't see what prevents installation...maybe a more apt eye than mine will :

Code: Select all

phil@17 ~ $ lsof +D '/usr/bin'
COMMAND     PID USER   FD   TYPE DEVICE SIZE/OFF    NODE NAME
vlc        2647 phil  txt    REG    8,1    14728 3163473 /usr/bin/vlc
lsof      13811 phil  txt    REG    8,1   163224 3146486 /usr/bin/lsof
lsof      13812 phil  txt    REG    8,1   163224 3146486 /usr/bin/lsof
audacious 15171 phil  txt    REG    8,1   128976 3158025 /usr/bin/audacious
ssh       16741 phil  txt    REG    8,1   641664 3153243 /usr/bin/ssh
pulseaudi 25219 phil  txt    REG    8,1    88120 3152178 /usr/bin/pulseaudio
mate-sess 25311 phil  txt    REG    8,1   231600 3146564 /usr/bin/mate-session
dbus-laun 25399 phil  txt    REG    8,1    27296 3145946 /usr/bin/dbus-launch
mate-sett 25416 phil  txt    REG    8,1    40232 3146567 /usr/bin/mate-settings-daemon
marco     25418 phil  txt    REG    8,1   556928 3146520 /usr/bin/marco
mate-pane 25423 phil  txt    REG    8,1   607400 3146550 /usr/bin/mate-panel
sh        25451 phil   10r   REG    8,1       21 3147121 /usr/bin/startcaja
caja      25457 phil  txt    REG    8,1  1911432 3145867 /usr/bin/caja
blueman-a 25459 phil  txt    REG    8,1  3341288 3151280 /usr/bin/python2.7
gksu      25472 phil  txt    REG    8,1    28176 3146157 /usr/bin/gksu
nm-applet 25475 phil  txt    REG    8,1   316112 3146709 /usr/bin/nm-applet
mate-scre 25478 phil  txt    REG    8,1   156968 3146558 /usr/bin/mate-screensaver
mate-volu 25479 phil  txt    REG    8,1   115152 3146578 /usr/bin/mate-volume-control-applet
mate-powe 25484 phil  txt    REG    8,1   185184 3146554 /usr/bin/mate-power-manager
mintmenu  25497 phil  txt    REG    8,1  3341288 3151280 /usr/bin/python2.7
mintupdat 25644 phil  txt    REG    8,1  3341288 3151280 /usr/bin/python2.7
mintUpdat 25648 phil  txt    REG    8,1  3341288 3151280 /usr/bin/python2.7
/usr/bin/ 26147 phil  txt    REG    8,1  3341288 3151280 /usr/bin/python2.7
mate-term 26855 phil  txt    REG    8,1   314016 3146571 /usr/bin/mate-terminal
pluma     30692 phil  txt    REG    8,1   683920 3146817 /usr/bin/pluma

fruitkiller
Level 4
Level 4
Posts: 349
Joined: Tue Aug 05, 2014 7:52 pm

Re: Just had updates for perl and libruby/ruby, only yarn installed and it uninstalled a lot of stuff and now dependency

Post by fruitkiller » Sat Apr 21, 2018 2:56 am

Well, that turned out too complicated for me, so I just closed everything non-essential, vlc, audacious, sound-converter, filezilla.

apt-get install -f worked

Now, I just need help on how to bring back everything on its feet.

Thanks smurphos.

I guess I should install that perl package you were speaking of and then see where it goes from there.

edit: All's fine now, first lesson, always check what PPA's might be installed...you might not have put them there manually.

Only one update left is SystemD but I never installed that. Thanks very much. 8)

Post Reply

Return to “Software & Applications”