MAT (Metadata Anonymisation Toolkit) installs but fails to launch: Is it broken?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
purpletree
Level 1
Level 1
Posts: 22
Joined: Tue Apr 10, 2018 12:55 am

MAT (Metadata Anonymisation Toolkit) installs but fails to launch: Is it broken?

Post by purpletree » Thu Apr 19, 2018 5:37 pm

I'm looking for software that can remove metadata from all kinds of files. It looks like MAT (Metadata Anonymisation Toolkit) is what I'm looking for.
When I used Software Manager to install it there's a couple of python dependencies that I also installed. The install process appeared error free. When I chose to Launch from the Software Manager it didn't work. Nothing happened.
I've since tried Removing and reinstalling from the Terminal. Again, no errors. But when I run

Code: Select all

mat-gui
this is what happens:
Traceback (most recent call last):
File "/usr/bin/mat-gui", line 18, in <module>
from libmat import mat
File "/usr/lib/python2.7/dist-packages/libmat/mat.py", line 22, in <module>
import strippers # this is loaded here because we need LOGGING_LEVEL
File "/usr/lib/python2.7/dist-packages/libmat/strippers.py", line 9, in <module>
import office
File "/usr/lib/python2.7/dist-packages/libmat/office.py", line 15, in <module>
gi.require_version('Poppler', '0.18')
File "/usr/lib/python2.7/dist-packages/gi/__init__.py", line 102, in require_version
raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Poppler not available
So is this a broken package or am I missing something on my end that I should know how to do?

I'm using
Linux Mint 18.3 KDE Edition
KDE Plasma Version: 5.8.9
KDE Frameworks Version: 5.36.0
Qt Version: 5.6.1
Kernel Version: 4.10.0-38-generic
OS Type: 64-bit

User avatar
WharfRat
Level 20
Level 20
Posts: 11559
Joined: Thu Apr 07, 2011 8:15 pm

Re: MAT (Metadata Anonymisation Toolkit) installs but fails to launch: Is it broken?

Post by WharfRat » Thu Apr 19, 2018 8:56 pm

purpletree,

I just tried to install and run mat-gui and got the exact same results as you did.

So I would say that package is either obsolete or broken.
ImageImage

Post Reply

Return to “Software & Applications”