Eric IDE installed won't launch

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
hardy765419
Level 1
Level 1
Posts: 1
Joined: Thu Apr 19, 2018 9:16 pm

Eric IDE installed won't launch

Post by hardy765419 » Thu Apr 19, 2018 10:04 pm

<r><t>I installed Eric IDE using both Synaptic (Eric6) and paquet manager. The installation goes okay according to synaptic. However, the syslog picks up the following errors at installation using package launcher: <br/>
<CODE><s>

Code: Select all

</s>Apr 19 21:30:40 mars AptDaemon.Trans: INFO: Queuing transaction /org/debian/apt/transaction/2e9276b91a1e4684be693aa0d70fa975<br/>
Apr 19 21:30:40 mars org.debian.apt[837]: 21:30:40 AptDaemon.Trans [INFO]: Queuing transaction /org/debian/apt/transaction/2e9276b91a1e4684be693aa0d70fa975<br/>
Apr 19 21:30:44 mars AptDaemon.Worker: INFO: Processing transaction /org/debian/apt/transaction/2e9276b91a1e4684be693aa0d70fa975<br/>
Apr 19 21:30:44 mars org.debian.apt[837]: 21:30:44 AptDaemon.Worker [INFO]: Processing transaction /org/debian/apt/transaction/2e9276b91a1e4684be693aa0d70fa975<br/>
Apr 19 21:31:00 mars AptDaemon.Worker: INFO: Finished transaction /org/debian/apt/transaction/2e9276b91a1e4684be693aa0d70fa975<br/>
Apr 19 21:31:00 mars org.debian.apt[837]: /usr/lib/python3/dist-packages/aptdaemon/progress.py:491: Warning: Source ID 46 was not found when attempting to remove it<br/>
Apr 19 21:31:00 mars org.debian.apt[837]:   GLib.source_remove(id)<br/>
Apr 19 21:31:00 mars org.debian.apt[837]: /usr/lib/python3/dist-packages/aptdaemon/progress.py:491: Warning: Source ID 47 was not found when attempting to remove it<br/>
Apr 19 21:31:00 mars org.debian.apt[837]:   GLib.source_remove(id)<br/>
Apr 19 21:31:00 mars org.debian.apt[837]: 21:31:00 AptDaemon.Worker [INFO]: Finished transaction /org/debian/apt/transaction/2e9276b91a1e4684be693aa0d70fa975<e>
</e></CODE><br/><br/>
<br/><br/>
When I try to launch the program, nothing happens. I followed the launch process in the syslog, but it did not pick up anything. <br/><br/>
<br/><br/>
Here is the hardware info:<br/><br/>

Code: Select all

System:    Host: mars Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)<br/><br/>
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.3 Sylvia<br/><br/>
Machine:   Mobo: Gigabyte model: H81M-D2V v: x.x<br/><br/>
           Bios: American Megatrends v: F1 date: 07/15/2013<br/><br/>
CPU:       Dual core Intel Pentium G3220 (-MCP-) cache: 3072 KB<br/><br/>
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12000<br/><br/>
           clock speeds: max: 3000 MHz 1: 1426 MHz 2: 2098 MHz<br/><br/>
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphic][/quote]<br/><br/>
<br/><br/>
I have googled the problem and I have looked in Mint forums, but I haven't found a solution.</t><br/>

Update April 22, 2018
I tried to launch Eric from the terminal. Here is the error message:

Code: Select all

/usr/bin $ ./eric
QApplication: invalid style override passed, ignoring it.
Error in sys.excepthook:
Traceback (most recent call last):
  File "<frozen importlib._bootstrap>", line 969, in _find_and_load
  File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 673, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 665, in exec_module
  File "<frozen importlib._bootstrap>", line 222, in _call_with_frames_removed
  File "/usr/share/eric/modules/Utilities/__init__.py", line 73, in <module>
    import Preferences
  File "/usr/share/eric/modules/Preferences/__init__.py", line 36, in <module>
    from PyQt5.QtWebKit import QWebSettings
ImportError: No module named 'PyQt5.QtWebKit'

Original exception was:
Traceback (most recent call last):
  File "/usr/share/eric/modules/eric6.py", line 326, in <module>
    main()
  File "/usr/share/eric/modules/eric6.py", line 240, in main
    import Preferences
  File "/usr/share/eric/modules/Preferences/__init__.py", line 36, in <module>
    from PyQt5.QtWebKit import QWebSettings
ImportError: No module named 'PyQt5.QtWebKit'
Python3-PyQt5.QtWebKit is installed in my computer. But Python-'PyQt5.QtWebKit is not.
Can anyone give me some guidance?

eegrek39
Level 1
Level 1
Posts: 25
Joined: Fri Jun 19, 2015 9:30 am
Location: Norfolk

Re: Eric IDE installed won't launch

Post by eegrek39 » Sat Aug 18, 2018 8:01 am

I had the same problem - at first the eric6 splash screen showed but the application never launched. I ensured I installed the required dependencies as shown on the eric website. After trying a few things even the splash screen disappeared and nothing at all happened. The way I got it to launch was to
Uninstall eric6
ensure dependencies
sudo apt install python3-pip
pip3 install qsscintilla
Then install eric6 again from the software manager.
THIS WAS SUCCESSFULL

I tried previous to these instructions
pip install --upgrade pip (which may have helped),
If trying this does not help then I will look back to see what further previous things I did which may have got me going.

Post Reply

Return to “Software & Applications”