Sound level 100% and yet too quiet...

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Rhinox
Level 1
Level 1
Posts: 15
Joined: Wed Aug 16, 2017 12:26 pm

Sound level 100% and yet too quiet...

Post by Rhinox » Sun May 13, 2018 2:21 pm

Not sure if this belongs to hw or sw-forum, but anyway:

After my troubles with on-board realtek sound chip (I did not solve crackling noise) I disabled it in bios, mounted asus xonar dx, and reinstalled LM. Everything works, and sound is clear.

The only problem is, sound level is too low even with volume setting 100%. I have to turn volume on my speakers really high. Then when I reboot to windows (where volume is on 30%), it's roaring like crazy, and I have to turn quickly volume on speakers down. Quite annoying. How could I fix this?

User avatar
Flemur
Level 15
Level 15
Posts: 5662
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Sound level 100% and yet too quiet...

Post by Flemur » Sun May 13, 2018 2:55 pm

Rhinox wrote:
Sun May 13, 2018 2:21 pm
mounted asus xonar dx, and reinstalled LM. Everything works, and sound is clear.

The only problem is, sound level is too low even with volume setting 100%. I have to turn volume on my speakers really high. Then when I reboot to windows (where volume is on 30%), it's roaring like crazy, and I have to turn quickly volume on speakers down. Quite annoying. How could I fix this?
1 - Don't boot windows.

2 - More seriously (I think), install "qasmixer" (like alsamixer but better) and "pavucontrol" - there are probably 3 or 4 different places where you can set the volume in an audio stream: in qasmixer, I see volumes for
Master, PCM, Front/Center, Wave, (and if you're running from line-in), Line.

Then there's pulseaudio on top of that.

Also search the forums - "audio too quiet" isn't a rare problem.
qasmixer.jpg
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

User avatar
phd21
Level 16
Level 16
Posts: 6210
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Sound level 100% and yet too quiet...

Post by phd21 » Sun May 13, 2018 3:06 pm

Hi Rhinox,

I just read your post and the good replies to it. Here are my thoughts on this as well.

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

+1 for installing "QasMixer" and the other Qas packages from the "Synaptic Package Manager (SPM)".
+1 for installing "Pulse Audio Volume control" as well.

You can also tell the system to go above 100% volume, I think there is an applet for that in Linux Mint Cinnamon called "Sound 150%", and there are other methods too.


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
lsemmens
Level 4
Level 4
Posts: 386
Joined: Wed Sep 10, 2014 9:07 pm
Location: Rural South Australia

Re: Sound level 100% and yet too quiet...

Post by lsemmens » Mon May 14, 2018 10:22 am

Yes, phd21 is correct, there is an applet call "sound 150%" it works as it's name implies.
Kernel: 4.13.0-37-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia

Laptop T4500 Dualcore 3Gb RAM
Out of my mind - please leave a message

Rhinox
Level 1
Level 1
Posts: 15
Joined: Wed Aug 16, 2017 12:26 pm

Re: Sound level 100% and yet too quiet...

Post by Rhinox » Sun May 20, 2018 12:57 pm

I installed QasMixer and found my "master" volume setting to -25dB. So I turned it up, and everything was OK.

The only problem is the change is not persistent. Whenever I reboot, I have to do it again because master-volume is down to -25dB. Could this be somehow fixed too?

User avatar
phd21
Level 16
Level 16
Posts: 6210
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Sound level 100% and yet too quiet...

Post by phd21 » Sun May 20, 2018 1:04 pm

HI Rhinox,

You are welcome from all of us that replied ...

QasMixer has settings which may or may not be retained from the previous session. Since I upgraded to Linux Mint 18.x based on Ubuntu 16.04, I cannot get QasMixer to remember my user settings either. So like you, I have to run QasMixer every time I restart and check the settings (minor hassle).

If anyone knows how to make the QasMixer settings stick, I too would like to know this.

...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
Flemur
Level 15
Level 15
Posts: 5662
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Sound level 100% and yet too quiet...

Post by Flemur » Sun May 20, 2018 6:01 pm

Rhinox wrote:
Sun May 20, 2018 12:57 pm
The only problem is the change is not persistent. Whenever I reboot, I have to do it again because master-volume is down to -25dB. Could this be somehow fixed too?
A "hack" is to set the audio when you login, namely run something like: That's a line from my "make the audio civilized" script that runs when I login.

You can run those "amixer" commands in a terminal and watch the values changes in qasmixer or alsamixer.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

User avatar
phd21
Level 16
Level 16
Posts: 6210
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Sound level 100% and yet too quiet...

Post by phd21 » Sun May 20, 2018 10:44 pm

Hi Rhinox,

I did a lot more research into this QasMixer and AlsaMixer problem saving user changes persistently after rebooting in Linux Mint 18.x Ubuntu 16.04 both of which worked perfectly before in Linux Mint 17.x based on Ubuntu 14.04.
------------------------------------------------------------------------------------------------------------------------------
Mikoto San wrote:Yes I launched alsamixer (or QasMixer) from the console terminal prompt as Sudo and saved it as Sudo.
I've seen ubuntu support where it states to save the settings it is necessary to open a second terminal and input the store command when alsamixer is still running in the first terminal.

Code: Select all

sudo qasmixer
or

Code: Select all

sudo alsamixer
You can easily make the settings stay after reboot!

just use this command AFTER you applied the settings ;-) while alsamixer or qasmixer is still running:

Code: Select all

sudo alsactl store
This should store all the settings in the configuration file, and make sure it works on boot ;-)
OR another similar approach
tisfo wrote:1.) Firstly type in terminal "alsamixer" (or qasmixer) to enter the alsamixer UI. Then make the configurations you need(e.g increase speakers/headphones level or unmute something pressing "m" on keyboard).

Now the most important part. 2.) Before you exit alsamixer (or qasmixer), open a new terminal (or new terminal tab) and do : "sudo su" to get high privileges (Be very careful with commands you use in "sudo su" mode because you may destroy your system) and then do "alsactl store" to save alsa settings. Then close both terminals and restart your computer. This will do the job.

Code: Select all

sudo su

Code: Select all

alsactl store

Code: Select all

exit
Articles and posts
Qasmixer and alsamixer not saving user changes:
Save settings Alsamixer – CloudReady
https://neverware.zendesk.com/hc/en-us/ ... -Alsamixer

alsa - Howto save AlsaMixer settings? - Ask Ubuntu
https://askubuntu.com/questions/50067/h ... r-settings

alsa - Howto save AlsaMixer settings? - Ask Ubuntu
https://askubuntu.com/questions/50067/h ... r-settings


FYI: In my KDE System Settings -> Startup, there are also "desktop session" settings, restore previous settings, restore manually saved session, or start empty (new) session. None of these affected my sound settings. I use an empty (new) session setting because the new KDE Plasma 5 would duplicate my startup apps with any previously running apps when I restarted my computer.

Hope this helps ...
Last edited by phd21 on Sun May 20, 2018 11:14 pm, edited 3 times in total.
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

MrEen
Level 5
Level 5
Posts: 682
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound level 100% and yet too quiet...

Post by MrEen » Sun May 20, 2018 10:55 pm

Hi phd21. I think I'm starting to understand this stuff better and just wanted to add to your last post the following.

If the settings don't survive a reboot (something else loading later changes them, for example,) then sudo alsactl restore should reload your saved settings.

Additionally, if you have multiple sound cards, both store and restore can be followed by the card number (sudo alsactl store 0 sudo alsactl restore 1 etc.) Leaving off the number stores and restores settings on all cards

User avatar
phd21
Level 16
Level 16
Posts: 6210
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Sound level 100% and yet too quiet...

Post by phd21 » Sun May 20, 2018 11:05 pm

Hi MrEen,

Sounds like you are understanding this stuff better. You are correct with your comments and the links I provided mention the "restore" options as well.

In addition to your comments and those from the articles, there could be something else changing your user profile or session after you login, so if just saving the new user configuration does not work, you could even create a simple bash script file with the restore command (sudo alsactl restore) and add that to your startup application options if need be.
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Post Reply

Return to “Software & Applications”