Problem installing Screenkey

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
sebsensegreen
Level 1
Level 1
Posts: 2
Joined: Tue May 26, 2015 2:03 pm

Problem installing Screenkey

Post by sebsensegreen » Fri May 18, 2018 9:57 pm

TL;DR:
Wasn't able to open screenkey's preferences in the default version from the software manager.
Read somewhere to install from scratch to correct problem.
Complete nightmare.
Now can't reinstall default version, always get error.

Long story:
Hi, first of all, I'm not very skilful in Linux. I just want to put it out there.
I wanted to make some screencasts and needed screenkey to display the keystrokes so I installed the default version from the software manager. Unfortunately, the preferences windows wouldn't open so I can't configure it and by default it uses both my monitor as one giant monitor and display the keystrokes "in-between" the two monitors.

I searched a bit on google and apparently if I install the real latest version I shouldn't have this problem. So I uninstall the default version and proceed to try to install the "real" version. Now, this is written in python I believe so the rabbit hole nightmare starts here.

I tried their "how-to" install via pip... had to install it. screenkey didn't work for some reason so I decided to install from the sources... big mistake, nothing worked correctly... I needed the python dev packages, etc... Everything broke, I'm completely lost and decided to just backtrack everything and remove all of what I did. Even after uninstalling everything, apparently there was still traces of my python/pip/screenkey ordeal and somehow, screenkey was still installed but was uninstalled from everywhere... so I manually deleted the executable.

Now, I reinstalled the default version. But now all I get is this error when I try to start it:
Traceback (most recent call last):
File "/usr/bin/screenkey", line 59, in <module>
Main()
File "/usr/bin/screenkey", line 54, in Main
s = Screenkey(logger=logger, nodetach=options.nodetach)
TypeError: __init__() got an unexpected keyword argument 'nodetach'
I tried to mark it as "complete removal" in the package manager but without success.
Any ideas on how to solve this problem?
Thanks.

Post Reply

Return to “Software & Applications”