CODEC Install procedures yield DIFFERENT packages!

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Webtest
Level 4
Level 4
Posts: 291
Joined: Sun Feb 21, 2010 4:45 pm
Location: Carlisle, Pennsylvania, USA

CODEC Install procedures yield DIFFERENT packages!

Post by Webtest » Wed May 23, 2018 2:33 pm

Esteemed Forum Participants & Lurkers:
NOTE: LM 18.3 LiveMedia system from LOCKED flash drives.

Mint surely has it's quirks. I started streaming videos in 18.3, and installation of both flash as well as other codecs are required for various sources.

According to the LM 18.3 Release Notes, to load the required files for offline installation of codecs (for all 4 Desktops):
Boot from the Linux Mint ISO on a computer which is connected to the Internet
Open a terminal and type "apt download mint-meta-codecs" (without the quotes)
This creates a "mint-meta-codecs.tgz" archive
That's great, but when I do an "sudo apt-get install mint-meta-codecs", it loads and installs a DIFFERENT set of files! About 33 of the 123 files are different. I would have thought they would all be the same ??? Here are about half of the differences ... the 1st in a pair is from the "apt-get install" and the 2nd is from the "tgz" archive:

Code: Select all

!  896760 Mar 30  2016 chromium-codecs-ffmpeg-extra_49.0.2623.108-0ubuntu1.1233_amd64.deb
- 1018526 May 11 15:23 chromium-codecs-ffmpeg-extra_66.0.3359.139-0ubuntu0.16.04.3_amd64.deb

!  107386 Mar 25  2016 gstreamer1.0-libav_1.8.0-1_amd64.deb
-   92484 Feb 14  2017 gstreamer1.0-libav_1.8.3-1ubuntu0.2_amd64.deb

! 1361448 Mar 25  2016 gstreamer1.0-plugins-bad_1.8.0-1ubuntu1_amd64.deb
- 1362542 Nov 23  2016 gstreamer1.0-plugins-bad_1.8.3-1ubuntu0.2_amd64.deb

!   21452 Mar 25  2016 gstreamer1.0-plugins-bad-faad_1.8.0-1ubuntu1_amd64.deb
-   21416 Nov 23  2016 gstreamer1.0-plugins-bad-faad_1.8.3-1ubuntu0.2_amd64.deb

!   84906 Mar 25  2016 gstreamer1.0-plugins-bad-videoparsers_1.8.0-1ubuntu1_amd64.deb
-   84924 Nov 23  2016 gstreamer1.0-plugins-bad-videoparsers_1.8.3-1ubuntu0.2_amd64.deb

!  215134 Mar 25  2016 gstreamer1.0-plugins-ugly_1.8.0-1ubuntu1_amd64.deb
-  215714 Sep  6  2016 gstreamer1.0-plugins-ugly_1.8.3-1ubuntu0.1_amd64.deb

!   33748 Mar 25  2016 gstreamer1.0-plugins-ugly-amr_1.8.0-1ubuntu1_amd64.deb
-   18648 Sep  6  2016 gstreamer1.0-plugins-ugly-amr_1.8.3-1ubuntu0.1_amd64.deb

!   13020 Mar 14  2016 libavcodec-extra_7%3a2.8.6-1ubuntu2_all.deb
-   13026 Apr 12 13:29 libavcodec-extra_7%3a2.8.14-0ubuntu0.16.04.1_all.deb

! 4083332 Mar 14  2016 libavcodec-ffmpeg-extra56_7%3a2.8.6-1ubuntu2_amd64.deb
- 4090274 Apr 12 13:29 libavcodec-ffmpeg-extra56_7%3a2.8.14-0ubuntu0.16.04.1_amd64.deb

!  531124 Mar 14  2016 libavfilter-ffmpeg5_7%3a2.8.6-1ubuntu2_amd64.deb
-  530380 Apr 12 13:29 libavfilter-ffmpeg5_7%3a2.8.14-0ubuntu0.16.04.1_amd64.deb

!  805092 Mar 14  2016 libavformat-ffmpeg56_7%3a2.8.6-1ubuntu2_amd64.deb
-  807684 Apr 12 13:29 libavformat-ffmpeg56_7%3a2.8.14-0ubuntu0.16.04.1_amd64.deb

!   51938 Mar 14  2016 libavresample-ffmpeg2_7%3a2.8.6-1ubuntu2_amd64.deb
-   51974 Apr 12 13:29 libavresample-ffmpeg2_7%3a2.8.14-0ubuntu0.16.04.1_amd64.deb

!  165606 Mar 14  2016 libavutil-ffmpeg54_7%3a2.8.6-1ubuntu2_amd64.deb
-  165580 Apr 12 13:29 libavutil-ffmpeg54_7%3a2.8.14-0ubuntu0.16.04.1_amd64.deb

!  121602 Oct 23  2015 libgme0_0.6.0-3_amd64.deb
-  122034 Dec 13  2016 libgme0_0.6.0-3ubuntu0.16.04.1_amd64.deb

!  411288 Mar 25  2016 libgstreamer-plugins-bad1.0-0_1.8.0-1ubuntu1_amd64.deb
-  400658 Nov 23  2016 libgstreamer-plugins-bad1.0-0_1.8.3-1ubuntu0.2_amd64.deb

!   38250 Feb  2  2015 libmspack0_0.5-1_amd64.deb
-   36980 Aug 17  2017 libmspack0_0.5-1ubuntu0.16.04.1_amd64.deb
So, which is the "correct" or "optimum" set of files to use ???

Thank you for any comments, suggestions, and assistance.
Blessings in abundance, all the best, & ENJOY!
Art in Carlisle, PA USA
BOAT - a hole in the water that you pour money into
LINUX - a hole in your life that you pour TIME into

HP dx2400 Core 2 Duo 4 GB - Mint 10 Gnome, Mint 13/15/17.x/18.x Mate <on LOCKED SD cards, and Kanguru USB drives>

User avatar
administrollaattori
Level 13
Level 13
Posts: 4969
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: CODEC Install procedures yield DIFFERENT packages!

Post by administrollaattori » Wed May 23, 2018 3:24 pm

The difference can be caused by non-updated system. Basically liveUSBs are intended to use for testing and installing, NOT for every day use.

Post Reply

Return to “Software & Applications”