Uninstalled nvidia-settings, now can't reinstall it

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
proto-nova
Level 1
Level 1
Posts: 2
Joined: Sat May 26, 2018 3:10 pm

Uninstalled nvidia-settings, now can't reinstall it

Post by proto-nova » Sat May 26, 2018 3:29 pm

A little information on my set up:
  • Nvidia 1080 Graphics Card
    nvidia-396 drivers
    Linux Mint 18.3
    Kernal version 4.13.0-43-generic
I was trying to to install CUDA drivers when I ran into this error

Code: Select all

The following packages have unmet dependencies:
 cuda : Depends: cuda-9-2 (>= 9.2.88) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Drilling down through the dependency requirements I found that the real problem was with my version of `nvidia-settings`.

Code: Select all

The following packages have unmet dependencies:
 cuda-drivers : Depends: nvidia-settings (>= 396.26) but 361.42-0ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.
I'm currently running the `nvidia-396` drivers without issue, but for some reason my `nvidia-settings` package wouldn't update to the latest version. Out of desperation I thought I would simply uninstall it completely and reinstall it -- except I can't. I can't figure out how to install version 361 of `nvidia-settings`, and I can't get version 396 because of this underlying error that turned out to be preventing the upgrade

Code: Select all

The following packages have unmet dependencies:
 nvidia-settings : Depends: libgtk2.0-0 (>= 2.24.31) but 2.24.30-1ubuntu1.16.04.2 is to be installed
E: Unable to correct problems, you have held broken packages.
And it's here I'm totally stuck. libgtk2.24.31 does appear to be in the repos and I'm not sure how to get it, or why I'm even having this problem as a google search doesn't seem to show anyone else with this issue. Is CUDA 9.2 not install able on Mint 18.3?

proto-nova
Level 1
Level 1
Posts: 2
Joined: Sat May 26, 2018 3:10 pm

Re: Uninstalled nvidia-settings, now can't reinstall it

Post by proto-nova » Sun May 27, 2018 5:17 pm

It turns out this problem was stemming from the fact that I had downloaded the wrong CUDA libraries. I forgot that Mint 18.3 used the Xenial 16.04 repos and had downloaded that 17.10 version of CUDA from Nvidia. Getting the correct version solved all my problems.

Post Reply

Return to “Software & Applications”