Files with .drive extension.

Questions about applications and software
Forum rules
Before you post please read how to get help
alex-n3050
Level 1
Level 1
Posts: 26
Joined: Sun Nov 22, 2015 10:54 pm

Files with .drive extension.

Post by alex-n3050 » Tue May 29, 2018 5:26 am

Where in Linuxmint there are files with the extension .drive?
They are used when displaying information about your computer in cinnamon.

User avatar
Flemur
Level 17
Level 17
Posts: 7073
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Files with .drive extension.

Post by Flemur » Tue May 29, 2018 10:57 am

alex-n3050 wrote:
Tue May 29, 2018 5:26 am
Where in Linuxmint there are files with the extension .drive?
This will find them:

Code: Select all

sudo find / -iname "*.drive" 
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

alex-n3050
Level 1
Level 1
Posts: 26
Joined: Sun Nov 22, 2015 10:54 pm

Re: Files with .drive extension.

Post by alex-n3050 » Tue May 29, 2018 11:33 am

> sudo find / -iname "*.drive"

I'm unpleasantly surprised this command returns no result.

User avatar
smurphos
Level 12
Level 12
Posts: 4077
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Files with .drive extension.

Post by smurphos » Tue May 29, 2018 12:05 pm

I'm intrigued - what makes you think there should be files with that extension or that the extension is anything to do with Cinnamon?
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

alex-n3050
Level 1
Level 1
Posts: 26
Joined: Sun Nov 22, 2015 10:54 pm

Re: Files with .drive extension.

Post by alex-n3050 » Tue May 29, 2018 8:21 pm

I'm surprised, too.
Too big size of screenshots does not allow to attach them to the message. I put them on the server.

https://ibb.co/mE7kFy

User avatar
smurphos
Level 12
Level 12
Posts: 4077
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Files with .drive extension.

Post by smurphos » Wed May 30, 2018 12:31 am

I see....I've never really seen the use of the 'COMPUTER' view in Nemo. AFAIK this just shows physical drives currently available to the system although you can't do anything with any of them from that screen other than navigate into 'File System' - where any mounted drives will be accessible anyway at their mount point.

What are you trying to do?

E2a - I just remembered this is in the Cinnamon Development Roadmap - not only me who doesn't see any use for that screen ---
nemo: retire computer:/// place (which is completely useless) or revamp it into something better
from - https://github.com/linuxmint/Roadmap
Last edited by smurphos on Wed May 30, 2018 1:39 am, edited 1 time in total.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
catweazel
Level 19
Level 19
Posts: 9187
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Files with .drive extension.

Post by catweazel » Wed May 30, 2018 1:38 am

alex-n3050 wrote:
Tue May 29, 2018 8:21 pm
I'm surprised, too.
I'm not. What is the nature of the problem you want help with?
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

alex-n3050
Level 1
Level 1
Posts: 26
Joined: Sun Nov 22, 2015 10:54 pm

Re: Files with .drive extension.

Post by alex-n3050 » Wed May 30, 2018 2:27 am

The main problem is that Nemo does not see my NVMe SSD drive, but the nvme utility sees it.
Namo says "Unnamed Drive /dev/nvme0n1"

Nemo screenshot available here -> https://ibb.co/mE7kFy

> nvme list

Node SN Model Namespace Usage Format FW Rev
---------------- -------------------- ---------------------------------------- --------- -------------------------- ---------------- --------
/dev/nvme0n1 S3ESNX0K437588X Samsung SSD 960 EVO 250GB 1 250,06 GB / 250,06 GB 512 B + 0 B 3B7QCXE7

I don't have any problems with the disc. He's efficient. Just have the discomfort of the fact that information about it for some reason is not displayed.
Also surprised with the fact that when booting the Linux kernel, unlike SATA drives, not logged on it any information.
During kernel booting device has successfully probed, but information about model has not displayed.
I don't want to work with an anonymous device.

> lspci | grep Samsung

02:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM961

> dmesg | grep nvme
[ 1.816108] nvme nvme0: pci function 0000:02:00.0
[ 2.058600] nvme0n1: p1 p2 < p5 >
[ 3.770957] EXT4-fs (nvme0n1p5): mounted filesystem with ordered data mode. Opts: (null)
[ 4.034318] EXT4-fs (nvme0n1p5): re-mounted. Opts: errors=remount-ro
[ 4.500509] EXT4-fs (nvme0n1p1): mounted filesystem with ordered data mode. Opts: (null)
Last edited by alex-n3050 on Wed May 30, 2018 3:11 am, edited 1 time in total.

User avatar
catweazel
Level 19
Level 19
Posts: 9187
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Files with .drive extension.

Post by catweazel » Wed May 30, 2018 2:57 am

alex-n3050 wrote:
Wed May 30, 2018 2:27 am
The main problem is that Nemo does not see my NVMe SSD drive, but the nvme utility sees it.
Namo says "Unnamed Drive /dev/nvme0n1"

Nemo screenshot available here -> https://ibb.co/mE7kFy
Well, that's easy fixed. If your NVMe is your boot device, start a live Mint session and use gparted to label the disk:

Image

If it isn't your boot disk then sudo apt-get install gparted, then label the disk from there.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

alex-n3050
Level 1
Level 1
Posts: 26
Joined: Sun Nov 22, 2015 10:54 pm

Re: Files with .drive extension.

Post by alex-n3050 » Wed May 30, 2018 3:14 am

Your advice didn't help. I have this menu item hidden.

User avatar
smurphos
Level 12
Level 12
Posts: 4077
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Files with .drive extension.

Post by smurphos » Wed May 30, 2018 3:15 am

NVME is a fairly new standard I believe. It might just be that nemo has never being updated to support displaying drive info for NVME on that screen, given that that screen is intended to be deprecated at some point or that the NVME kernel driver doesn't support providing a model name. Does it get a name/model in Gnome Disks? gnome-disks to launch from terminal or Disks in the menu.

If the drive appears in /dev/ and mounts OK I wouldn't be worried.

According to the Archwiki - https://wiki.archlinux.org/index.php/So ... Linux_4.10 - there is a bug in the 4.10 kernel driver affecting Samsung NVME's. Whilst it's not given that Ubuntu maintained 4.10 kernels have the same problem you may want to avoid running a 4.10 kernel. 4.10 is now EOL anyway so you should be using a 4.4 or 4.13 currently in any case on Mint 18.x

I see this for my regular drives in Nemo / Disks...

Image
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
smurphos
Level 12
Level 12
Posts: 4077
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Files with .drive extension.

Post by smurphos » Wed May 30, 2018 3:25 am

For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
catweazel
Level 19
Level 19
Posts: 9187
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Files with .drive extension.

Post by catweazel » Wed May 30, 2018 3:26 am

smurphos wrote:
Wed May 30, 2018 3:15 am
NVME is a fairly new standard I believe. It might just be that nemo has never being updated to support displaying drive info for NVME on that screen
Nonesense. NVMe has been supported for years.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

User avatar
smurphos
Level 12
Level 12
Posts: 4077
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Files with .drive extension.

Post by smurphos » Wed May 30, 2018 3:33 am

catweazel wrote:
Wed May 30, 2018 3:26 am
smurphos wrote:
Wed May 30, 2018 3:15 am
NVME is a fairly new standard I believe. It might just be that nemo has never being updated to support displaying drive info for NVME on that screen
Nonesense. NVMe has been supported for years.
Kernel 3.3 officially - that's fairly new in my book - 5 or 6 years I believe - and I'm not nearly as old as you are.... :wink:

Anyway reading between the lines it appears there is an upstream bug affecting both Gnome Disks and Nemo preventing either app displaying a Model name....
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
catweazel
Level 19
Level 19
Posts: 9187
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Files with .drive extension.

Post by catweazel » Wed May 30, 2018 3:35 am

smurphos wrote:
Wed May 30, 2018 3:33 am
Anyway reading between the lines it appears there is an upstream bug affecting both Gnome Disks and Nemo preventing either app displaying a Model name....
You may be right, and my suggestion to label the fs is incorrect.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

alex-n3050
Level 1
Level 1
Posts: 26
Joined: Sun Nov 22, 2015 10:54 pm

Re: Files with .drive extension.

Post by alex-n3050 » Wed May 30, 2018 4:59 am

I have not been able to establish the true cause, but in reality the device is recognized, but its model for some reason is not displayed anywhere.

> cat /sys/block/nvme0n1/device/model
Samsung SSD 960 EVO 250GB

> cat /sys/block/nvme0n1/device/serial
S3ESNX0K437588X

> udevadm info /dev/nvme0n1

P: /devices/pci0000:00/0000:00:04.0/0000:02:00.0/nvme/nvme0/nvme0n1
N: nvme0n1
S: disk/by-id/nvme-Samsung_SSD_960_EVO_250GB_S3ESNX0K437588X
S: disk/by-id/nvme-eui.0025385481b0ce8f
E: DEVLINKS=/dev/disk/by-id/nvme-eui.0025385481b0ce8f /dev/disk/by-id/nvme-Samsung_SSD_960_EVO_250GB_S3ESNX0K437588X
E: DEVNAME=/dev/nvme0n1
E: DEVPATH=/devices/pci0000:00/0000:00:04.0/0000:02:00.0/nvme/nvme0/nvme0n1
E: DEVTYPE=disk
E: ID_PART_TABLE_TYPE=dos
E: ID_PART_TABLE_UUID=0001e8bf
E: ID_SERIAL=Samsung SSD 960 EVO 250GB_S3ESNX0K437588X
E: ID_SERIAL_SHORT=S3ESNX0K437588X
E: MAJOR=259
E: MINOR=0
E: SUBSYSTEM=block
E: TAGS=:systemd:
E: USEC_INITIALIZED=2056118
E: net.ifnames=0
Last edited by alex-n3050 on Wed May 30, 2018 5:32 am, edited 2 times in total.

User avatar
catweazel
Level 19
Level 19
Posts: 9187
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Files with .drive extension.

Post by catweazel » Wed May 30, 2018 5:09 am

alex-n3050 wrote:
Wed May 30, 2018 4:59 am
I have not been able to establish the true cause, but in reality the device is recognized, but its model for some reason is not displayed anywhere.
The link posted by @smurphos explains it. Did you read it?
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

alex-n3050
Level 1
Level 1
Posts: 26
Joined: Sun Nov 22, 2015 10:54 pm

Re: Files with .drive extension.

Post by alex-n3050 » Wed May 30, 2018 5:39 am

Thank you for the information. Very useful, but I have not found a solution yet.
All the software at my disposal even with the latest updates works with this error.
I can't do anything about it.

User avatar
catweazel
Level 19
Level 19
Posts: 9187
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Files with .drive extension.

Post by catweazel » Wed May 30, 2018 5:57 am

alex-n3050 wrote:
Wed May 30, 2018 5:39 am
Thank you for the information. Very useful, but I have not found a solution yet.
There won't be a solution until and unless the bug is fixed. The best thing you can do is register your issue at the bug link. More people affected will improve the priority of a fix.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

alex-n3050
Level 1
Level 1
Posts: 26
Joined: Sun Nov 22, 2015 10:54 pm

Re: Files with .drive extension.

Post by alex-n3050 » Wed May 30, 2018 6:22 am

That's exactly what it is. I will write to the authors of the software so that the error is taken into account in the next releases and I can only wait.

Post Reply

Return to “Software & Applications”