Inserting Unicode glyphs on Mint 19 beta Not Solved

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
mhenriday
Level 3
Level 3
Posts: 151
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by mhenriday » Fri Jun 08, 2018 4:24 am

After installing Linux Mint 19 Cinnamon beta on a reserve box (I await the standardversion before upgrading from 18.3 on my main box), I've only encountered one bug ; viz, I can no longer insert Unicode characters into a text using «Ctrl + Shift + u», typing in the relevant hexadecimal code, and then depressing the space bar. On web sites, I can utilise the html code ; thus, while «Ctrl + Shift + u»», «1f609» and «Space» only produces 1f609, entering «&# 128521 ;» without the spaces produces - on some websites, but not here - a wink ( :wink: ) emoji….

Have any other users experienced this problem ? If so, have they been able to resolve it in some way ? I've posted the above as a bug to the relevant release thread, but thought it wouldn't harm to post here as well....

Henri
Last edited by mhenriday on Tue Jun 12, 2018 2:15 pm, edited 2 times in total.

User avatar
kyphi
Level 8
Level 8
Posts: 2292
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Inserting Unicode glyphs on Mint 19 beta

Post by kyphi » Sun Jun 10, 2018 5:50 pm

Holding down Ctrl+Shift followed by typing u1f609 produces 😉 when Ctrl+Shift are released. No need to press Space.
Ctrl+Shift plus u&#128521 cannot be accomplished as far as I can see since & and # require the shift key which is in use.

https://unicode.org/emoji/charts/full-emoji-list.html
Linux Mint 19 Cinnamon - 64bit

User avatar
mhenriday
Level 3
Level 3
Posts: 151
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Inserting Unicode glyphs on Mint 19 beta Solved

Post by mhenriday » Mon Jun 11, 2018 12:55 pm

kyphi wrote:
Sun Jun 10, 2018 5:50 pm
Holding down Ctrl+Shift followed by typing u1f609 produces 😉 when Ctrl+Shift are released. No need to press Space.
Ctrl+Shift plus u&#128521 cannot be accomplished as far as I can see since & and # require the shift key which is in use.

https://unicode.org/emoji/charts/full-emoji-list.html
Thanks for your reply, kyphi ! As noted above, «Ctrl + Shift + u», and then typing in the relevant hexadecimal code didn't work for me, (whether or not I depressed the space bar) ; the thing was that after entering «Ctrl + Shift + u», «u», contrary to my expectations, was not displayed and entering the hexadecimal code simple displayed the latter. But after installing«Ibus-table» and «Ibus-m17n» (in a vain attempt to get Ibus to enter Cyrillic glyphs), I found the above problem was resolved ; I now was able to enter «Ctrl + Shift + u» and then 1 f 44d (without the spaces) and upon taking «Space» get 👍. I suppose that is what is called serendipity.... :D

Henri

User avatar
mhenriday
Level 3
Level 3
Posts: 151
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by mhenriday » Tue Jun 12, 2018 2:43 pm

As noted above, «Ctrl + Shift + u», and then typing in the relevant hexadecimal code didn't work for me, (whether or not I depressed the space bar) ; the thing was that after entering «Ctrl + Shift + u», «u», contrary to my expectations, was not displayed and entering the hexadecimal code simple displayed the latter. But after installing«Ibus-table» and «Ibus-m17n» (in a vain attempt to get Ibus to enter Cyrillic glyphs), I found the above problem was resolved ; I now was able to enter «Ctrl + Shift + u» and then 1 f 44d (without the spaces) and upon taking «Space» get 👍. I suppose that is what is called serendipity.... :D

Henri
I've now had to prefix the past participle »Solved« in the subject line with the adverb »Not« - today when I tried using the procedure above to enter a Unicode glyph, I failed. At the same time I noticed that my Compose Key, which I had set to the right Win-key, no longer works ; when, for example I try to enter »š« by taking the right Win-key and then «< + s», I just get «<s» instead. I suspect these two phenomena are connected, but I don't know how ; only that both have to do with a input failure from my keyboard. Odd that these procedures worked fine just a couple of days ago and that I haven't changed any keyboard or input manager since - what can have happened ?!!...

Anybody have a clue ?...

Henri

User avatar
kyphi
Level 8
Level 8
Posts: 2292
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by kyphi » Tue Jun 12, 2018 5:32 pm

The unicode sequences for Š and š are Shift+Ctrl followed by u0160 and u0161 respectively.

Since this malfunction appeared only recently, have you tried to unplug and then reinsert the keyboard connection? Alternatively, connect the keyboard to another socket or even use another keyboard.
Check that the settings for the Compose key are still present or set another compose key. I use the Caps Lock key.

As you can see, I have not experienced any problem with unicode in Linux Mint 19 👍 nor with the Compose Key ç, ë, é, è, ê, etc.
Linux Mint 19 Cinnamon - 64bit

User avatar
mhenriday
Level 3
Level 3
Posts: 151
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by mhenriday » Wed Jun 13, 2018 5:16 am

kyphi wrote:
Tue Jun 12, 2018 5:32 pm
The unicode sequences for Š and š are Shift+Ctrl followed by u0160 and u0161 respectively.
Quite aware of these facts, kyphi, but it's much easier for me to use the Compose key and the sequence I outlined above. Alas, neither of these alternatives work, which to my mind indicates that there is a programme setting somewhere which has gone wrong....
Since this malfunction appeared only recently, have you tried to unplug and then reinsert the keyboard connection? Alternatively, connect the keyboard to another socket or even use another keyboard.
Check that the settings for the Compose key are still present or set another compose key. I use the Caps Lock key.
I unplug and re-insert the keyborad connection automatically, when switching between the computer with LM 19 beta installed and my main box, which has LM 18.3 installed and on which both the Compose Key and the procedure for inserting Unicode glyphs work fine. I've tried switching USB ports and using a different keyboard, but no joy ; none of these measures has proved of any use....
As you can see, I have not experienced any problem with unicode in Linux Mint 19 👍 nor with the Compose Key ç, ë, é, è, ê, etc.
I'm very glad to hear that, which demonstrates that the problem is not a bug in LM 19 - which, aside from the difficulties I describe here, I like very much - but rather a problem with my installation. As noted above, I can't help but think that there's some software setting which for some reason renders both the Compose Key and the Unicode procedures ineffective, but for the life of me I can't imagine what it could be - as far as I can see, the settings under Keyboard → Layout → Options on my LM 19 beta setup are precisely the same as those on my LM 18.3 setup. One alternative would, of course, be to reinstall LM 19 and see if that resolved the problem, but I'd prefer a somewhat less drastic intervention, in the event one were available....

Henri

User avatar
kyphi
Level 8
Level 8
Posts: 2292
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by kyphi » Wed Jun 13, 2018 8:18 pm

I have just used a fresh live medium with Linux Mint 19 to test Unicode functioning and it all works fine.

If you prefer to use the Compose Key to insert diacritics like the Caron then use this sequence: Compose Key - c - s

Did you verify your download of Linux Mint 19 using the usual integrity and authenticity checks?
Linux Mint 19 Cinnamon - 64bit

User avatar
mhenriday
Level 3
Level 3
Posts: 151
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by mhenriday » Thu Jun 14, 2018 3:41 pm

kyphi wrote:
Wed Jun 13, 2018 8:18 pm
I have just used a fresh live medium with Linux Mint 19 to test Unicode functioning and it all works fine.
I don't doubt that in the least - which is both encouraging and discouraging - encouraging because I thus know that the problem is not with LM 19 beta per se, discouraging because I can't expect an update will cure it.
If you prefer to use the Compose Key to insert diacritics like the Caron then use this sequence: Compose Key - c - s
The sequence «Compose Key, <, and s» works fine on my main box running LM 18.3, as can be seen here : š ; «Compose Key, c, and s» also works, but I see no reason to prefer it to the former, which I've been using for many years. The problem does not lie in the specif sequence I sue to enter the glyph, but in the fact that on my LM 19 box, the Compose Key, like the procedure for entering Unicod glyphs, doesn't work at all....

Did you verify your download of Linux Mint 19 using the usual integrity and authenticity checks?[/quote]

No, I have not yet done so, but intend to check this out tomorrow. My best guess is that there must be something wrong with the ISO file I downloaded, but it does seem odd that only these two key board functions seem to be affected - everything else works fine, at least as far as I've been able to determine hitherto. I intend first to check to see if I can get the Compose Key and the procedure for entering Unicode glyphs to work if I run LM 19 from my flash drive and then proceed to the identification and authentication procedures. Even if these latter don't exhibit any problems, I intend to perform a new download and then reinstall the OS from it - after checking to see that these two procedures work when I run LM 19 from the flash drive - as I see no other alternative. A pain, but what can one do ?...

Thank you at any rate for all your help with this matter !... 👍

Henri

User avatar
mhenriday
Level 3
Level 3
Posts: 151
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by mhenriday » Fri Jun 15, 2018 11:49 am

Prepare yourself, kyphi, for a detailed account of my throrn-strewed path. The first thing I did was to check integrity and authenticity of my ISO file, with the following result :
mhenriday@mhenriday-GA-990FXA-UD3 ~/ISO $ sha256sum -b *.iso
dd2a619f84a55084a3fcc743ceecce3c004ef22919662b09fbc08657c185608b *linuxmint-19-cinnamon-64bit-beta.iso

mhenriday@mhenriday-GA-990FXA-UD3 ~/ISO $ sha256sum --ignore-missing -c sha256sum.txt
linuxmint-19-cinnamon-64bit-beta.iso: OK

mhenriday@mhenriday-GA-990FXA-UD3 ~/ISO $ gpg --verify sha256sum.txt.gpg sha256sum.txt
gpg: Signatur gjordes fre 1 jun 2018 13:30:12 CEST med RSA nyckel-id A25BAE09
gpg: Korrekt signatur från "Linux Mint ISO Signing Key <root@linuxmint.com>"
gpg: VARNING: Denna nyckel är inte certifierad med en pålitlig signatur!
gpg: Det finns inget som indikerar att signaturen tillhör ägaren.
Primära nyckelns fingeravtryck: 27DE B156 44C6 B3CF 3BD7 D291 300F 846B A25B AE09
As far as I could see, no problems, save for that warning (varning to the effect that «This key is not certified with a valid signature» and that «There is nothing which indicate that this signature belongs to the owner» in the second and third-last lines above. Assuming that the ISO file was in fact valid, I then proceeded to start the computer in question from my flash drive (which defaults to the English-language version), made the right Win key the Compose Key and found that both it and the procedure for inserting Unicode glyphs worked precisely as they should. I then proceed to re-install the Swedish version from the flash drive, after which I again made the right Win key my Compose Key and lo and behold, both it and the Unicode-glyph procedure worked perfectly, even after rebooting the computer !...

I then installed all the pending updates, tested Compose Key and Unicode : everything hunky-dory, again even after rebooting. I then installed the European and East Asian languages I need (and removed some of the many versions of English, which I do not) rebooted and checked - everything fine. As a final measure I then installed IBus as my input method, and put it on the automatic startup list, checked again - everything in working order. BUT when I rebooted the machine just to make sure, what I feared would happen did, indeed, happen ; i e, neither the Compose Key nor the input procedure for Unicode glyphs worked any longer !...

It would seem that in some strange way - which doesn't occur on my LM 18.3 box - IBus interferes with the proper function of the Compose Key and the standard method for entering Unicode characters. At this point, I gave up, put the LM 19 beta box away, and turned to my main - LM 18.3 - computer....

So it goes.... :(

Henri

User avatar
kyphi
Level 8
Level 8
Posts: 2292
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by kyphi » Fri Jun 15, 2018 11:26 pm

Here is my detailed account, Henri:

I installed ibus-m17n including its entourage of ibus, etc. via Synaptic. Checked the functioning of Unicode as well as Compose Key sequences which all worked. Rebooted. Checked the functioning of Unicode and Compose Key sequences which again all worked. Removed ibus-m17n and ibus completely via Synaptic. Rebooted. Everything still works as intended.

Perhaps you have a reason for placing an ibus reference in your Startup Applications, I would consider that unnecessary if it is installed.
There is a possibility that removal of language files considered surplus has left a gap causing a "synapse failure".

Linux Mint 19 comes with a radical overhaul of its base which could render past practices inoperative (compared to LM 18.3).
Linux Mint 19 Cinnamon - 64bit

User avatar
mhenriday
Level 3
Level 3
Posts: 151
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by mhenriday » Sat Jun 30, 2018 7:34 am

kyphi wrote:
Fri Jun 15, 2018 11:26 pm
Here is my detailed account, Henri:

I installed ibus-m17n including its entourage of ibus, etc. via Synaptic. Checked the functioning of Unicode as well as Compose Key sequences which all worked. Rebooted. Checked the functioning of Unicode and Compose Key sequences which again all worked. Removed ibus-m17n and ibus completely via Synaptic. Rebooted. Everything still works as intended.

Perhaps you have a reason for placing an ibus reference in your Startup Applications, I would consider that unnecessary if it is installed.
There is a possibility that removal of language files considered surplus has left a gap causing a "synapse failure".

Linux Mint 19 comes with a radical overhaul of its base which could render past practices inoperative (compared to LM 18.3).
And here's mine, kyphi : I decided to give it a rest and wait until the standard LM 19 Cinnamon version, which came today, was released. I then updated the beta version, and then used the instructions found in the release notice to upgrade from the beta to the standard version. After doing this, I checked both the procedure for typing in Unicode glyphs and using the Compose Key (set, as mentioned above, to the right Win key) - both worked without the slightest problem. As you can imagine, I was ecstactic, but when I rebooted the machine, neither the one nor the other functioned.... :(

What to do ? After fiddling around with the IBus settings, I discovered that if I reset them from my standard (Swedish) setting to either SunPinyin or Anthy and then reset them again back to Swedish, I was able to enter both 👍 and š ! I've now checked this out several times and the pattern remains consistent : after a reboot (or logging out and then logging in again), I find myself unable to use the standard procedures to enter these glyphs, but I if I first «retune» IBus as per the above, the problem disappears....

I find this really weird, and don't know whether marking this thread as «Solved» would really be justified, but I can live with the workaround. When information on upgrading an LM 18.3 installation to LM 19 is released in a couple of days, I'll perform the upgrade on several other computers, and see what happens with this particular problem. Get back to you - and anyone else with an interest in this matter - then....

Thanks once again for you suggestions and interest !

Henri

rsholmes
Level 1
Level 1
Posts: 11
Joined: Sat Jun 30, 2018 8:31 am

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by rsholmes » Sat Jun 30, 2018 8:50 am

I am using Linux Mint 19 Cinnamon, updated from Beta per the instructions in yesterday's announcement.

Ibus is not installed.

Neither shift-ctrl u nor the compose key works for me:
* shift-ctrl <release> u2015 inserts "u2015"
* shift-ctrl-u <release> 2015 inserts "2015"
* compose key <release> --- inserts "---"
* compose key --- inserts "---"

What, by the way, does e.g. "3rd level of Caps Lock" mean in the Keyboard Layout Options?

User avatar
mhenriday
Level 3
Level 3
Posts: 151
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by mhenriday » Sat Jun 30, 2018 10:23 am

rsholmes wrote:
Sat Jun 30, 2018 8:50 am
I am using Linux Mint 19 Cinnamon, updated from Beta per the instructions in yesterday's announcement.

Ibus is not installed.

Neither shift-ctrl u nor the compose key works for me:
* shift-ctrl <release> u2015 inserts "u2015"
* shift-ctrl-u <release> 2015 inserts "2015"
* compose key <release> --- inserts "---"
* compose key --- inserts "---"

What, by the way, does e.g. "3rd level of Caps Lock" mean in the Keyboard Layout Options?
Let me deal with your last question first, rsholmes ; «3rd level modifiers» are the keys that allow one to access the keyboard alternatives shown on the right on certain keys ; the standard setting is «Alt Gr». Thus, for example, if I wish to type an «@» on a machine with e g, Swedish installed as the default language, I hold down «Alt Gr» and press «2»( the same result as that obtained with «Shift + 2» on a machine with English installed as the default language). On LM 18.3, which I'm using just now - the LM 19 machine has been put away for the present - I don't see anything that corresponds to «3rd level of Caps Lock», but I surmise that it would mean allowing the Caps Lock key to subsume this function. Perhaps you could check ?....

As described above, when working through the problem on LM 19 beta, I had no difficulty getting the standard procedures for inserting Unicode glyphs and using the Compose Key to function prior to installing IBus, despite restarting the machine several times, but while they worked fine directly after installing IBus, they failed after a reboot (I didn't try playing with toggling input language from a European to an East Asian language and then back again ; it might well have worked, just as it worked on standard LM 19). So my suspicion has hitherto been that the problem was in some way related to IBus and possibly to the fact that Swedish is the default language on my computers ; but as you haven't installed IBus and I surmise that your default language is not Swedish, there must be something else which is causing the problem....

Back on this matter after checking out LM 19 - both fresh installs and upgrades - on more computers.... :)

Henri

User avatar
kyphi
Level 8
Level 8
Posts: 2292
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by kyphi » Sat Jun 30, 2018 4:49 pm

rsholmes wrote:
Sat Jun 30, 2018 8:50 am
Neither shift-ctrl u nor the compose key works for me:
* shift-ctrl <release> u2015 inserts "u2015"
* shift-ctrl-u <release> 2015 inserts "2015"
* compose key <release> --- inserts "---"
* compose key --- inserts "---"
Correct technique for unicode is to hold Shift+Ctrl (do not release) type u2015, release. Result: ―
Correct technique for Compose Key is press and release the key designated as the compose key, then press diacritic required, then press the letter.
Compose key -> comma -> c = ç
Compose key -> double quotes -> o = ö
Compose key -> single quote -> e = é

No ibus installed, default language is Australian English, operating system is Linux Mint 19 and designated Compose Key is Caps Lock.
Linux Mint 19 Cinnamon - 64bit

rsholmes
Level 1
Level 1
Posts: 11
Joined: Sat Jun 30, 2018 8:31 am

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by rsholmes » Sat Jun 30, 2018 7:48 pm

kyphi wrote:
Sat Jun 30, 2018 4:49 pm
Correct technique for unicode is to hold Shift+Ctrl (do not release) type u2015, release. Result: ―
Result for me: ")!%".
Correct technique for Compose Key is press and release the key designated as the compose key, then press diacritic required, then press the letter.
Compose key -> comma -> c = ç
For me (compose key is right ctrl): result is ",c".
No ibus installed, default language is Australian English, operating system is Linux Mint 19 and designated Compose Key is Caps Lock.
Again: No ibus installed, default language is American English, operating system is Linux Mint 19 Cinnamon, and compose key is right ctrl.

User avatar
kyphi
Level 8
Level 8
Posts: 2292
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by kyphi » Sat Jun 30, 2018 10:06 pm

That is all very strange. ")!%" is not a Unicode symbol.

Here is the URL for Unicode: https://unicode-table.com/en/#control-character.

What do you get, holding down Shift+Ctrl, if you follow that with ub0 - it should produce a degree symbol °.

Regarding the Compose key, I have tried it after setting the Right Ctrl key to be the selector and it works just as it should. Would you please check in Settings, Hardware, Keyboard, Layout, Options, Position of Compose Key that the box next to the Right Ctrl has a check-mark.
Linux Mint 19 Cinnamon - 64bit

rsholmes
Level 1
Level 1
Posts: 11
Joined: Sat Jun 30, 2018 8:31 am

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by rsholmes » Sat Jun 30, 2018 11:16 pm

kyphi wrote:
Sat Jun 30, 2018 10:06 pm
That is all very strange. ")!%" is not a Unicode symbol.

Here is the URL for Unicode: https://unicode-table.com/en/#control-character.

What do you get, holding down Shift+Ctrl, if you follow that with ub0 - it should produce a degree symbol °.

Regarding the Compose key, I have tried it after setting the Right Ctrl key to be the selector and it works just as it should. Would you please check in Settings, Hardware, Keyboard, Layout, Options, Position of Compose Key that the box next to the Right Ctrl has a check-mark.
No, of course it is not a Unicode symbol. It's shift 0, shift 1, shift 5. Curiously, with shift-ctrl held down, most of the number keys give their shifted equivalents, but not 2 or 7; nothing happens with those. That is, that's the result in xed which is what I was using previously to test. In LibreOffice Writer, and here in this form in the Chromium browser, nothing at all happens if I hold shift-ctrl and enter u2015. In all three, compose comma c gives ",c".

And yes, I checked, re-checked, changed, re-changed the compose key setting before posting. It is indeed where I think it is, on the right ctrl key, and it prevents that key from acting like a ctrl key. (right ctrl-o enters an o instead of opening a file dialog.) But it doesn't act like a compose key either.

User avatar
kyphi
Level 8
Level 8
Posts: 2292
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by kyphi » Sun Jul 01, 2018 12:29 am

I have found how to reproduce ")!%"

Open System Settings, Preferences, Input Method and set it from XIM to None and then reboot.

Now try unicodes again.
Linux Mint 19 Cinnamon - 64bit

rsholmes
Level 1
Level 1
Posts: 11
Joined: Sat Jun 30, 2018 8:31 am

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by rsholmes » Sun Jul 01, 2018 12:34 am

kyphi wrote:
Sun Jul 01, 2018 12:29 am
I have found how to reproduce ")!%"

Open System Settings, Preferences, Input Method and set it from XIM to None and then reboot.

Now try unicodes again.
Nope, it's already set to "none".

User avatar
mhenriday
Level 3
Level 3
Posts: 151
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Inserting Unicode glyphs on Mint 19 beta Not Solved

Post by mhenriday » Sun Jul 01, 2018 7:26 am

Firstly, the Unicode hexadecimal code for the degree symbol ° is «00b0», effectuated by typing «Ctrl + Shift + u» and then entering the code and taking Return....

But let me return to my own experience : yesterday I downloaded the 32-bit ISO file for LM 19 to my main (64-bit LM 18.3) box, used UNetbootin to transfer it to a bootable flash drive, from which I installed (the Swedish version of) the OS on an old Samsung R530 laptop, on which I then proceeded to open two accounts. Testing for Unicode and Compose Key all the way, with frequent reboots and logging out and in, I found that on both accounts, the procedure for entering Unicode glyphs and that for using the Compose Key (which I had defined as right Control, as the keyboard lacks a right Win key) gave me the results I desired. Thereafter, I installed IBus, IBus Anthy, and IBus SunPinyin and activated both in the IME ; as before, both the procedure for entering Unicode glyphs and that for using the Compose Key worked fine. I did, however, notice a difference : on one account, on which IBus is configured to start automatically, when I perform «Ctrl + Shift + u», u appears on the screen and when I then type in, e g, «5000», u5000 is displayed. If I then take Return, I see 倀. I get exactly the same thing when running IBus via entering «ibus-daemon» in a terminal on the other account, but if I don't run IBus there, nothing is displayed when I enter «Ctrl + Shit + u» and then enter «5000», but 倀 still appears when I take Return, i e, precisely what I see on my 64-bit 18.3 main box, on which I am now typing, even though IBus launches automatically here. Weird, but not a problem....

Back again, when I've had the opportunity to install the 64-bit version of LM 19 from a flash drive onto another old box I have lying around and to test the procedures for entering Unicode glyphs and using the Compose Key there....

Henri

Post Reply

Return to “Software & Applications”