Nemo very slow to open

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
mxminty1
Level 1
Level 1
Posts: 4
Joined: Sat Dec 23, 2017 4:49 pm

Nemo very slow to open

Post by mxminty1 » Sun Jun 17, 2018 2:38 pm

The issue has been happening for months, but it is sporadic. Usually things work fine but sometimes clicking the Nemo icon does not open the file browser until about 5 minutes later. While waiting I tried launching from terminal and got a "Could not register nemo as a remote: Timeout was reached" error. Once Nemo gets running opening new windows is fine. Sometimes it happens early on in a session, sometimes after everything is up and running for awhile. If I don't want to wait I need a full reboot to get a working file manager. Recommendations on how to troubleshoot this?

Running Mint 18.3 64-bit on 4.4 kernel. Also using a PPA (obaif) for optimized radeon drivers but have not encountred problems with any other application being so slow to launch.

Thanks.

User avatar
all41
Level 13
Level 13
Posts: 4987
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Nemo very slow to open

Post by all41 » Sun Jun 17, 2018 8:36 pm

When this happens look at your System Monitor/Processes to see what is running and what is using
the most cpu. You could also open a terminal and enter top

Do you have an external hard drive connected when this happens?

When it hangs try log-out by Ctrl+Alt+Backspace and log back in to see if it hangs
again on a fresh login. You can also terminate the hanging process by terminal killall nemo

If you suspect problems with a ppa go to Software Sources/PPA and temporarily disable them.
Proud to be a supporter and monthly contributor to Mint.

lmuserx4849

Re: Nemo very slow to open

Post by lmuserx4849 » Mon Jun 18, 2018 4:04 am

> Nemo hangs

If starting a console times-out during this period, try a virtual terminal, ctrl-alt-f1, login, then to get back to your graphical session, ctrl-alt-f7.

Check log: tail -n20 -f /var/log/syslog - watch for awhile (ctrl-c to exit)

I agree on using top or htop. htop is a little easier to use. It uses colors & there is a help menu at the bottom. In KDE, I can also hit ctrl-esc and a gui system activity monitor runs. Or issue the command to see the top 5 by %cpu: ps axu --sort=-%cpu |head -n5.

I would also do the killall nemo rather than rebooting. I suspect it's a hard boot too, which increases the chances of file system errors.

Last time KDE's Dolphin hanged, my drive was failing. The system log showed the errors & smartctl confirmed.

BUT take a look at - System-hang when browsing unconnected network share, or a more general search under Issues - https://github.com/linuxmint/nemo/issue ... Aopen+hang.

Doing a google site search for nemo hangs - Nemo hangs when Windows 7 PC share goes away [SOLVED]

mxminty1
Level 1
Level 1
Posts: 4
Joined: Sat Dec 23, 2017 4:49 pm

Re: Nemo very slow to open

Post by mxminty1 » Thu Jun 21, 2018 11:25 pm

Thanks for the tips. I will try them out next time I see the problem. Of course past few days things are back to running great.

mxminty1
Level 1
Level 1
Posts: 4
Joined: Sat Dec 23, 2017 4:49 pm

Re: Nemo very slow to open

Post by mxminty1 » Sun Jul 08, 2018 2:20 pm

Issue showed up again so I followed some of the listed suggestions.

Running top showed cinnamon being the major cpu user but only a few %. However I did see a [mount.ntfs] command pop up on the list once in awhile then drop away. Opened another terminal and ran killall nemo, then tried running nemo from the command line. Nothing, and the [mount.ntfs] still popping up under top. I ran pstree to see where this command was coming from, and it showed up right under systemd as 2*[mount.ntfs]. That makes sense as I have a second hdd with two ntfs partitions. Nemo eventually opened and the [mount.ntfs] stopped showing up in top.

I will try running smartctl on the disk to see if there are any errors. The other options might be to not auto-mount the NTFS partitions.

Post Reply

Return to “Software & Applications”