upgrading software ,lost my way. <SOLVED>

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
charvey
Level 1
Level 1
Posts: 38
Joined: Mon Jun 05, 2017 1:05 pm

upgrading software ,lost my way. <SOLVED>

Post by charvey »

ok..most things go smooth but this time i dont understand why i cant do an upgrade from the command line.
I want to install this program https://github.com/juancarlospaco/pyvoi ... icechanger

my version of sox is fine, i need to upgrade python and PyQt...so i did this :

chris@chris-p6674y ~ $ sudo apt-get install sox python3-pyqt5
[sudo] password for chris:
Reading package lists... Done
Building dependency tree
Reading state information... Done
python3-pyqt5 is already the newest version (5.5.1+dfsg-3ubuntu4).
python3-pyqt5 set to manually installed.
sox is already the newest version (14.4.1-5).
The following package was automatically installed and is no longer required:
ocl-icd-libopencl1:i386
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 26 not upgraded.

now...if i do $ python --version
Python 2.7.12
This is not the newest version, but it did not update. am i reading it right? i need python 3.x.x yes? and thats a seperate update from the python3-pyqu5?
it seems i learn daily with linux lol. someone steer me in the right direction here ?
charvey
Last edited by charvey on Thu Jun 28, 2018 10:54 am, edited 1 time in total.

User avatar
thx-1138
Level 8
Level 8
Posts: 2041
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: upgrading software ,lost my way.

Post by thx-1138 »

...Mint 18 comes with both Python 2.7.12 & 3.5.2. That software requires Python 3.6+, so it won't run.
Removing and / or 'upgrading' any of those pre-installed Python versions will most likely break your desktop (you've been warned...) :)

Mint 19 comes with Python 3.6.5 i believe, so that would be your best bet...

User avatar
thx-1138
Level 8
Level 8
Posts: 2041
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: upgrading software ,lost my way.

Post by thx-1138 »

charvey wrote:
Thu Jun 28, 2018 10:37 am
............
...you might wanna give a try at the older non-forked version of the app in question:
https://github.com/capturePointer/pyvoicechanger
In it's requirements, i only see Python 3.5 - so you might have better luck with it...

Post Reply

Return to “Software & Applications”