Old Amarok on Gloria.

Questions about applications and software
Forum rules
Before you post please read how to get help
sledz
Level 1
Level 1
Posts: 2
Joined: Sun Jun 07, 2009 10:04 am

Old Amarok on Gloria.

Postby sledz » Sun Jun 07, 2009 10:26 am

Is there any way to install Amarok 1 on Mint 7?
I'm trying repos and Amarok's site, but I can't find it anywhere.

User avatar
Zwopper
Level 10
Level 10
Posts: 3077
Joined: Fri Nov 30, 2007 12:20 pm
Location: Deep in the Swedish woods

Re: Old Amarok on Gloria.

Postby Zwopper » Sun Jun 07, 2009 11:13 am

sledz wrote:Is there any way to install Amarok 1 on Mint 7?
I'm trying repos and Amarok's site, but I can't find it anywhere.

Try this!
Image
My artwork at deviantART | My Band - Electric Alchemea
CREA DIEM!

Toshiba Portégé R930 | i7 | 16GB | 128GB - SSD | Ubuntu 15.04

kei84
Level 3
Level 3
Posts: 184
Joined: Tue Apr 14, 2009 8:54 pm
Location: Brazil

Re: Old Amarok on Gloria.

Postby kei84 » Mon Jun 08, 2009 12:37 pm

I have Amarok 1.4 installed in Gloria.
To install it just add these repositories in Synaptic.

deb http://ppa.launchpad.net/bogdanb/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/bogdanb/ppa/ubuntu jaunty main

To register the PPA key type this in your terminal.
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0x1d7e9dd033e89ba781e32a24b9f1c432ae74ae63

The click Refresh and you`ll see Amarok 1.4 in the list. Then just check it to install.

PS: Don`t forget to remove Amarok2 before installing Amarok 1.4

andrassyut
Level 1
Level 1
Posts: 14
Joined: Sun Mar 29, 2009 5:35 am
Location: Beograd
Contact:

Re: Old Amarok on Gloria.

Postby andrassyut » Wed Jun 10, 2009 7:26 am

kei84 wrote:I have Amarok 1.4 installed in Gloria.
To install it just add these repositories in Synaptic.

deb http://ppa.launchpad.net/bogdanb/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/bogdanb/ppa/ubuntu jaunty main

To register the PPA key type this in your terminal.
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0x1d7e9dd033e89ba781e32a24b9f1c432ae74ae63

The click Refresh and you`ll see Amarok 1.4 in the list. Then just check it to install.

PS: Don`t forget to remove Amarok2 before installing Amarok 1.4


hi :)
when I try to add that repos, I get the following message:

Could not download all repository indexes

The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.


but before that I was installing and downloading something through synaptic..so I guess it is not the network problem

I get to see Amarok 1.4 in list, but when I want to install, it says error:

Code: Select all

These packages have unresolvable dependencies...
amarok14:
 Depends: amarok14-common but it is not going to be installed
 Depends: amarok14-engine-xine but it is not going to be installed



edit: I forgot:

Code: Select all

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0x1d7e9dd033e89ba781e32a24b9f1c432ae74ae63

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --recv-keys --keyserver keyserver.ubuntu.com 0x1d7e9dd033e89ba781e32a24b9f1c432ae74ae63
gpg: requesting key AE74AE63 from hkp server keyserver.ubuntu.com
gpg: key AE74AE63: "Launchpad PPA for Bogdan Butnaru" not changed
gpg: Total number processed: 1
gpg: unchanged: 1

User avatar
grimdestripador
Level 6
Level 6
Posts: 1057
Joined: Fri Feb 16, 2007 2:26 am

Re: Old Amarok on Gloria.

Postby grimdestripador » Wed Jun 10, 2009 2:59 pm

not working for me. I added the repos, placing them at the top of my list. Clicking update. no amarok14

andrassyut
Level 1
Level 1
Posts: 14
Joined: Sun Mar 29, 2009 5:35 am
Location: Beograd
Contact:

Re: Old Amarok on Gloria.

Postby andrassyut » Wed Jun 10, 2009 5:38 pm

I wrote mail to Mr. Bogdan Butnaru who made those packages, and he told me, that he is working to fix the problem. It will probably be soon :) if any news, I will let you know ;)

kei84
Level 3
Level 3
Posts: 184
Joined: Tue Apr 14, 2009 8:54 pm
Location: Brazil

Re: Old Amarok on Gloria.

Postby kei84 » Wed Jun 10, 2009 6:54 pm

Yes, there is a problem with bogdan.

While they are fixing it, you can download the deb file for Amarok 1.4 from http://packages.debian.org/sid/amarok

PS: download amarok (1.4.10-3), amarok-common (1.4.10-3), amarok-engine-xine (1.4.10-3+b1), amarok-engine-yauap (1.4.10-3+b1) and problably libmtp8 (0.3.1)

andrassyut
Level 1
Level 1
Posts: 14
Joined: Sun Mar 29, 2009 5:35 am
Location: Beograd
Contact:

Re: Old Amarok on Gloria.

Postby andrassyut » Fri Jun 12, 2009 2:41 pm

edit of edit:

it works, finally! but there were some errors while installing, is it something "big"?

Code: Select all

dpkg: error processing /var/cache/apt/archives/amarok14-common_2%3a1.4.10-0ubuntu3~ppa4_all.deb (--unpack):
 trying to overwrite `/etc/kde3/amarokrc', which is also in package amarok-common-kde3
Selecting previously deselected package amarok14-engine-xine.
Unpacking amarok14-engine-xine (from .../amarok14-engine-xine_2%3a1.4.10-0ubuntu3~ppa4_i386.deb) ...
Selecting previously deselected package amarok14.
Unpacking amarok14 (from .../amarok14_2%3a1.4.10-0ubuntu3~ppa4_i386.deb) ...
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/amarok14-common_2%3a1.4.10-0ubuntu3~ppa4_all.deb

sledz
Level 1
Level 1
Posts: 2
Joined: Sun Jun 07, 2009 10:04 am

Re: Old Amarok on Gloria.

Postby sledz » Sat Jun 13, 2009 6:44 am

kei84 wrote:Yes, there is a problem with bogdan.

While they are fixing it, you can download the deb file for Amarok 1.4 from http://packages.debian.org/sid/amarok

PS: download amarok (1.4.10-3), amarok-common (1.4.10-3), amarok-engine-xine (1.4.10-3+b1), amarok-engine-yauap (1.4.10-3+b1) and problably libmtp8 (0.3.1)
It worked, thanks.

Can I mark in Synaptic or somewhere else that I don't want to upgrade Amarok to version 2?

emorrp1
Level 8
Level 8
Posts: 2281
Joined: Thu Feb 26, 2009 8:58 pm

Re: Old Amarok on Gloria.

Postby emorrp1 » Sat Jun 13, 2009 7:00 am

sledz wrote:Can I mark in Synaptic or somewhere else that I don't want to upgrade Amarok to version 2?

Package --> Lock Version will stop it being automatically upgraded. Alternatively you could add a rule to /etc/apt/preferences for the ppa, so it overrides any upstream updates (e.g. v2) but lets you keep updating v1 from the repo.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com


Return to “Software & Applications”

Who is online

Users browsing this forum: Mintmag, Pierre and 4 guests