[SOLVED] LM19 software update error with GRUB-COMMON. How dangerous is this error?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
carum carvi
Level 6
Level 6
Posts: 1029
Joined: Sun Apr 16, 2017 11:44 pm

[SOLVED] LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by carum carvi » Mon Jul 09, 2018 4:41 pm

I am newbie and dutch speaking language is native language. I got an error message during the latest software update of GRUB-COMMON. I need help what to do. Below is my translation of the error message in dutch original language, sorry for possible translation mistakes...


Not all updates have succeeded:
Warning: adjusting GRUB TIMEOUT not equal to zero while GRUB HIDDEN TIMEOUT is set, will no longer be supported
Dpkg: error with managing packet ubuntu-system-adjustments (--configure): installed ubuntu-system-adjustments packet post installation script subproces reported an error shutdownstatus1






Below is the full error message in dutch language.



Waarschuwing: Het instellen van GRUB_TIMEOUT ongelijk aan nul terwijl GRUB_HIDDEN_TIMEOUT ingesteld is, wordt niet langer ondersteund.

Bezig met afhandelen van triggers voor ubuntu-system-adjustments (2018.06.07) ...
postinst called with unknown argument `triggered'
dpkg: fout bij verwerken van pakket ubuntu-system-adjustments (--configure):
geïnstalleerd ubuntu-system-adjustments pakket post-installation script subproces meldde een fout afsluitstatus 1
Bezig met afhandelen van triggers voor ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot

update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults



Voorconfigureren van pakketten ...
(Database wordt ingelezen ... 312991 bestanden en mappen momenteel geïnstalleerd.)
Uitpakken van .../libjpeg-turbo8_1.5.2-0ubuntu5.18.04.1_amd64.deb wordt voorbereid...
Bezig met uitpakken van libjpeg-turbo8:amd64 (1.5.2-0ubuntu5.18.04.1) over (1.5.2-0ubuntu5) ...
Instellen van libjpeg-turbo8:amd64 (1.5.2-0ubuntu5.18.04.1) ...
(Database wordt ingelezen ... 312991 bestanden en mappen momenteel geïnstalleerd.)
Uitpakken van .../grub-pc_2.02-2ubuntu8.1_amd64.deb wordt voorbereid...
Bezig met uitpakken van grub-pc (2.02-2ubuntu8.1) over (2.02-2ubuntu8) ...
Uitpakken van .../grub-pc-bin_2.02-2ubuntu8.1_amd64.deb wordt voorbereid...
Bezig met uitpakken van grub-pc-bin (2.02-2ubuntu8.1) over (2.02-2ubuntu8) ...
Uitpakken van .../grub2-common_2.02-2ubuntu8.1_amd64.deb wordt voorbereid...
Bezig met uitpakken van grub2-common (2.02-2ubuntu8.1) over (2.02-2ubuntu8) ...
Uitpakken van .../grub-common_2.02-2ubuntu8.1_amd64.deb wordt voorbereid...
Bezig met uitpakken van grub-common (2.02-2ubuntu8.1) over (2.02-2ubuntu8) ...
Uitpakken van .../libjpeg-turbo-progs_1.5.2-0ubuntu5.18.04.1_amd64.deb wordt voorbereid...
Bezig met uitpakken van libjpeg-turbo-progs (1.5.2-0ubuntu5.18.04.1) over (1.5.2-0ubuntu5) ...
Instellen van libjpeg-turbo-progs (1.5.2-0ubuntu5.18.04.1) ...
Bezig met afhandelen van triggers voor ubuntu-system-adjustments (2018.06.07) ...
postinst called with unknown argument `triggered'
dpkg: fout bij verwerken van pakket ubuntu-system-adjustments (--configure):
geïnstalleerd ubuntu-system-adjustments pakket post-installation script subproces meldde een fout afsluitstatus 1
Bezig met afhandelen van triggers voor ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
Bezig met afhandelen van triggers voor install-info (6.5.0.dfsg.1-2) ...
Bezig met afhandelen van triggers voor libc-bin (2.27-3ubuntu1) ...
Instellen van grub-common (2.02-2ubuntu8.1) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Bezig met afhandelen van triggers voor systemd (237-3ubuntu10) ...
Bezig met afhandelen van triggers voor man-db (2.8.3-2) ...
Instellen van grub-pc-bin (2.02-2ubuntu8.1) ...
Instellen van grub2-common (2.02-2ubuntu8.1) ...
Instellen van grub-pc (2.02-2ubuntu8.1) ...
Installeren voor i386-pc-platform.
Installatie is afgerond. Er werden geen fouten gerapporteerd.
Aanmaken van GRUB-configuratiebestand...
Waarschuwing: Het instellen van GRUB_TIMEOUT ongelijk aan nul terwijl GRUB_HIDDEN_TIMEOUT ingesteld is, wordt niet langer ondersteund.
Linux-schijfkopie gevonden: /boot/vmlinuz-4.15.0-24-generic
Initrd-schijfkopie gevonden: /boot/initrd.img-4.15.0-24-generic
Linux-schijfkopie gevonden: /boot/vmlinuz-4.15.0-23-generic
Initrd-schijfkopie gevonden: /boot/initrd.img-4.15.0-23-generic
Linux-schijfkopie gevonden: /boot/vmlinuz-4.15.0-20-generic
Initrd-schijfkopie gevonden: /boot/initrd.img-4.15.0-20-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
voltooid
Fouten gevonden tijdens verwerken van:
ubuntu-system-adjustments
E: Sub-process /usr/bin/dpkg returned an error code (1)
Een pakket kon niet geïnstalleerd worden. Aan het proberen om te herstellen:
Instellen van ubuntu-system-adjustments (2018.06.07) ...
Reloading systemd
Removed /etc/systemd/system/multi-user.target.wants/hddtemp.service.
Created symlink /etc/systemd/system/multi-user.target.wants/hddtemp.service → /etc/systemd/system/hddtemp.service.
Last edited by carum carvi on Tue Jul 10, 2018 10:13 am, edited 1 time in total.

srpohl
Level 1
Level 1
Posts: 7
Joined: Wed Nov 29, 2017 10:12 pm

Re: LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by srpohl » Mon Jul 09, 2018 4:52 pm

Same here on 3 different laptops (different brands). A few very obvious things should have been better. I want to keep using LM 19, but IMO the official release should have still been "beta". I know there will be bugs in a x.0 release, but GRUB!! Who QA's this?

carum carvi
Level 6
Level 6
Posts: 1029
Joined: Sun Apr 16, 2017 11:44 pm

Re: LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by carum carvi » Mon Jul 09, 2018 5:40 pm

I restored everything with Timeshift. First time I had to use it and it worked splendidly although it is rather daunting for newbies because there are so many options.

Afterwards I immediately removed all level 4 software updates. Better safe than sorry, with a new release. I love LM19 Tara though. Really pleased with it. Everything works better in it than in LM18. Although the level 4 software updates are to be avoided for newbies like me...

KBD47
Level 7
Level 7
Posts: 1809
Joined: Fri Jul 29, 2011 12:03 am

Re: LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by KBD47 » Mon Jul 09, 2018 7:55 pm

newbie serena wrote:
Mon Jul 09, 2018 5:40 pm

Afterwards I immediately removed all level 4 software updates. Better safe than sorry, with a new release. I love LM19 Tara though. Really pleased with it. Everything works better in it than in LM18. Although the level 4 software updates are to be avoided for newbies like me...
I wish Mint had kept its old default update policy like with Mint 18. I can't count the level 4 updates that have borked people's systems in the past few days. At the least, it should be explained to newbies that skipping these updates are a viable option for a more stable system.

hydrurga
Level 2
Level 2
Posts: 57
Joined: Sun Nov 15, 2015 4:08 pm

Re: LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by hydrurga » Mon Jul 09, 2018 7:59 pm

Please see my post here for a solution:

viewtopic.php?f=90&t=272870#p1492991

User avatar
Snafu
Level 2
Level 2
Posts: 66
Joined: Tue Mar 13, 2018 7:01 am
Location: Australia

Re: LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by Snafu » Mon Jul 09, 2018 8:00 pm

Same result from that update here. Thankfully it was only a "dummy package", god knows what might have happened if it was a real one :lol:
When all else fails follow the instructions

srpohl
Level 1
Level 1
Posts: 7
Joined: Wed Nov 29, 2017 10:12 pm

Re: LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by srpohl » Mon Jul 09, 2018 9:10 pm

hydrurga - Thanks for the work-around. I expect Mint to get a fix out very ASAP. Nothing like the word getting out that GRUB is broken. So much for "stable".

User avatar
smurphos
Level 13
Level 13
Posts: 4826
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by smurphos » Tue Jul 10, 2018 12:42 am

There appears to be an issue with some of the Tara mirrors being out of date - change to the default http://packages.linuxint.com pushes an update to ubuntu-system-adjustments which avoids the ubuntu-system-adjustments install error. I guess the other mirrors will catch up in due course.

The Grub 'error' is completely inconsequential, it's just warning that some features of the mint /etc/default/grub won't be supported in some future version of Grub. The same warning was present on every Grub update in 18.x aswell.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

hydrurga
Level 2
Level 2
Posts: 57
Joined: Sun Nov 15, 2015 4:08 pm

Re: LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by hydrurga » Tue Jul 10, 2018 4:14 am

srpohl wrote:
Mon Jul 09, 2018 9:10 pm
hydrurga - Thanks for the work-around. I expect Mint to get a fix out very ASAP. Nothing like the word getting out that GRUB is broken. So much for "stable".
My pleasure. The problem was with the triggered ubuntu-system-adjustments rather than grub itself, and the issuing of v. 2018.07.09 by Mint resolves the problem. The final line in my solution, to reinstall grub-common, probably wasn't necessary but if the installation of a package emits any sort of failure message at all then I like to be sure by resolving the issue and installing it again to ensure it doesn't the second time.

carum carvi
Level 6
Level 6
Posts: 1029
Joined: Sun Apr 16, 2017 11:44 pm

Re: LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by carum carvi » Tue Jul 10, 2018 10:06 am

KBD47 I agree with your comment:

" I wish Mint had kept its old default update policy like with Mint 18. I can't count the level 4 updates that have borked people's systems in the past few days. At the least, it should be explained to newbies that skipping these updates are a viable option for a more stable system."

I re installed LM19 and to my surprise level 4 software updates were included as standard. The window showing the software updates after a fresh new LM19 install was just a tiny bit too short in length, therefore I couldnt even see the option to deselect accepting system kernels. I had to manually lengthen the software update screen in order to be able to see the option to not select system kernels as standard.

I am glad though to read that the GRUB COMMON update error wasnt dangerous at all. I over reacted a bit, because the only thing I knew was that Grub had to do with the booting of Linuxmint. But thankfully it is a rather innocent update error.

KBD47
Level 7
Level 7
Posts: 1809
Joined: Fri Jul 29, 2011 12:03 am

Re: LM19 software update error with GRUB-COMMON. How dangerous is this error?

Post by KBD47 » Tue Jul 10, 2018 12:15 pm

newbie serena wrote:
Tue Jul 10, 2018 10:06 am
KBD47 I agree with your comment:

" I wish Mint had kept its old default update policy like with Mint 18. I can't count the level 4 updates that have borked people's systems in the past few days. At the least, it should be explained to newbies that skipping these updates are a viable option for a more stable system."

I re installed LM19 and to my surprise level 4 software updates were included as standard. The window showing the software updates after a fresh new LM19 install was just a tiny bit too short in length, therefore I couldnt even see the option to deselect accepting system kernels. I had to manually lengthen the software update screen in order to be able to see the option to not select system kernels as standard.

I am glad though to read that the GRUB COMMON update error wasnt dangerous at all. I over reacted a bit, because the only thing I knew was that Grub had to do with the booting of Linuxmint. But thankfully it is a rather innocent update error.
Grub issues are scary because not being able to boot your system is almost as bad as it gets. If you can at least boot your system you can fix things, though grub can be reinstalled from a live version of Linux.
I actually ended up with the problem kernel because I initially misunderstood and only removed the level four updates, without disabling them on the options page as well on update manager, so it is a bit more tricky to disable these updates than in version 18 Mint. I removed the problem kernel from two of my machines after the fact as I saw a similar laptop to mine did get wrecked by that kernel and I didn't want to take any chances.

Post Reply

Return to “Software & Applications”