MEGASync Client in Mint Mate 19

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
zcacogp
Level 1
Level 1
Posts: 34
Joined: Thu Nov 08, 2012 1:59 pm
Location: London, England

MEGASync Client in Mint Mate 19

Post by zcacogp » Tue Jul 10, 2018 10:30 am

Hi,

I've just done a clean build of Mint MATE 19, and am trying to install the MEGASync client. I've downloaded the 18.04 version from the MEGA website.

It appears to install OK and I can (apparently) login to my MEGA account but when it comes to selecting what I want sync'd it throws the error report at the end of this message (it's quite long). Given that it claims to be a Segmentation Fault I am slightly at a loss as to what to do, and am assuming that it is a fault within the software in question. Having googled the problem I find that there is someone else who has posted similarly on this forum here but it sounds like the problem there is different.

viewtopic.php?f=47&t=272152&p=1488222&h ... a#p1488222

I've sent an error report and support request to the MEGA software developers but was wondering whether there are any other suggestions.

Thanks for your help.


Oli.

Error Report is as follows;

MEGAprivate ERROR DUMP
Application: MEGAsync
Version code: 3606.0
Module name: megasync
Operating system: Linux
System version: linuxmint 19/#26-Ubuntu SMP Wed Jun 13 08:44:47 UTC 2018
System release: 4.15.0-24-generic
System arch: x86_64
Error info:
Segmentation fault (11) at address 0x7f1cb510f260
Stacktrace:
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x2e685c) [0x7f1c9eac485c]
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x2e685c) [0x7f1c9eac485c]
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x3715bd) [0x7f1c9eb4f5bd]
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(_ZN11QMessageBoxC1ENS_4IconERK7QStringS3_6QFlagsINS_14StandardButtonEEP7QWidgetS4_IN2Qt10WindowTypeEE+0x1fd) [0x7f1c9eb5108d]
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x37328e) [0x7f1c9eb5128e]
megasync(+0xad4f8) [0x558978ca74f8]
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5(_ZN7QObject5eventEP6QEvent+0x9b) [0x7f1c9d5ce0db]
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x9c) [0x7f1c9e93282c]
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x2a4) [0x7f1c9e93a0f4]
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5(_ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent+0x118) [0x7f1c9d59e9a8]
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5(_ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData+0x1ed) [0x7f1c9d5a111d]
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5(+0x2e42c3) [0x7f1c9d5f82c3]
/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x2e7) [0x7f1c9a222287]
/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x4c4c0) [0x7f1c9a2224c0]
/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7f1c9a22254c]
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x5f) [0x7f1c9d5f78ef]
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0x13a) [0x7f1c9d59c9ea]
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5(_ZN16QCoreApplication4execEv+0x94) [0x7f1c9d5a5a84]
megasync(+0x788e7) [0x558978c728e7]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7f1c9c3e1b97]
megasync(+0x792fa) [0x558978c732fa]

zcacogp
Level 1
Level 1
Posts: 34
Joined: Thu Nov 08, 2012 1:59 pm
Location: London, England

Re: [SOLVED] MEGASync Client in Mint Mate 19

Post by zcacogp » Tue Jul 17, 2018 11:12 am

For reference, this problem has now been solved by the Support team at MEGA. It sounds like there was a problem in their installer and they sent me another one which solved things.

Many thanks for the help from the MEGA support team - they were patient and friendly and genuinely very helpful. If any of them should ever read this then Thank You Very Much!

Post Reply

Return to “Software & Applications”