Applications not using Theme in Linux Mint 19

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
STonEDSTonE
Level 1
Level 1
Posts: 6
Joined: Wed Jul 11, 2018 5:18 pm

Applications not using Theme in Linux Mint 19

Post by STonEDSTonE »

Hi,

I switched from Linux Mint 18.3 to 19, and noticed an odd behaviour:
I like the dark theme a lot since it is easier on the eyes. On LM 18.3 every application i used used whatever theme was selected by the OS.
working.jpg
Under 19, some applications don't use any theme, not even the standard theme from LM.
nextcloud.jpg
As of now this is true for nextcloud-client, virtualbox and audacity.
VirtualBox.jpg
VirtualBox.jpg
But there may be more.
Can someone explain why this happens? It is a clean 64-Bit install with Cinnamon DE in both cases …

greetings

STonE

fromWinToLin
Level 2
Level 2
Posts: 78
Joined: Thu Nov 19, 2009 11:53 am

Re: Applications not using Theme in Linux Mint 19

Post by fromWinToLin »

Try this. It works for most Qt applications, such as VLC.

Install the following if they are not already installed:

sudo apt install qt5ct qt4-qtconfig

Run from the terminal the application Qt5 Configuration Tool.

qt5ct

Under Appearance > Style, select "gtk2". You can also make sure to use the correct icon theme, such as Mint-Y, under the Icon Theme tab.

Click Apply, then click Okay.

Run from the terminal the application Qt4 Configuration Tool.

qtconfig-qt4

Under Appearance > GUI Style, select "GTK+".

Go to File > Save, then File > Exit.

Now restart your applications. You might have to logout then login again.

STonEDSTonE
Level 1
Level 1
Posts: 6
Joined: Wed Jul 11, 2018 5:18 pm

Re: Applications not using Theme in Linux Mint 19

Post by STonEDSTonE »

Thanks, that already helps a bit, nextcloud-client and virtualbox now work as intended.
Why isn't this a standard setting?

Audacity still doesn't use it like it should though, and anydesk does not either.
audacity.jpg
Anydesk.jpg
Do you have more suggestions?

User avatar
smurphos
Level 15
Level 15
Posts: 5566
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Applications not using Theme in Linux Mint 19

Post by smurphos »

Any of them Flatpaks? I think Flatpak in Mint 19 can only support Mint-Y themes...
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

STonEDSTonE
Level 1
Level 1
Posts: 6
Joined: Wed Jul 11, 2018 5:18 pm

Re: Applications not using Theme in Linux Mint 19

Post by STonEDSTonE »

nope, both are normal packages.
audacity is installed directly via apt install and anydesk is a .deb file downloaded from the homepage (installs some additional packages via apt though).

User avatar
smurphos
Level 15
Level 15
Posts: 5566
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Applications not using Theme in Linux Mint 19

Post by smurphos »

For Audacity - looks like the newer versions of Audacity by design only partly follows system themes and have a built in theme engine.

See https://manual.audacityteam.org/man/themes.html

Anydesk appears to be using an HTML based interface for it's main window - it's pretty poorly done and looks awful with any darkish theme as the background doesn't respect the theme background colours but the foreground text does (and is thus pretty much unreadable). Can't find any obvious way to change that.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

STonEDSTonE
Level 1
Level 1
Posts: 6
Joined: Wed Jul 11, 2018 5:18 pm

Re: Applications not using Theme in Linux Mint 19

Post by STonEDSTonE »

thanks for the link, audacity now fits in rather well with the dark theme.
since anydesk is a separate program, i have to ask there i guess.

gibbs1984
Level 5
Level 5
Posts: 798
Joined: Mon Oct 27, 2008 2:40 pm
Location: Hemel Hempstead, England

Re: Applications not using Theme in Linux Mint 19

Post by gibbs1984 »

Thanks for this, solved my issue.

I'd like to expand on it a bit too though, I've also changed the Fonts to be the same as I use for other applications:

Run from the terminal the application Qt4 Configuration Tool:

Code: Select all

qtconfig-qt4
Then go to the Fonts tab and click on the 3 little dots next to General and Fixed and change both of them to Noto Sans, Regular, 9.

This way the menus aren't massive and look exactly the same as every other application.

Image
Linux Mint 19.0 (Cinnamon) 64bit.

fromWinToLin
Level 2
Level 2
Posts: 78
Joined: Thu Nov 19, 2009 11:53 am

Re: Applications not using Theme in Linux Mint 19

Post by fromWinToLin »

The same can be done (matching fonts) with qt5ct. Newer Qt applications will use the Qt5 toolkit, while older applications might still use Qt4.

gibbs1984
Level 5
Level 5
Posts: 798
Joined: Mon Oct 27, 2008 2:40 pm
Location: Hemel Hempstead, England

Re: Applications not using Theme in Linux Mint 19

Post by gibbs1984 »

Sorry, I meant qt5ct, that's actually a screenshot of the qt5ct configuration tool.
Linux Mint 19.0 (Cinnamon) 64bit.

User avatar
overkill22
Level 4
Level 4
Posts: 402
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Applications not using Theme in Linux Mint 19

Post by overkill22 »

I still have this problem with few applications, for example KeepassXC is light theme while I set all to be dark theme.
I have a fresh install Mint 19 Cinnamon.
Theme set to Mint Y, dark.

User avatar
smurphos
Level 15
Level 15
Posts: 5566
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Applications not using Theme in Linux Mint 19

Post by smurphos »

overkill22 wrote:
Mon Oct 01, 2018 2:39 am
, for example KeepassXC is light theme while I set all to be dark theme.
I have a fresh install Mint 19 Cinnamon.
Theme set to Mint Y, dark.
Flatpak perchance? The PPA or repo version should honour the system theme.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
overkill22
Level 4
Level 4
Posts: 402
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Applications not using Theme in Linux Mint 19

Post by overkill22 »

smurphos wrote:
Mon Oct 01, 2018 4:26 am
overkill22 wrote:
Mon Oct 01, 2018 2:39 am
, for example KeepassXC is light theme while I set all to be dark theme.
I have a fresh install Mint 19 Cinnamon.
Theme set to Mint Y, dark.
Flatpak perchance? The PPA or repo version should honour the system theme.
I'm not sure I understood what you mean

User avatar
smurphos
Level 15
Level 15
Posts: 5566
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Applications not using Theme in Linux Mint 19

Post by smurphos »

overkill22 wrote:
Mon Oct 01, 2018 9:28 pm
I'm not sure I understood what you mean
How did you install KeepassXC? In software manager there are two versions - The Flatpak (version 2.3.4) and the regular Ubuntu repo version (2.3.1).

Or you might have installed the appimage, added the official PPA or the snap version.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
overkill22
Level 4
Level 4
Posts: 402
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Applications not using Theme in Linux Mint 19

Post by overkill22 »

smurphos wrote:
Tue Oct 02, 2018 1:25 am
overkill22 wrote:
Mon Oct 01, 2018 9:28 pm
I'm not sure I understood what you mean
How did you install KeepassXC? In software manager there are two versions - The Flatpak (version 2.3.4) and the regular Ubuntu repo version (2.3.1).

Or you might have installed the appimage, added the official PPA or the snap version.
it is the flatpak version

User avatar
smurphos
Level 15
Level 15
Posts: 5566
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Applications not using Theme in Linux Mint 19

Post by smurphos »

overkill22 wrote:
Tue Oct 02, 2018 1:33 am
it is the flatpak version
Poor theme integration is a limitation of the flatpak packaging format.

Mint 19 you can switch to the regular software manager version although I'd recommend using the official PPA as set out below to ensure you are using an up to date version.

If you are using Mint 18.x or 19 you can add the projects official PPA to your software sources - see https://launchpad.net/~phoerious/+archi ... /keepassxc
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
overkill22
Level 4
Level 4
Posts: 402
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Applications not using Theme in Linux Mint 19

Post by overkill22 »

smurphos wrote:
Tue Oct 02, 2018 2:09 am
overkill22 wrote:
Tue Oct 02, 2018 1:33 am
it is the flatpak version
Poor theme integration is a limitation of the flatpak packaging format.

Mint 19 you can switch to the regular software manager version although I'd recommend using the official PPA as set out below to ensure you are using an up to date version.

If you are using Mint 18.x or 19 you can add the projects official PPA to your software sources - see https://launchpad.net/~phoerious/+archi ... /keepassxc
Is the software manager of mint 19 based on flatpak?
I'll try to get the apps through website or official ppa anyway.

User avatar
smurphos
Level 15
Level 15
Posts: 5566
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Applications not using Theme in Linux Mint 19

Post by smurphos »

overkill22 wrote:
Tue Oct 02, 2018 3:49 am
Is the software manager of mint 19 based on flatpak?
I'll try to get the apps through website or official ppa anyway.
Nope, not based on flatpak but it supports flatpak in addition to the standard apt/deb repositories - hence why some applications (including KeepassXC in Mint 19) have two listings in Software Manager. Synaptic on the other hand only lists standard apt/deb packages from the repos.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
deanr72
Level 3
Level 3
Posts: 160
Joined: Sat Mar 24, 2018 2:00 pm
Location: Poland

Re: Applications not using Theme in Linux Mint 19

Post by deanr72 »

I've just installed Google Chrome on a brand new install and I've got the same problem. As Chrome isn't available from the software centre...

UPDATE: This solved the Chrome problem:

https://www.youtube.com/watch?v=XZlYhWHHd7A

Post Reply

Return to “Software & Applications”