Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Questions about applications and software
Forum rules
Before you post please read how to get help
Locked
STonEDSTonE
Level 1
Level 1
Posts: 6
Joined: Wed Jul 11, 2018 5:18 pm

Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by STonEDSTonE »

Hi,

I am currently experimenting with Linux MInt 19 Cinnamon 64-Bit.
I found that the terminal is just plaintext (instead of the green user@system) and autocomplete works with normal programs rudimentarily (e.g. audaTAB produces audacity), but things like apt instTAB does not work, and apt install audaTAB does not work aswell.
Is there a way to get this features back?

greetings

STonE

STonEDSTonE
Level 1
Level 1
Posts: 6
Joined: Wed Jul 11, 2018 5:18 pm

Re: Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by STonEDSTonE »

I realised that it works on another machine, but not on my daily driver machine. I attatched two screenshots. Both are from different Machines but are both set up with a fresh LM19 Cinnamon 64-Bit.
without.jpg
with.jpg
I don't get why the behaviour is different. Is there a package missing for whatever reason?

ngiampaoli
Level 1
Level 1
Posts: 11
Joined: Tue Aug 11, 2015 12:17 pm

Re: Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by ngiampaoli »

I have exactly the same problem. Terminal without colors and command apt without autocomplete.
I did a fresh install of LinuxMint 19 and this problems appears. Before, I was updating from LM17.1 until 18.3 and everything went fine.

I also did a second fresh install from other usb drive, but the problem persist.

Can anyone help us with this problem, please?

all41
Level 16
Level 16
Posts: 6093
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by all41 »

On the terminal toolbar select Edit/Preferences.
Under the Colors tab you can select
libera ab tyrannis

ngiampaoli
Level 1
Level 1
Posts: 11
Joined: Tue Aug 11, 2015 12:17 pm

Re: Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by ngiampaoli »

all41 wrote:
Wed Aug 08, 2018 2:33 pm
On the terminal toolbar select Edit/Preferences.
Under the Colors tab you can select
It doesn't work.
I also installed guake terminal but the problem persist, so is some wrong configuration in the system.

Anything else to tried?

ngiampaoli
Level 1
Level 1
Posts: 11
Joined: Tue Aug 11, 2015 12:17 pm

Re: Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by ngiampaoli »

I SOLVE this problem.

Just run this command
cat /etc/skel/.bashrc >> $HOME/.bashrc

:D

fabiocasi
Level 1
Level 1
Posts: 16
Joined: Tue Sep 06, 2016 3:21 am

Re: Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by fabiocasi »

Hi All,
I have the same problem... on Mint 19!

Code: Select all

cat /etc/skel/.bashrc >> $HOME/.bashrc
IS NOT WORKING for me!

Someone has found the final solution???

User avatar
BG405
Level 8
Level 8
Posts: 2108
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by BG405 »

In ~/.bashrc, try uncommenting the force-color-prompt line:

Code: Select all

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
force_color_prompt=yes
Sorry don't know why autocomplete isn't working right; not tested Mint 19 yet myself.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Two ROMS don't make a write.

DrM
Level 2
Level 2
Posts: 91
Joined: Sun Feb 23, 2014 4:03 pm

Re: Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by DrM »

I don't like a monochrome terminal in Linux Mint 19.1 Xfce. It is just like MS-DOS or the default Dos box of Windows XP, which were monochrome terminals too. And different items in the terminal window aren't clearly distinctive when it's monochrome.

I edited the .bashrc file in /etc/skel by uncommenting the force-color-prompt line:

Code: Select all

force_color_prompt=yes
But it didn't help. Are there any other options to get rid of the monochrome terminal?

DrM
Level 2
Level 2
Posts: 91
Joined: Sun Feb 23, 2014 4:03 pm

Re: Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by DrM »

Problem solved. Uncomment the line "force_color_prompt=yes" in the .bashrc in the /etc/skel directory and copy that file to your home directory:

Code: Select all

 cp -v /etc/skel/.bashrc ~/

dld
Level 1
Level 1
Posts: 30
Joined: Sat Oct 29, 2011 4:12 pm

Re: Terminal without colors and less autocomplete in Linux Mint 19 Cinnamon

Post by dld »

Mint 19 MATE -- my fix was to add "TERM xterm-256color" to my .dircolors file. Took a long time. Don

Locked

Return to “Software & Applications”