[Solved] Compiing from source when a newer version is required

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Tuxkid
Level 1
Level 1
Posts: 31
Joined: Sun Nov 01, 2015 9:53 pm

[Solved] Compiing from source when a newer version is required

Post by Tuxkid » Fri Jul 20, 2018 5:26 am

I need GDAL version > 1.11.4 but the latest version in the Mint repo's newest version is 1.10.1. If I compile it from source, will that clash with anything else when it's not handled by the package manager?
Last edited by Tuxkid on Sat Jul 21, 2018 12:08 am, edited 1 time in total.

User avatar
xenopeek
Level 24
Level 24
Posts: 22660
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Compiing from source when a newer version is required

Post by xenopeek » Fri Jul 20, 2018 5:42 am

I take it you're using Linux Mint 17.x? Linux Mint 19 has gdal 2.2.3.

I doubt it will cause issues with other programs, unless you're using other "geospatial" programs that use gdal and those need it to be a specific older version. You would probably know that better than me.

In any case, to safely compile it from source replace any make install or sudo make install command in instructions for compiling it from source with sudo checkinstall. And first install checkinstall package. Checkinstall does the same thing as make install but first builds a package and then installs that package with your package manager, instead of just writing the files directly to your system directories with no care or decency as make install does. By using checkinstall your package manager will know you have gdal installed, which version, and what files belong to it. This means you can easily uninstall it if necessary and you won't have any file conflicts with your package manager as it knows about the files and which package owns them.
Image

Post Reply

Return to “Software & Applications”