[ SOLVED] Stellarium will not launch. Segfault issue [IGNORE]

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
tgwilt
Level 2
Level 2
Posts: 71
Joined: Fri Jun 08, 2018 2:26 am
Location: Florida, USA

[ SOLVED] Stellarium will not launch. Segfault issue [IGNORE]

Post by tgwilt » Fri Jul 20, 2018 11:59 am

Hello all,

I recently did a clean install of Mint 19 on my desktop. It no longer seems to be sluggish - good job developers. So, after restoring my homedir, I installed one of my favorite programs, Stellarium.

I can't launch it, and the logfile, /var/log/syslog shows the following:

Code: Select all

segfault at 7fa258018260 ip 00007fa241ce485c sp 00007fffdf462610 error 4 in libQt5Widgets.so.5.9.5[7fa2419fe000+616000
Here is the result of inxi -Fzz

Code: Select all

 System:    Host: HP-Compaq-dc7900 Kernel: 4.15.0-20-generic x86_64 bits: 64
           Desktop: Cinnamon 3.8.8  Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: Hewlett-Packard product: HP Compaq dc7900 Small Form Factor serial: N/A
           Mobo: Hewlett-Packard model: 3031h serial: N/A
           BIOS: Hewlett-Packard v: 786G1 v01.16 date: 03/05/2009
CPU:       Dual core Intel Core2 Duo E8400 (-MCP-) cache: 6144 KB
           clock speeds: max: 3000 MHz 1: 1994 MHz 2: 1994 MHz
Graphics:  Card: Intel 4 Series Integrated Graphics Controller
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1280x1024@60.02hz
           OpenGL: renderer: Mesa DRI Intel Q45/Q43 version: 2.1 Mesa 18.0.5
Audio:     Card Intel 82801JD/DO (ICH10 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-genericapter driver: rt2800usb
           IF: wlx9cefd5fd1def state: N/A mac: N/A
Drives:    HDD Total Size: 4000.8GB (5.1% used)
           ID-1: /dev/sda model: HITACHI_HUA72302 size: 2000.4GB
           ID-2: USB /dev/sdb model: FA_GoFlex_Desk size: 2000.4GB
Partition: ID-1: / size: 909G used: 19G (3%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 39.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 183 Uptime: 10 min Memory: 1299.0/7786.7MB
           Client: Shell (bash) inxi: 2.3.56 
I've searched for the segfault error, and the prevailing answer seems to be that the kde developers don't know what causes it. I've tried booting with different kernels. all 4.15 versions, but it keeps happening.

Has anyone else encountered this with a possible solution?

Thanks,

Tom
Network: Card-1: Intel 82567LM-3 Gigabit Network Connection driver: e1000e
Last edited by tgwilt on Fri Jul 20, 2018 12:08 pm, edited 1 time in total.

tgwilt
Level 2
Level 2
Posts: 71
Joined: Fri Jun 08, 2018 2:26 am
Location: Florida, USA

Re: Stellarium will not launch. Segfault issue

Post by tgwilt » Fri Jul 20, 2018 12:07 pm

Ignore this topic. I forgot that I had posted a similar request long ago. Recently downloaded the appimage file and it worked, although with warnings about the Open GL system. I can live with it.

Post Reply

Return to “Software & Applications”