Trouble with update manager

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
jorgenask
Level 1
Level 1
Posts: 23
Joined: Thu Mar 09, 2017 4:39 pm

Trouble with update manager

Post by jorgenask » Thu Jul 26, 2018 3:51 am

Hi guys!

Since yesterday I have gotten this message trying to refresh and check for updates:

"The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct."

and

"An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://repository.spotify.com stable InRelease: The following signatures were invalid: EXPKEYSIG EFDC8610341D9410 Spotify Public Repository Signing Key <tux@spotify.com>Failed to fetch http://repository.spotify.com/dists/stable/InRelease The following signatures were invalid: EXPKEYSIG EFDC8610341D9410 Spotify Public Repository Signing Key <tux@spotify.com>Some index files failed to download. They have been ignored, or old ones used instead."

This happens no matter which mirror I choose in software sources.

When I select a new mirror in software sources and click ok to update APT cache , I get this message:

"Failed to downdload repository information, check your internet connection"

This is strange as I do have internet connection.

Any ideas guys ?
Last edited by jorgenask on Thu Jul 26, 2018 8:06 am, edited 2 times in total.

jorgenask
Level 1
Level 1
Posts: 23
Joined: Thu Mar 09, 2017 4:39 pm

Re: Trouble with update manager

Post by jorgenask » Thu Jul 26, 2018 4:00 am

Update:

I booted the linux mint 19 usb stick just to see if I get the same error there and I did, so apparently nothing wrong with my install.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1832
Joined: Thu Jan 04, 2018 1:00 pm

Re: Trouble with update manager

Post by Sir Charles » Thu Jul 26, 2018 4:07 am

jorgenask wrote:
Thu Jul 26, 2018 3:51 am
GPG error: http://repository.spotify.com stable InRelease
Hi,

Seemingly, there is some issue at the moment at Spotify's end. Please see: viewtopic.php?f=90&t=274158

Cheers
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

jorgenask
Level 1
Level 1
Posts: 23
Joined: Thu Mar 09, 2017 4:39 pm

Re: Trouble with update manager

Post by jorgenask » Thu Jul 26, 2018 4:11 am

Thanks!

when I removed Spotify from repositories it works fine :)

User avatar
Sir Charles
Level 7
Level 7
Posts: 1832
Joined: Thu Jan 04, 2018 1:00 pm

Re: [SOLVED] Trouble with update manager

Post by Sir Charles » Thu Jul 26, 2018 4:18 am

I guess we would need to keep an eye on Spotify to see when the repository is back in order.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

jorgenask
Level 1
Level 1
Posts: 23
Joined: Thu Mar 09, 2017 4:39 pm

Re: [SOLVED] Trouble with update manager

Post by jorgenask » Thu Jul 26, 2018 8:06 am

No it seemes like its more than spotify creating issues, after I disabled updates for spotify it was fine for a while .. but now it is giving me a similar error message as before.

User avatar
Moem
Level 17
Level 17
Posts: 7017
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Trouble with update manager

Post by Moem » Thu Jul 26, 2018 8:27 am

Can we see the error message please?
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

expat_tony
Level 4
Level 4
Posts: 285
Joined: Thu Mar 27, 2014 6:52 pm

Re: Trouble with update manager

Post by expat_tony » Sun Sep 23, 2018 8:17 am

I'm having a similar issue currently.
Here's my error message...

GPG error: http://dl.google.com stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1397BC53640DB551Failed to fetch https://repo.skype.com/deb/dists/stable ... 4/Packages Hash Sum mismatch
Some index files failed to download. They have been ignored, or old ones used instead.


Having read links to other forums, I'm guessing that what happened with Spotify earlier this year has now happened with Skype.
Can anyone offer self-help advice, or do I have to wait for Skype (or Google???) to fix the repo?
Thanks for your time.

gm10
Level 12
Level 12
Posts: 4116
Joined: Thu Jun 21, 2018 5:11 pm

Re: Trouble with update manager

Post by gm10 » Sun Sep 23, 2018 9:19 am

expat_tony wrote:
Sun Sep 23, 2018 8:17 am
I'm having a similar issue currently.
Here's my error message...

GPG error: http://dl.google.com stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1397BC53640DB551Failed to fetch https://repo.skype.com/deb/dists/stable ... 4/Packages Hash Sum mismatch
Some index files failed to download. They have been ignored, or old ones used instead.


Having read links to other forums, I'm guessing that what happened with Spotify earlier this year has now happened with Skype.
Can anyone offer self-help advice, or do I have to wait for Skype (or Google???) to fix the repo?
Thanks for your time.
No, those are completely different issues, which is why the forum rules ask you to make your own thread for you own issues, otherwise things just get confusing.

The first error message is because you did not add the google repository correctly. Usually the software that needs it (Google Chrome?) sets it up correctly for you, so I suggest you didn't correctly install that, either. You should just remove that repo and reinstall the software. Otherwise see https://www.google.com/linuxrepositories/.

The second issue can happen if you try to use the repo just when it updates. Simply try again later. It's nothing you can resolve on your end, the issue is with the repository.

Post Reply

Return to “Software & Applications”