LM19 - missing packages

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Zurd
Level 1
Level 1
Posts: 34
Joined: Wed Feb 27, 2013 8:46 am

LM19 - missing packages

Post by Zurd » Sun Aug 05, 2018 12:35 pm

Hi, I just installed Linux Mint 19 and I'm now missing packages. Where can I find pdftk, libav-tools (for avconv) and network-manager-sstp-gnome ?

In 18.3, they were all easily installed with apt install. Why would they be removed?

User avatar
xenopeek
Level 24
Level 24
Posts: 22908
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: LM19 - missing packages

Post by xenopeek » Sun Aug 05, 2018 1:29 pm

pdftk and libav-tools come from the Ubuntu 18.04 (aka "bionic") universe repository. Packages in universe are maintained by the community (not Canonical) and usually just imported from Debian testing or unstable. Often you can find answers to such questions by searching the Internet for "ubuntu 18.04 packagename removed" (Ubuntu 18.04 is the package base for Linux Mint 19.x).

For pdftk that gives a quick answer:
https://ubuntuforums.org/showthread.php?t=2390293

For libav-tools I can't find a definitive answer other than that it was removed from Debian testing:
https://bugs.debian.org/cgi-bin/bugrepo ... bug=873182

I'd advice against trying to install pdftk or libav-tools packages from an earlier release as there are often security issues in programs handling PDF and multimedia files. You don't want to use such programs without getting updates for them. What functionality do you need of these packages? There are likely alternatives that are supported.

As for network-manager-sstp-gnome, there is no such package found in Linux Mint or Ubuntu (or Debian) repositories. I think you would've added this PPA to your system in the past to be able to install that package:
https://launchpad.net/~eivnaes/+archive ... ter=bionic
Image

Zurd
Level 1
Level 1
Posts: 34
Joined: Wed Feb 27, 2013 8:46 am

Re: LM19 - missing packages

Post by Zurd » Sun Aug 05, 2018 5:00 pm

Thanks, this is great information!

With pdftk, it was for merging pdf files. Indeed, there's probably some other tool that will do the same job. I can find this.

Like you said, I probably installed a PPA for network-manager-sstp before without writing it down. I was able to re-install it without problem.

But for libav-tools, I really need avconv, what do you guys use? I thought ffmpeg was dead?!

gm10
Level 10
Level 10
Posts: 3460
Joined: Thu Jun 21, 2018 5:11 pm

Re: LM19 - missing packages

Post by gm10 » Sun Aug 05, 2018 5:39 pm

Zurd wrote:
Sun Aug 05, 2018 5:00 pm
But for libav-tools, I really need avconv, what do you guys use? I thought ffmpeg was dead?!
ffmpeg is under active development. and it is indeed the replacement Debian/Ubuntu suggest for avconv. From the libav-tools description:

Code: Select all

 This is a transitional package that provides the following links:
  * avconv -> ffmpeg
  * avplay -> ffplay
  * avprobe -> ffprobe

Zurd
Level 1
Level 1
Posts: 34
Joined: Wed Feb 27, 2013 8:46 am

Re: LM19 - missing packages

Post by Zurd » Mon Aug 06, 2018 1:31 pm

I found pdfunite to replace pdftk, as easy to use also:

Code: Select all

pdfunite in1.pdf in2.pdf in3.pdf out.pdf
I will go back to ffmpeg instead of avconv, it's confusing what happened to these projects. Fortunately, they're pretty much the same so all my avconv commands I saved will work with ffmpeg.

Thanks a lot for your help, everything's solved! :)

mscroggi
Level 1
Level 1
Posts: 4
Joined: Wed Sep 21, 2016 1:31 pm

Re: LM19 - missing packages

Post by mscroggi » Wed Sep 19, 2018 8:09 am

gm10 wrote:
Sun Aug 05, 2018 5:39 pm
Zurd wrote:
Sun Aug 05, 2018 5:00 pm
But for libav-tools, I really need avconv, what do you guys use? I thought ffmpeg was dead?!
ffmpeg is under active development. and it is indeed the replacement Debian/Ubuntu suggest for avconv. From the libav-tools description:
AH! Thanks for that info.. I too was looking for the avconv package because in the past the point was made that avconv was the replacement for ffmpeg.

The nice thing is, I only needed to replace avonv with ffmpeg in my scripts and they ran as-is

Post Reply

Return to “Software & Applications”