Opera Can't Run Facebook Videos

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Opera Can't Run Facebook Videos

Post by johnywhy » Sun Aug 12, 2018 1:20 am

I can play Youtube videos no-problem.
Adobe test page says:
Congratulations, your computer has the latest Flash Player installed.
https://helpx.adobe.com/flash-player.html

On facebook, i can see the player-- looks normal. If i click play-button, i get video-spinner.
But after video-wait spins for a few seconds, video returns to stopped mode.

any ideas?

THX
Mint 19 xfce. Semi-noob

emjaycee
Level 1
Level 1
Posts: 4
Joined: Sun Jul 01, 2018 7:47 am

Re: Opera Can't Run Facebook Videos

Post by emjaycee » Sun Aug 12, 2018 4:06 am

Not sure if it's going to help or not, but the 'Opera' I had to end up installing was the 'Ubuntu snap' Opera. I've just checked some online Facebook videos in my area of interest (dog agility) and they all worked just fine. When I had the 'standard' Opera, I couldn't watch my online AFL (football) clips at all. It kept coming up with a message 'plug-in blocked' or something similar up in the top right hand corner in the address bar where the Opera 'heart' is located. This may or may not be useful information for you, but good luck :)

Cheers
Michael

gm10
Level 9
Level 9
Posts: 2704
Joined: Thu Jun 21, 2018 5:11 pm

Re: Opera Can't Run Facebook Videos

Post by gm10 » Sun Aug 12, 2018 4:27 am

Opera blocks flash by default for security reasons. You can unblock it on a case by case basis or define an exception in the settings. Or just remove flash, it's cancer, anyway. It's 2018. We've got HTML5.

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: Opera Can't Run Facebook Videos

Post by johnywhy » Sun Aug 12, 2018 11:48 am

gm10 wrote:
Sun Aug 12, 2018 4:27 am
Opera blocks flash by default for security reasons. You can unblock it on a case by case basis or define an exception in the settings. Or just remove flash, it's cancer, anyway. It's 2018. We've got HTML5.
Great! I uninstalled flash (had tried both pepper and the 'nonfree' version-- neither helped FB videos.

But i see no difference after removing flash. Images show what i'm seeing
emjaycee wrote:
Sun Aug 12, 2018 4:06 am
the 'Opera' I had to end up installing was the 'Ubuntu snap' Opera.
i didn't like snap, it seems to install packages in it's own managed, isolated area instead of installing like any other package. Snap infrastructure seems to consume a lot of disk-space and RAM (even when not running any snap apps). i'm on a resource-limited machine, so I removed snap completely.
When I had the 'standard' Opera, It kept coming up with a message 'plug-in blocked' or something similar up in the top right hand corner
i'm not seeing plugin-blocked.

Before clicking play:
operaBeforePlay.jpg
After clicking play:
operaAfterPlay.jpg
THX
Mint 19 xfce. Semi-noob

User avatar
administrollaattori
Level 14
Level 14
Posts: 5158
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Opera Can't Run Facebook Videos

Post by administrollaattori » Sun Aug 12, 2018 1:54 pm

Code: Select all

dpkg --get-selections | grep flash

Code: Select all

apt-cache policy adobe-flashplugin

gm10
Level 9
Level 9
Posts: 2704
Joined: Thu Jun 21, 2018 5:11 pm

Re: Opera Can't Run Facebook Videos

Post by gm10 » Sun Aug 12, 2018 2:03 pm

johnywhy wrote:
Sun Aug 12, 2018 11:48 am

Before clicking play:
operaBeforePlay.jpg

After clicking play:
operaAfterPlay.jpg

THX
Got a link? Based on that picture I assumed https://www.facebook.com/cnn/ and my Opera plays the video at the top just fine, and I don't have flash installed. You might be missing the h264 codec. apt install chromium-codecs-ffmpeg-extra

User avatar
administrollaattori
Level 14
Level 14
Posts: 5158
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Opera Can't Run Facebook Videos

Post by administrollaattori » Sun Aug 12, 2018 2:11 pm

gm10 wrote:
Sun Aug 12, 2018 2:03 pm
Got a link? Based on that picture I assumed https://www.facebook.com/cnn/ and my Opera plays the video at the top just fine, and I don't have flash installed. You might be missing the h264 codec. apt install chromium-codecs-ffmpeg-extra
I tested that link, and so that videos are working, adblocker need to be disabled.
cnn.jpg

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: Opera Can't Run Facebook Videos

Post by johnywhy » Fri Aug 17, 2018 8:26 pm

i get

Code: Select all

$ dpkg -l | grep chromium-codecs-ffmpeg-extra
ii  chromium-codecs-ffmpeg-extra               68.0.3440.75-0ubuntu0.18.04.1       amd64        Extra ffmpeg codecs for the Chromium Browser
i don't have flash installed.

problem happens with any facebook video.
Mint 19 xfce. Semi-noob

Post Reply

Return to “Software & Applications”