Hamsphere 3/4 and Mint 19

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Leo1030
Level 1
Level 1
Posts: 5
Joined: Tue Aug 14, 2018 7:38 am

Hamsphere 3/4 and Mint 19

Post by Leo1030 » Tue Aug 14, 2018 7:57 am

Hello is here someone using Hamsphere 3 and Hamsphere 4 using Linux Mint 19 Tara?
I can't install it.

Please help.

Greating,

Leo PA0CVE
Last edited by Leo1030 on Tue Aug 14, 2018 8:11 am, edited 1 time in total.

User avatar
Pierre
Level 17
Level 17
Posts: 7298
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Hamsphere 3/4 and Mint 19

Post by Pierre » Tue Aug 14, 2018 8:08 am

Hi Leo,
there is a Number of Ham's on this Forum.,
as Linux is a quite popular alternative to the Windows system.

what do you know about the Hamsphere software ?
- it does seem to be quite propriety in it's nature.
it seems to come as an archive, that needs to be extracted, and then Run with it's executable files,
& this is where some folk do have issues, in getting this sort of Linux software to work,
as it is not as simple as running an EXE like you would do, on the Windows System.

but, there is already some alternatives available, similar to what that program seems to be doing:
echolink.org
is one such program.

73s,
Pierre
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Leo1030
Level 1
Level 1
Posts: 5
Joined: Tue Aug 14, 2018 7:38 am

Re: Hamsphere 3/4 and Mint 19

Post by Leo1030 » Tue Aug 14, 2018 8:16 am

Hello Pierre,

I am using Hamsphere with windows 7 now more then 2 years.
Is a nice alternative for the real radio.
You have to pay every year for using it.

http://www.hamsphere.com/
http://www.hamsphere4.com/

Now I want to use Hamsphere on my Linux Laptop.

73 de Leo PA0CVE

User avatar
Pierre
Level 17
Level 17
Posts: 7298
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Hamsphere 3/4 and Mint 19

Post by Pierre » Tue Aug 14, 2018 8:22 am

5. Linux or Mac: JAR files are Java runtime executable files.
Never unzip the jar-file even if suggested.
- Save the jar file intact somewhere on your computer, like the desktop and right click "open with" Java (TM) platform binary.

6. Linux: Save the jar file as hamsphere.jar in your home directory.
Open a root terminal window and execute java -jar hamsphere.jar


so, can you get as far as step 6?. - - what failed ?.
& did you manage to mark the 'hamsphere.jar ' as an executable ?.

an little more research on this program, does reveal, over on eHam, that it is quite doable on Linux.
8)
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Leo1030
Level 1
Level 1
Posts: 5
Joined: Tue Aug 14, 2018 7:38 am

Re: Hamsphere 3/4 and Mint 19

Post by Leo1030 » Tue Aug 14, 2018 8:46 am

I have instaled it and use +x filename to make executable.
But when I start the HamSphere_3.1.5.jar or hamSphere_4.010 nothing happens.

User avatar
Pierre
Level 17
Level 17
Posts: 7298
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Hamsphere 3/4 and Mint 19

Post by Pierre » Tue Aug 14, 2018 8:54 am

you did the "open with" Java thing ?.

can you open an Terminal - in the directory where the program is located,,
and then type in the "open with" Java command - - and copy any errors - back here, on your next post.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Leo1030
Level 1
Level 1
Posts: 5
Joined: Tue Aug 14, 2018 7:38 am

Re: Hamsphere 3/4 and Mint 19

Post by Leo1030 » Tue Aug 14, 2018 9:00 am

This is the mess.
Can not obtain file descriptor that refers to the console

I am using Gnome Terminal

User avatar
Pierre
Level 17
Level 17
Posts: 7298
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Hamsphere 3/4 and Mint 19

Post by Pierre » Tue Aug 14, 2018 9:38 am

you may not have the JRE files installed (Java Runtime Environment)
https://tecadmin.net/install-oracle-jav ... u-via-ppa/
uses a PPA to install those JRE files

this is where most users can fall over,
- - those JRE files from Oracle come as a *.tar.gz & which is an archive file,
which you then have to extract & then run an executable - which is not that easy.

then, you have to download the Hamsphere program, also as a *.tar.gz & which is an archive file,
which you then have to extract & then run an executable, again .. ..

this is not exactly easy, even for the more experienced Linux Users,,
- let alone for some Linux Newbie to do.
after that, you may then have an issue with your firewall, blocking the program, from using the Internet.
:(
so, I've gotten part way though, all that lot, and I've still got some issues, in getting the Hamsphere program - to run.
:roll:
NB: the Windows version, does seem to work using ./wine - Unsurprisingly.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Leo1030
Level 1
Level 1
Posts: 5
Joined: Tue Aug 14, 2018 7:38 am

Re: Hamsphere 3/4 and Mint 19

Post by Leo1030 » Wed Aug 15, 2018 6:38 am

Pierre tnx for the info, HS3 is now ok.

Next step is HS4.


I will let you know.

73 de Leo PA0CVE

Post Reply

Return to “Software & Applications”